Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-05-2006, 02:11 PM   #1
Erexxx
Scooby Specialist
 
Member#: 92054
Join Date: Jul 2005
Chapter/Region: SCIC
Location: Aliso Viejo
Vehicle:
2008 Mazdaspeed 3
Cosmic Blue Mica

Default Does Clunking Front swaybar = not doing its job?

So I've read a few posts about clunking sway bars etc, and well I just installed my whiteline FSB w/ noltec endlinks and it clunks every now and then at low speeds.

I was just wondering is this just an annoyance or can this actually yield negative performance out of the sway bar?
* Registered users of the site do not see these ads.
Erexxx is offline   Reply With Quote
Old 04-05-2006, 06:08 PM   #2
Erexxx
Scooby Specialist
 
Member#: 92054
Join Date: Jul 2005
Chapter/Region: SCIC
Location: Aliso Viejo
Vehicle:
2008 Mazdaspeed 3
Cosmic Blue Mica

Default

Any one?
Erexxx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how well does the oem fuel filter do its job? subynation Newbies & FAQs 14 04-17-2010 11:01 PM
FAA failing to do its job? Indocti Discant Off-Topic 58 07-14-2009 07:34 AM
Stage 2,... doing its job jmlaser Proven Power Bragging 9 10-06-2007 09:04 PM
radiator not doing its job! captianmo999 Service & Maintenance 3 08-29-2007 09:41 PM
Vid of my Escort Passport 8500 x50 doing its job GHST Car Audio, Video & Security 18 01-14-2006 08:12 AM


All times are GMT -4. The time now is 10:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.