Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-03-2001, 12:58 AM   #1
NateDogg
Scooby Specialist
 
Member#: 6467
Join Date: May 2001
Location: philadelphia, pa, usa
Vehicle:
1999 Impreza 2.5 RS
silver

Exclamation MAF question.....need help

i was thinking to myself after swaping my 2nd MAF, why dont i take it apart and see what connection broke? and solder it back together? does anyone know if someone has tried this before? also has anyone tried putting a WRX MAF onto a 2.5RS? if the plug fits it should work, kinda sorta. if anyone knows anything about this please met me know what you think.

thanks,
Nate
* Registered users of the site do not see these ads.
NateDogg is offline   Reply With Quote
Old 10-03-2001, 11:04 AM   #2
RallyNavvie
Scooby Specialist
 
Member#: 7113
Join Date: Jun 2001
Chapter/Region: TXIC
Location: Minnesotan in Texas
Vehicle:
2008 Spec B
DGM

Default haha, try and open it without destroying it

Thos MAF sensors are built like safes. Besides, the 99 RS has a hotfilm MAF so there aren't any wires to be sodering back together. Someone did crack one open to show what they look like after they're blown but I can't remember the link to that. You may have to search for it. Also you may want to tyr my silly little trick on getting a broken MAF to work again, however it requires the faulty MAF to be back in your car again. Do a search, I just posted it a couple days ago. If it doesn't work then no harm done other than having to reset the ECU again when you put the new one back in, but if it does work then we know to do some more research on why such a trick works to get the little bugger working again.

~Garrett
RallyNavvie is offline   Reply With Quote
Old 10-03-2001, 11:38 AM   #3
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

Would an older MAF work? I have a 93 MAF I'm willing to part with...

Chad
93 1.8T
subachad is offline   Reply With Quote
Old 10-03-2001, 08:03 PM   #4
NateDogg
Scooby Specialist
 
Member#: 6467
Join Date: May 2001
Location: philadelphia, pa, usa
Vehicle:
1999 Impreza 2.5 RS
silver

Default

i dont know if an older MAF would work, i would like to try it, however does the 93 maf suffer from the same problems as the 99? also i think the ecu adapts to the maf, looking at my 1st one (orginal) it has 5 prongs for the plug the new one only has 4. and when i pluged it in the car still ran like **** untill i reset the ecu, but when ive swaped MAFs before i didnt have to do i reset.(on other RS's) what gave me this idea was my freind who is a toyota tech, he also owns a WRX and he told me the MAF from an wrx and a toyota avalon are the same part! so who knows maybe out there somewhere is a maf that will work. hey it doesnt hurt to try.

ralli,
i know about that cuzfor the longest time my car would run like drap on and off, it was weird. the maf goes good then bad then good the bad ntill in finally dies 100%

Nate

Last edited by NateDogg; 10-03-2001 at 08:14 PM.
NateDogg is offline   Reply With Quote
Old 10-04-2001, 03:00 AM   #5
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

I don't know if it fits, but I seriously doubt it has any issues that the 99 MAF does.

It's a wire, not the film type. I've got 40,000 turbo miles and a Weapon-R cone filter. That's like 2 negatives working against the MAF and it still works fine.

Chad
93 1.8T
subachad is offline   Reply With Quote
Old 10-05-2001, 12:04 AM   #6
NateDogg
Scooby Specialist
 
Member#: 6467
Join Date: May 2001
Location: philadelphia, pa, usa
Vehicle:
1999 Impreza 2.5 RS
silver

Default

what do you want for that other MAF? i want to try it out.

Nate
NateDogg is offline   Reply With Quote
Old 10-05-2001, 12:13 AM   #7
tom@kartboy
NASIOC Vendor
 
Member#: 67
Join Date: Jul 1999
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
1999 Outlasting
the competition.

Default

98and earlier has a HOT WIRE
the 99 has a HOT FILM
they are not interchangable
tom@kartboy.com
do what i did and get a tec-2. 4 maf's later you could have paid for the tec-2
tom@kartboy is offline   Reply With Quote
Old 10-05-2001, 12:23 AM   #8
NateDogg
Scooby Specialist
 
Member#: 6467
Join Date: May 2001
Location: philadelphia, pa, usa
Vehicle:
1999 Impreza 2.5 RS
silver

Default

i would love to get a tec 2 but A i dont feel like having to tune it everytime it gets cold/hot. and B im a 19 year ols college student i dont have the time OR the money for a tec 2.

Nate
NateDogg is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cusco coilover question - need help alfriedesq Brakes, Steering & Suspension 7 10-29-2001 02:18 PM
UR Pulley questions, Need help quick ATX25RS Transmission (AT/MT) & Driveline 7 10-19-2001 03:30 AM
more 2.5 RS-T conversion questions.. need help ASAP STiTuner Normally Aspirated with bolt-on Forced Induction Powertrain 2 07-02-2001 06:45 AM
A question. Need Help!!!!! ADIL Legacy Forum 0 01-06-2000 11:55 AM


All times are GMT -4. The time now is 03:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.