Welcome to the North American Subaru Impreza Owners Club Wednesday July 9, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > UTEC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-15-2006, 03:06 PM   #1
KitchenerWRX
Scooby Specialist
 
Member#: 79934
Join Date: Jan 2005
Chapter/Region: E. Canada
Location: Kitchener, Ontario
Vehicle:
02 WRX
MBP

Default USB to serial adapter - won't connect?

Hey I have a laptop that won't allow me to plug the serial cable to i got a usb-serial adapter and plugged the USB side into the laptop...now my question is, when it comes to selecting which "COM" port, it doesnt give me the option for COM1 (im guessing its because i dont have a port to connect to since its USB?)...it gives me 3 options.

my question is, since im no computer expert at all - which "connection" should i select from the 3?
1. COM3
2. TCP/IP (Winsock)
3. some data fax voice modem one

any help would be appreciated, thanks.
* Registered users of the site do not see these ads.
KitchenerWRX is offline   Reply With Quote
Old 04-15-2006, 03:20 PM   #2
AaronWRX
Scooby Specialist
 
Member#: 7194
Join Date: Jun 2001
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2011 997.2 Turbo
Black

Default

COM1 is probably already in use. Select Com3. Then go into hyperterminal.. start a new connecion and choose com3. 19200 8N1
AaronWRX is offline   Reply With Quote
Old 04-16-2006, 04:53 PM   #3
KitchenerWRX
Scooby Specialist
 
Member#: 79934
Join Date: Jan 2005
Chapter/Region: E. Canada
Location: Kitchener, Ontario
Vehicle:
02 WRX
MBP

Default

it still didnt work even with com3...did directly as the manual said, pressed enter a few times like others mentioned to do

does it matter which usb port i plug it in since there is like 3-4 on this laptop??
KitchenerWRX is offline   Reply With Quote
Old 04-16-2006, 05:04 PM   #4
Peeblesmx445
Scooby Specialist
 
Member#: 92202
Join Date: Jul 2005
Location: Reno, NV
Vehicle:
2002 WRX
WRB

Default

Did you install the software that the adapter came with? I had a similar problem. Sometimes these adapters arnt just plug and play. Depending on the computer, sometimes you have to load/update the drivers off the software
Peeblesmx445 is offline   Reply With Quote
Old 04-17-2006, 01:14 PM   #5
Freon
Scooby Specialist
 
Member#: 88322
Join Date: Jun 2005
Chapter/Region: MWSOC
Location: Indianapolis, IN
Vehicle:
2009 BMW 135i

Default

If you are running Windows 2000 you almost certainly need to install drivers. You should have a disk included with your adapter or you can go download one.

When you first plug in the device it should prompt you to install it. XP is more likely to used a "canned" driver that XP came with. Just click next over and over until it says "successfully installed" or "failed to install". BUT YOU HAVE TO READ WHAT IT SAYS. People love to just click next on installs and not pay any attention on the last screen when it says "failed to installed"... XP may also just install it in the background and be done without even prompting, but you should see the little "usb device" icon in your system tray next to the clock at least.

BEST WAY TO FIGURE THIS OUT:

Check device manager and see if you see a COM port appear and disappear as you plug your adapter in and remove it. See if you have any items in device manager that have a yellow exclamation point on the icon. Like "Unknown device" or "Unknown USB port" or "Unknown serial port adapter". If you see anything like that, you need to double click it and click "reinstall drivers" or "update drivers". From there stick your driver disk in or browse for the drivers you downloaded.

I'll see if I can put up pictures later. A lot of people struggle with this... It isn't hard, but you may need to know some basics of installing a hardware device on a Windows computer.


Last edited by Freon; 04-22-2006 at 10:12 PM.
Freon is offline   Reply With Quote
Old 04-17-2006, 06:15 PM   #6
KitchenerWRX
Scooby Specialist
 
Member#: 79934
Join Date: Jan 2005
Chapter/Region: E. Canada
Location: Kitchener, Ontario
Vehicle:
02 WRX
MBP

Default

Thanks Freon that definately made it all clear to me, the problem now is that I just grabbed the adapter from one of my buddies and I don't even think he had an isntallation CD? So when I plug my adapter in the USB port I get the message to install new hardware, but I cannot because either I don't have the disk or the computer cannot find hardware to suit it.

So what are my options now? I dont even know what brand the adapter is. Is there some sort of "universal" usb adapter installation hardware that is downloadable on the internet??
KitchenerWRX is offline   Reply With Quote
Old 04-17-2006, 06:49 PM   #7
AaronWRX
Scooby Specialist
 
Member#: 7194
Join Date: Jun 2001
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2011 997.2 Turbo
Black

Default

Wirelessly posted (xv6700 EVDO: Mozilla/4.0 (compatible; MSIE 4.01; Windows CE; PPC; 240x320))

A while back someone posted a link to radioshack.com usb2serial drivers that seemed to work better then the oem driver. if i wasn't on my cell i could find them for you but search round on radioshack.com. i'm sure you cand find them there.
AaronWRX is offline   Reply With Quote
Old 04-20-2006, 09:34 PM   #8
Strng1dah
Scooby Newbie
 
Member#: 7053
Join Date: May 2001
Chapter/Region: BAIC
Location: Sacramento, CA
Vehicle:
2002 WRX
13.1@104

Default

witht he adaptor i'm using the initial screen that the utec displays is always blank. I have to hit "e" and then the display starts. Enter does nothing.
Strng1dah is offline   Reply With Quote
Old 04-22-2006, 10:14 PM   #9
Freon
Scooby Specialist
 
Member#: 88322
Join Date: Jun 2005
Chapter/Region: MWSOC
Location: Indianapolis, IN
Vehicle:
2009 BMW 135i

Default

Well if you don't know the brand and don't have a disk, you can't install it. I guess you can try the radioshack driver and hope you get lucky. If their adapter and your adapter use the same IC, it might work.

If it doesn't work, go buy a new one. I use a Sabrent adapter I got off Newegg.com for $9.95 and it works fine. Comes with a disk, and Sabrent keeps all the drivers on their website. It's not like they're expensive...
Freon is offline   Reply With Quote
Old 04-22-2006, 10:53 PM   #10
sidewayz
Scooby Specialist
 
Member#: 5810
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Easton PA
Vehicle:
2001 S366 2.5RS

Default

just buy a new one. I did. the thing was only $25 at staples
sidewayz is offline   Reply With Quote
Old 04-23-2006, 02:25 AM   #11
plus plus plus
Scooby Newbie
 
Member#: 102013
Join Date: Dec 2005
Location: OK
Vehicle:
2002 WRX

Default

yo,

along the same lines, I am trying to run data from the turbo xs wideband gen 2 reg. tuner into my laptop using the utec interface and serial to usb adapter cord.

I have downloaded the devices and everything is working properly in The device manager, however in hyperterminal my com ports only show 1-4.

My device is hooked into COM 5....how do I chose COM 5 for detection or make a change from com5 to say com 3 or 4 which does show as a COM port option in the hyperterminal.

PS. The device radio shack cd does not allow me to change the COM configuration in the installation process. This Sucks.......
plus plus plus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
USB to Serial Adapter for V1 to PC joec wrx AccessPort 9 02-28-2009 04:55 PM
USB to Serial port adapter 904scooby Engine Management & Tuning 6 09-16-2007 01:59 AM
Computer -> PCMCIA USB card -> USB to serial -> AP PJC1909 AccessPort 2 07-24-2006 12:39 AM
USB to Serial Converter roybfr Engine Management & Tuning 35 06-01-2005 03:26 PM
i need help boys and girls. usb to serial cable? Tobey Engine Management & Tuning 12 04-01-2003 05:44 PM


All times are GMT -4. The time now is 08:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.