Welcome to the North American Subaru Impreza Owners Club Monday May 4, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-14-2006, 01:48 PM   #1
Rdwrc
Scooby Newbie
 
Member#: 112552
Join Date: Apr 2006
Chapter/Region: Tri-State
Location: phily
Vehicle:
98 RS-WRX
RED

Default RS to Wrx swap speedo problem

Have 98 RS , have done '05 WRX swap, everything works except for speedo. Can someone help? A 98 RS DASH AND BULK HEAD HARNESS ,WIT A 05 WRX MOTOR TRANS DIFF TANK ECU AND MOTOR HARNESS ,EVERYTHING WORKS WELL EXEPT SPEDO IN DASH ,AND IF I CONECT 05 WRX SPEED SENSOR WIRE TO MY 98 CLUSTER .IGET A LOW SIGNAL SPEED SENSOR CELL LIGHT CODE .ANY HELP WILL BE AWSOME
* Registered users of the site do not see these ads.

Last edited by Rdwrc; 04-14-2006 at 05:37 PM.
Rdwrc is offline   Reply With Quote
Old 04-14-2006, 03:21 PM   #2
tcard
Scooby Newbie
 
Member#: 80459
Join Date: Jan 2005
Location: F-town
Vehicle:
2000 impreza 6MT
DCCD silver

Default

what exactly did you swap? everything, you swapped a tranny and motor into a 98rs harness? or did you swap in the new harness also? lemme know and i can try to help
tcard is offline   Reply With Quote
Old 04-14-2006, 05:25 PM   #3
tweakling
Scooby Newbie
 
Member#: 33072
Join Date: Feb 2003
Chapter/Region: MAIC
Location: Centreville, VA
Vehicle:
'95 EJ20g v1 STI RA
BRP, 2001 GC8 chassis

Default

the more details you provide, the better everyone here will be able to help you out. hook us up with some more info.
tweakling is offline   Reply With Quote
Old 04-14-2006, 06:05 PM   #4
Matt Monson
Scooby Guru
 
Member#: 832
Join Date: Jan 2000
Chapter/Region: RMIC
Location: Teh Ghetto Garage, CO
Vehicle:
99 2.5RS, '85 911
'73 914 and 2012 BRZ

Default

typing a yelled response to questions looking for more info generally gets your thread ignored...
Matt Monson is offline   Reply With Quote
Old 04-14-2006, 08:11 PM   #5
JeremyRS
Scooby Specialist
 
Member#: 65126
Join Date: Jun 2004
Chapter/Region: NESIC
Location: Manchester NH
Vehicle:
00 Leggy Wagon
99 Silverado, 06 HD

Default

You need to check the wire that you spliced in for the speedo. The rs wire is LG I believe, but anyway check it to see if you spliced the right wire.
JeremyRS is offline   Reply With Quote
Old 04-14-2006, 09:35 PM   #6
FF2
Scooby Newbie
 
Member#: 63453
Join Date: Jun 2004
Chapter/Region: MWSOC
Location: Chicago, IL
Vehicle:
1998 Impreza 2.5RS
Black

Default

In a 98 cluster, pin A1 (white) is your speed sensor + and pin A3 (black) is your speed sensor -.
FF2 is offline   Reply With Quote
Old 07-24-2006, 04:36 PM   #7
jamesfacts
Scooby Guru
 
Member#: 51282
Join Date: Dec 2003
Chapter/Region: Tri-State
Location: Brooklyn NYC
Vehicle:
98 RS
black & blue from parking

Default

You need to use your '98 speed sensor...
jamesfacts is offline   Reply With Quote
Old 07-24-2006, 04:53 PM   #8
TwoFive
Scooby Newbie
 
Member#: 72511
Join Date: Oct 2004
Chapter/Region: RMIC
Location: Aspen, CO
Vehicle:
08 Acura RDX
Black

Default

Quote:
Originally Posted by Rdwrc
Have 98 RS , have done '05 WRX swap, everything works except for speedo. Can someone help? A 98 RS DASH AND BULK HEAD HARNESS ,WIT A 05 WRX MOTOR TRANS DIFF TANK ECU AND MOTOR HARNESS ,EVERYTHING WORKS WELL EXEPT SPEDO IN DASH ,AND IF I CONECT 05 WRX SPEED SENSOR WIRE TO MY 98 CLUSTER .IGET A LOW SIGNAL SPEED SENSOR CELL LIGHT CODE .ANY HELP WILL BE AWSOME
No, it will not work at all. I have just gone through this myself and have succesfuly got my speedo working. I have a 98 as well with a 2002 WRX swap. On 1998, the cluste uses a computer in the cluster to figure out the speed, the way the speed sensor is wired on the 98 uses three wires to the cluster, where as 99+ on uses a single wire. The other two wires A1&A3 will not be hooked up to anything, there for you will need to use a cluster calling for only a single wire, You need to use a WRX speed sensor and harness as well. Then you will need either a 99+ cluster from an RS or WRX. Then on pins A1 & A3 on the 98 cluster will not be used and A2 (Speed Sensor Signal form ECU) will be used on the RS cluster (PIN C10) You will need to completely repin the harness but it isnt hard. I have the wiring diagrams if you want them, just PM me if you have questions. But the speedometer works flawlessly on mine with no jumping/inconsistancy on the gauge itself.

Here is my thread where no one helped me figure out what was wrong, as well as other threads of note.

http://forums.nasioc.com/forums/show...t=speed+sensor
http://www.rs25.com/forums/showthrea...iagram+cluster
TwoFive is offline   Reply With Quote
Old 07-26-2006, 11:36 AM   #9
Rdwrc
Scooby Newbie
 
Member#: 112552
Join Date: Apr 2006
Chapter/Region: Tri-State
Location: phily
Vehicle:
98 RS-WRX
RED

Default

Thanx Much I Will Give That A Try
Rdwrc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Idea: Anyone help with mechanicals for rs to wrx swap? greddy18 New England Impreza Club Forum -- NESIC 3 03-18-2008 08:13 PM
RS to WRX swap xjordanx Electrical & Lighting 0 09-09-2006 02:43 PM
Have some ??'s on doing the rs to wrx swap yukon1 Alaskan Impreza Club Forum -- AKIC 20 05-27-2005 01:03 AM
rs to wrx swap civic1260 Mid Atlantic Impreza Club -- MAIC 13 11-08-2004 06:05 PM
S.E. RS to WRX swaps bluimpreza00 South East Region Forum 5 04-08-2003 08:43 AM


All times are GMT -4. The time now is 12:05 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.