Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-23-2006, 10:23 AM   #1
BVM
Scooby Specialist
 
Member#: 41049
Join Date: Aug 2003
Chapter/Region: South East
Location: Panama City FL (Tyndall AFB)
Vehicle:
2010 Impreza WRX
KTM 250sx

Default Bye bye SR30, hello FPEVO316g!

Well after having some nightmare problems with my APS S/R30 turbo I decided to replace it with what I was going to buy in the first place.
2 weeks ago I placed an order for the Forced Performance EV03, ported big 16g. Unfortunately its on a 3 week back order! Oh well at least they told me that up front.

Why remove a $1,800 APS ball bearing turbo for a $900 mitsu turbo you say? Well here is my story:

A few months ago I called up Jerry (the man!) @ Deabolt to buy a turbo. He said he would make me a good deal on the APS turbo. True to his word I got this slightly used turbo for a bargain. No, I mean a steal! Received it promptly and installed the turbo on my '02 WRX. The turbo did not want to make more than 12psi of boost and really wasn't interested till about 4k rpm! EBC or MBC nothing really made a difference. One of the problems the turbo did not include the restrictor pill. When I went to WRC they ended up removing one from a brand new VF34 and made it work. The wastegate actuator rod had to be tightened nearly all the way in. At the end of the day the turbo was great and made 335chp/310lbft @ 17.5 psi (263 WHP). I was pretty happy until the weather turned really cold. Now I am spiking to 22psi! Boost cut and det are a big problem. I called APS and they told me that they have had problems with the actuator on the S/R30 and they would suggest I get a new one. 4 days later and $150 it arrived. 15 minutes later the turbo was back to little boost and very lazy. Another call to APS and they told me how to set the factory preload... no change. Tightened the actuator all the way in, back to 18psi and good response. So there goes $150 down the toilet. APS keeps telling me its my cars fualt, not the turbo. The car was running great with the TD04 @ 297hp/284ftlbs (232WHP), prior to the APS turbo... so that cant be right. Jerry has been very helpful but as he says, the APS is not his specialty. He said the turbo was cleaned and inspected prior to selling it to me and he didn't find anything out of the ordinary. I trust Jerry so I can't blame him.
Nobody seems to know why I need to run the actuator so tight. Either the flapper isn't sealing properly or the supplied 8psi spring is just too soft. Either way, I am done messing with it. So there goes $1,099 I had put away for my 6 speed swap.

Anyway, so how do you FP16g owners like your turbo?
* Registered users of the site do not see these ads.
BVM is offline   Reply With Quote
Old 03-23-2006, 11:12 AM   #2
Crawdads
Scooby Specialist
 
Member#: 30907
Join Date: Dec 2002
Chapter/Region: SWIC
Location: Cat Keyboard Cat
Vehicle:
SWP GDB-G

Default

how much did the FP E3 16g run you total? are they including lines and stuff now?
Crawdads is offline   Reply With Quote
Old 03-23-2006, 11:26 AM   #3
Paul
Scooby Guru
 
Member#: 56203
Join Date: Feb 2004
Chapter/Region: Tri-State
Location: south nj
Vehicle:
00 RSTI Coupe
Twin Scroll 2.5XTR EJ207

Default

you should have sold the turbo then posted this
Paul is offline   Reply With Quote
Old 03-23-2006, 11:41 AM   #4
J-Rex2004
Scooby Specialist
 
Member#: 68490
Join Date: Aug 2004
Chapter/Region: TXIC
Location: Spring
Vehicle:
'04 tippin' on
fo'fo jackstands.

Default

Ported FPE318G is $939.00

FP has been supplying coolant lines for a while now.
J-Rex2004 is offline   Reply With Quote
Old 03-23-2006, 12:48 PM   #5
BVM
Scooby Specialist
 
Member#: 41049
Join Date: Aug 2003
Chapter/Region: South East
Location: Panama City FL (Tyndall AFB)
Vehicle:
2010 Impreza WRX
KTM 250sx

Default

Quote:
Originally Posted by Paul
you should have sold the turbo then posted this
I would never sell a faulty part w/o disclosing that information.
BVM is offline   Reply With Quote
Old 03-23-2006, 12:50 PM   #6
BVM
Scooby Specialist
 
Member#: 41049
Join Date: Aug 2003
Chapter/Region: South East
Location: Panama City FL (Tyndall AFB)
Vehicle:
2010 Impreza WRX
KTM 250sx

Default

Quote:
Originally Posted by Crawdads
how much did the FP E3 16g run you total? are they including lines and stuff now?
The total came to $1,099 including shipping, braided oil feed line, gaskets and misc items needed for the installation (banjo bolts I believe).

http://linux.forcedperformance.net/m...e=NTWRXFP16G5H
BVM is offline   Reply With Quote
Old 03-23-2006, 12:59 PM   #7
Crawdads
Scooby Specialist
 
Member#: 30907
Join Date: Dec 2002
Chapter/Region: SWIC
Location: Cat Keyboard Cat
Vehicle:
SWP GDB-G

Default

Quote:
Originally Posted by BVM
The total came to $1,099 including shipping, braided oil feed line, gaskets and misc items needed for the installation (banjo bolts I believe).

http://linux.forcedperformance.net/m...e=NTWRXFP16G5H
exactly what i was looking for/asking. Thanks
Crawdads is offline   Reply With Quote
Old 03-23-2006, 01:31 PM   #8
Paul
Scooby Guru
 
Member#: 56203
Join Date: Feb 2004
Chapter/Region: Tri-State
Location: south nj
Vehicle:
00 RSTI Coupe
Twin Scroll 2.5XTR EJ207

Default

Quote:
Originally Posted by BVM
I would never sell a faulty part w/o disclosing that information.
who said it was faulty? Deadbolt looked at it and said it was good. Maybe the turbo just didn't like your car Or the turbo just needs a ewg.
Paul is offline   Reply With Quote
Old 03-23-2006, 01:49 PM   #9
BVM
Scooby Specialist
 
Member#: 41049
Join Date: Aug 2003
Chapter/Region: South East
Location: Panama City FL (Tyndall AFB)
Vehicle:
2010 Impreza WRX
KTM 250sx

Default

Maybe... does that mean you want to buy it!?
BVM is offline   Reply With Quote
Old 03-23-2006, 02:24 PM   #10
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

What EM were you using?
Tea cups is offline   Reply With Quote
Old 03-23-2006, 02:53 PM   #11
BVM
Scooby Specialist
 
Member#: 41049
Join Date: Aug 2003
Chapter/Region: South East
Location: Panama City FL (Tyndall AFB)
Vehicle:
2010 Impreza WRX
KTM 250sx

Default

Ecutek
BVM is offline   Reply With Quote
Old 03-23-2006, 03:45 PM   #12
WRX-ERROR
Scooby Specialist
 
Member#: 83211
Join Date: Mar 2005
Chapter/Region: Tri-State
Location: Wilkes Barre, Pa
Vehicle:
2002 WRX - stg4
PSM

Default

Why didn't you just get an UR EWG setup? and be done with it?
WRX-ERROR is offline   Reply With Quote
Old 03-23-2006, 04:39 PM   #13
HerculesPeanut
Scooby Specialist
 
Member#: 35421
Join Date: Apr 2003
Vehicle:
2003 WRX
W R Blue

Default

Quote:
Originally Posted by WRX-ERROR
Why didn't you just get an UR EWG setup? and be done with it?
I think now he really is done with it.
HerculesPeanut is offline   Reply With Quote
Old 03-23-2006, 05:23 PM   #14
BVM
Scooby Specialist
 
Member#: 41049
Join Date: Aug 2003
Chapter/Region: South East
Location: Panama City FL (Tyndall AFB)
Vehicle:
2010 Impreza WRX
KTM 250sx

Default

Quote:
Originally Posted by WRX-ERROR
Why didn't you just get an UR EWG setup? and be done with it?
Nice setup, I really would like an EWG!
BVM is offline   Reply With Quote
Old 03-23-2006, 07:56 PM   #15
BGPunk2001
Scooby Specialist
 
Member#: 46134
Join Date: Oct 2003
Chapter/Region: TXIC
Location: Welcome to Flavor Town
Default

if you are getting det and boost cut, you might want to compression test to make sure the motor is not part of the problem.
BGPunk2001 is offline   Reply With Quote
Old 03-24-2006, 05:39 AM   #16
BVM
Scooby Specialist
 
Member#: 41049
Join Date: Aug 2003
Chapter/Region: South East
Location: Panama City FL (Tyndall AFB)
Vehicle:
2010 Impreza WRX
KTM 250sx

Default

Det and boost cut are directly the result of the car being mapped at 17.5 psi and now that its cold running 22psi. I actually changed the plugs and tested #1 & 3 and you couldnt even tell there had been det looking at the plugs. When I say det I mean -1.5 max on the SM3.
BVM is offline   Reply With Quote
Old 03-24-2006, 08:35 AM   #17
BensonRST
Scooby Newbie
 
Member#: 106895
Join Date: Feb 2006
Chapter/Region: NESIC
Location: Torrington, CT
Vehicle:
1999 RS-T
Custom Charcoal

Default

Quote:
Originally Posted by Paul
who said it was faulty? Deadbolt looked at it and said it was good. Maybe the turbo just didn't like your car Or the turbo just needs a ewg.
+1 for an external gate.
BensonRST is offline   Reply With Quote
Old 03-24-2006, 12:11 PM   #18
stu
Scooby Specialist
 
Member#: 25768
Join Date: Oct 2002
Chapter/Region: RMIC
Location: CO springs
Vehicle:
35R bugeye
Slowbaru

Default

hey steve try a helper spring. adjust it back to the factory setting and put a helper spring on if that is the problem then the factory wastgate is just to weak. call phil and go external that is what I did because th sr55 had a 9 lbs spring and I could only boost 19 lbs at max on my ebc
stu is offline   Reply With Quote
Old 03-24-2006, 12:22 PM   #19
line
Scooby Specialist
 
Member#: 76189
Join Date: Nov 2004
Chapter/Region: Tri-State
Location: NJ
Vehicle:
WRX: Parking Lot
Racer in Training

Default

I thought those Garrett based turbos lover to run 20psi or more. Hopefully you can get the waste gate issue resolved and keep the SR30 with good results. If you go to a relatively low reading dyno Iím not use how much youíre going to gain (if any) with the new turbo. Best of luck and keep us posted.
line is offline   Reply With Quote
Old 03-24-2006, 12:30 PM   #20
BVM
Scooby Specialist
 
Member#: 41049
Join Date: Aug 2003
Chapter/Region: South East
Location: Panama City FL (Tyndall AFB)
Vehicle:
2010 Impreza WRX
KTM 250sx

Default

Glad to know a 14psi actuator spring will solve the boost problems. If this is a known problem with APS turbos, why didn't APS sell me a 14psi actuator instead of a new 8psi one?????? I hope they will let me exchange it!
BVM is offline   Reply With Quote
Old 04-26-2006, 07:11 AM   #21
BVM
Scooby Specialist
 
Member#: 41049
Join Date: Aug 2003
Chapter/Region: South East
Location: Panama City FL (Tyndall AFB)
Vehicle:
2010 Impreza WRX
KTM 250sx

Default

Update.

Forced Performance is suppose to be shipping my EVo3 turbo out today (its only been 6 weeks!) so the S/R30 has been removed. Upon inspection it looks like the flapper valve isnt sealing properly and that caused the boost problems. ATF Power is sorting out the turbo so I can sell it working 100%.



Now if only the FPEVO316g would get here!!!!
BVM is offline   Reply With Quote
Old 04-26-2006, 09:27 AM   #22
JRSCCivic98
Scooby Specialist
 
Member#: 67080
Join Date: Jul 2004
Default

Did you get just the regular Evo3 or did you tack on PnP and such? Post pics when you get it in.
JRSCCivic98 is offline   Reply With Quote
Old 04-26-2006, 10:00 AM   #23
BVM
Scooby Specialist
 
Member#: 41049
Join Date: Aug 2003
Chapter/Region: South East
Location: Panama City FL (Tyndall AFB)
Vehicle:
2010 Impreza WRX
KTM 250sx

Default

from post #1:
2 weeks ago I placed an order for the Forced Performance EV03, ported big 16g. Unfortunately its on a 3 week back order!
BVM is offline   Reply With Quote
Old 04-26-2006, 10:16 AM   #24
bgod
Scooby Specialist
 
Member#: 100274
Join Date: Nov 2005
Default

so where exactly did deadbolt get this barely used turbo?

is it possible they may have known there were some issues? just curious because it seems like you've gotten a raw deal.
bgod is offline   Reply With Quote
Old 04-26-2006, 11:48 AM   #25
BVM
Scooby Specialist
 
Member#: 41049
Join Date: Aug 2003
Chapter/Region: South East
Location: Panama City FL (Tyndall AFB)
Vehicle:
2010 Impreza WRX
KTM 250sx

Default

No, I don't feel that Jerry did anything wrong. He has bent over backwards for me many times in the past. It was a calculated risk buying a used part, really. I believe he said the turbo came from an employee's car.
Too be fair I have had more of a run around with Forced Performance than anything. I was promised I would have my new turbo in 2 weeks at the time of the order.... here we are over 6 weeks later and still no turbo.
BVM is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bye bye Microdrive, hello 8GB Flash... Idjiit Off-Topic 3 02-13-2004 10:47 AM
bye bye Jaguar, hello...... munkis Tri-State Area Forum 20 08-16-2003 03:05 PM
Bye bye WRX, hello rx-7 SiLu Texas Impreza Club Forum -- TXIC 19 07-18-2003 02:53 AM
Bye bye VF22, hello 18G MAD REX Factory 2.0L Turbo Powertrain 15 07-16-2003 02:53 PM
Bye bye H4, hello V8 dada21 Mid West Subaru Owners Club Forum -- MWSOC 9 03-14-2001 12:24 AM


All times are GMT -4. The time now is 04:08 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.