Welcome to the North American Subaru Impreza Owners Club Sunday April 19, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-01-2006, 10:27 PM   #1
1990Loyale
*** Banned ***
 
Member#: 101521
Join Date: Nov 2005
Location: Owensboro, Kentucky
Vehicle:
1990 Subaru Loyale
baby blue, AWD Conversion

Default legacy Wagon problem.

im thinking about buying a '97 Legacy wagon... the body is in PREFECT shape but it has 219K miles.... it still runs great, but when your coming to a stop at around 15 and under it kinda jerks and you see the RPM gauge bouncing from 1,100 down to 800 then back up... it does it until you apply the breaks.... anyone know what that deal is? and it is bad?
* Registered users of the site do not see these ads.
1990Loyale is offline   Reply With Quote
Old 05-01-2006, 10:39 PM   #2
1990Loyale
*** Banned ***
 
Member#: 101521
Join Date: Nov 2005
Location: Owensboro, Kentucky
Vehicle:
1990 Subaru Loyale
baby blue, AWD Conversion

Default Legacy Problems.

im thinking about buying a '97 Legacy wagon... the body is in PERFECT shape but it has 219,000 miles.... it still runs great, but when your coming to a stop at around 15 and under it kinda jerks and you see the RPM gauge bouncing from 1,100 down to 800 then back up... it does it until you apply the breaks.... anyone know what the deal with that is?
1990Loyale is offline   Reply With Quote
Old 05-01-2006, 10:43 PM   #3
suby2low
Scooby Newbie
 
Member#: 82633
Join Date: Mar 2005
Chapter/Region: NESIC
Location: Claremont, nh
Vehicle:
'08 WRX STI
Silver

Default

sounds like the torque converter lock up is not disengaging. i am not sure how it is engaged in these cars though. (i drive a 5speed.) could be done with a solenoid or could be done by straight hydraulic control. so... it could be as simple as changing a solenoid, or could be a much bigger project.
suby2low is offline   Reply With Quote
Old 05-01-2006, 10:46 PM   #4
subyrally
Scooby Specialist
 
Member#: 52662
Join Date: Jan 2004
Chapter/Region: MAIC
Location: frederick, maryland
Vehicle:
2009 dgm WRX hatch
86 & 87 rx, 1985 brat

Default

sounds like avac leak almost.

also would help to put in the right forum, this is old school, 97 aint old school, not by far.
subyrally is offline   Reply With Quote
Old 05-01-2006, 10:57 PM   #5
1990Loyale
*** Banned ***
 
Member#: 101521
Join Date: Nov 2005
Location: Owensboro, Kentucky
Vehicle:
1990 Subaru Loyale
baby blue, AWD Conversion

Default

hmm... this one is Automatic sadly.... thanks for your help though... im gonna take it to a professional that has been working with Subaru since 73 and he can do ANYTHING with repairing them... he will know for sure.
1990Loyale is offline   Reply With Quote
Old 05-01-2006, 10:59 PM   #6
1990Loyale
*** Banned ***
 
Member#: 101521
Join Date: Nov 2005
Location: Owensboro, Kentucky
Vehicle:
1990 Subaru Loyale
baby blue, AWD Conversion

Default

LOL.... i know it aint old school... but people the in old school forum here know more than the others....LOL
1990Loyale is offline   Reply With Quote
Old 05-01-2006, 11:03 PM   #7
subyrally
Scooby Specialist
 
Member#: 52662
Join Date: Jan 2004
Chapter/Region: MAIC
Location: frederick, maryland
Vehicle:
2009 dgm WRX hatch
86 & 87 rx, 1985 brat

Default

Quote:
Originally Posted by 1990Loyale
LOL.... i know it aint old school... but people the in old school forum here know more than the others....LOL
dont sweat it. im not serious about that.

lets start with the basics, what engine, what tranny, and what are you doing when the problem happens??
subyrally is offline   Reply With Quote
Old 05-01-2006, 11:07 PM   #8
1990Loyale
*** Banned ***
 
Member#: 101521
Join Date: Nov 2005
Location: Owensboro, Kentucky
Vehicle:
1990 Subaru Loyale
baby blue, AWD Conversion

Default

well its the 2.2 liter engine... and it does it as im coming to a stop within the speeds under 20 MPH.
1990Loyale is offline   Reply With Quote
Old 05-02-2006, 02:44 AM   #9
Flowmastered87GL
WCSS Drunk
Moderator
 
Member#: 8914
Join Date: Aug 2001
Chapter/Region: NWIC
Location: Portland Oregon
Vehicle:
2005 Baja Sport
Regal Blue Pearl

Default

relocating to proper forum
Flowmastered87GL is offline   Reply With Quote
Old 05-02-2006, 06:47 PM   #10
Wiscon_Mark
Scooby Guru
 
Member#: 94945
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Stevens Point, WI
Vehicle:
1995 Legacy OB 5MT
2003 Forester X 5MT

Default

I would agree with the torque converter guess. I would say the IAC valve, but I can't imagine that jerking the car around.
Wiscon_Mark is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
05 Legacy problems gusman21 Legacy Forum 9 03-18-2005 10:14 PM
Any 05 Legacy Problems ? allythom Newbies & FAQs 6 12-27-2004 03:49 PM
2000 Legacy problems (need help ASAP) Mr.Freeze Normally Aspirated Powertrain 3 06-10-2004 05:35 PM
93 legacy problem Pacs_Legend Legacy Forum 1 05-07-2004 03:25 PM
Common 97 98 99 GT Legacy Problems? SubaTubaru Legacy Forum 6 04-20-2001 09:24 PM


All times are GMT -4. The time now is 12:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.