View Single Post
Old 02-03-2008, 11:11 PM   #65
Scooby Specialist
Member#: 142133
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Virginia - hate it
3 Jeeps
And a Saab


Originally Posted by blkscooby View Post
Rick I haven't tried it yet but it appears that you MUST have your ROM named the same as the stock ROM for it to work.
I did it that way, too..

But I tried another method this evening, and got it to work.. sorta. then i had to modify the XML pasted portion to get it proper.

1. apparently, I had to run the CMD as user, not administrator. (which is weird, on another level, but it IS a microshaft product...)
2. When it patched, and I copied the XML bit to the Impreza WRX file, I had to make a change: kph to MPH.

Reason for #2 was, that when I opened ECUFlash, and ticked the 'speed threshold' box, there was no box to put a numeric value, but the RPM box was okay. The SPEED box only had a button-looking thing in it, with "..." in the field.

After changing the xml paste to "MPH", it was fine, and allowed me to enter a speed value.

Here's what I pasted:
    <table name="LC disable speed threshold" category="tinywrex patches" address="2D2D0" type="1D" level="1" scaling="VehicleSpeed(MPH)"/>
    <table name="LC RPM delta" category="tinywrex patches" address="2D2D2" type="1D" level="1" scaling="EngineSpeed(RPM)"/>
I 'assume' this is due to the USDM not using KPH

the weird thing I see now, is, when looking at the actual Params > Misc > Rev Limit: both fields have "28" in the "ON ABOVE" and "OFF BELOW" data fields. In Enginuity, I see 7100 above, 7200 below..

Question: If I alter this "patched" rom, rename it something, and alter it more in Enginuity, will the FTL still be nestled in the HEX?
* Registered users of the site do not see these ads.

Last edited by Rogan; 02-03-2008 at 11:24 PM.
Rogan is offline   Reply With Quote