View Single Post
Old 05-08-2009, 02:28 AM   #90
Dartholomew
Scooby Newbie
 
Member#: 208771
Join Date: Apr 2009
Vehicle:
2009 WRX
OBP

Default Installed! (Lots of pics)

Took a bit longer than anticipated, since, naturally, I screwed up a bit. I performed the installation on my '09 OBP 5-door WRX:

My car:


First off, a big thanks to Ben at Hodges Subaru for getting the kit out to me, and at a great price. I ordered:

H201SS100 - Subaru Red LED Interior Illumination Lamp Kit
66237SA120 Lamp Pocket (red cubbyhole LED)1


The illumination kit came with a wiring harness, driver and passenger LED modules, instructions, and a bunch of washers, nuts and bolts for the installation.



Tools you'll need: philips screwdriver, and 3/8" wrench (I used a crescent). ALSO, a FLASHLIGHT to help shine some light on the underside when you're trying to wire the harness. That's probably the toughest part, since there are some small spaces and plenty of spots for the wires to get stuck.

First, I popped off the blue cubbyhole LED - this is where you will wire everything in.


It comes right off in its retainer.



The blue cubbyhole LED (left), and the new red LED (center). Duh. The LED modules pop on and off the retainer (right)


The driver's side LED module. It's actually very well constructed - the whole thing is sealed in epoxy. I'm not sure why, maybe it's rated for deep-sea use.


First thing I did was connect the new LEDs to the wiring harness, and connect the harness to the cubbyhole power, to make sure everything worked.
* Registered users of the site do not see these ads.
Dartholomew is offline   Reply With Quote