View Single Post
Old 05-23-2012, 02:15 PM   #1
AK SloPok
Scooby Specialist
Member#: 56464
Join Date: Mar 2004
Chapter/Region: AKIC
Location: Anchorage, AK
12 Ram

Default Aeromotive Prime Issue, Crank No Start

So Tuesday I go out to start the Forester to take to work. I hadn't started/drove it in a couple weeks and it was time. Stick the key in, hear the pump prime, twist and.... cranky crank. No start. Repeat, never running the starter more than a few seconds. I was frustrated because she has NEVER done this before. I had no codes, full battery, full tank of gas and hadn't changed any settings or wiring and she was working perfectly when parked in the garage. What to do? Well I went to work in my other car.

I did some searches specifically looking for no spark as I thought it had to be one of two things, no fuel or no spark. Since I could hear the pump I assumed it was OK. I also thought it might be the remote start/alarm but after speaking to a pro, he determined it was not my issue.

I get home from work, armed with ideas and a bad attitude, I quickly (without removing my work clothes) start the process of elimination. Reset the ECU, check all fuses, etc etc. Then I realize something, my adjustable fuel pressure regulator is reading zero. As in nada nothing. That can't be right! So I pull the fuel pump, a brand new Aeromotive Stealth 340 (maybe 200 miles on it). The assembly looks great, all fittings are good, wiring is correct (well actually reversed but there are many posts on that). So I perform a test. I put the assembly in a vessel of fuel and gave it 12 volts and guess what... pump runs great but no fuel comes out. I run the pump for about 30 seconds to a minute hoping it will prime and fuel will flow. But nothing.

So I figure, maybe I can suck it to prime (no jokes now). And sure enough, the dang thing starts pumping fuel like crazy. So I take a break to think and search the web. I found a brief mention on an Evo site about the "Prime Hole" yea I was like that sounds bad. But really there is on... see

It's the little hole at the six oclock position in the above pic. But there is a problem, now I am not sure about all STI or WRX but on my Forester the rubber foot covers the prime hole and wont allow gas to enter the body of the pump.

So, I cut and fit several times, I want to keep the majority of the rubber foot to secure the pump but I also want to make sure the fuel can get to the pump. Here is the result.

Not a great pic but you can see how fuel can go into that hole unobstructed. I retested my setup in the same fashion as before. The pump fired right up, and immediately changed tone from what can best be described as unloaded to fully loaded and fuel poured forth! Success! I put the assembly back in the car, secured all fasteners and put the key to the on position. Immediately my fuel pressure gauge jumps to live and after a second cycling reads max fuel pressure.

I did several searches on Nasioc and the web but didn't find much. And like I said, your car may be different or this could be so common nobody cares, but I did and you may too. Let me know if I can answer any questions. I am still bothered as to how my setup worked for 200 miles and only now became a problem. But am almost certain that little hole shouldn't be covered.
* Registered users of the site do not see these ads.
AK SloPok is offline   Reply With Quote