View Single Post
Old 09-26-2012, 11:32 AM   #1
Scooby Newbie
Member#: 222308
Join Date: Sep 2009
Chapter/Region: South East
2004 STi

Default ecu bricked.. again

Okay if anyone could help me out here I would appreciate it. I tried to flash a rom on my 04sti and followed the procedure to the best of my knowledge. It ended up bricking my ecu. I shipped it to Cobb, had it unbricked. When I got it back, I called my tuner to make sure I was doing everything perfectly so I tried it again. And now it appears to be bricked again here is what I done.

- opened ecu flash
- connected green test connectors under dash
- turned on ignition
- read and saved stock rom (the one Cobb put back on for me) in case I ever need it.
- turned off ignition
- opened rom from tuner that I need flashed
- turned on ignition and wrote rom to ecu

It took about 3 or 4 minutes to write and said it completed successfully. But then when I go to start my car the solenoid next to the ecu just clicks and the cel lights flash. The car only turns over, it will not start. I have tried disconnecting battery and power to ecu. Nothing works, so it appears to be bricked again. Also, I monitored voltage during the entire process and it stayed well above 12v. Does anyone have any ideas as to what may be going on? Thanks, Garrett
* Registered users of the site do not see these ads.
gberryhill is offline   Reply With Quote