View Single Post
Old 10-09-2012, 04:03 AM   #20
Scooby Guru
Member#: 140444
Join Date: Feb 2007
Chapter/Region: NWIC
Location: Near Seattle, WA
05 Stage Free LGT


Your cal-id is A2ZJ500J, EcuFlash just calls it "Internal ID" in the ROM info section.

I am really curious what's gone wrong here. I'm up to about 200 flashes on my ECU now, but stuff like this still worries me a little, because it would ruin my day... My guess is that the file you got from your tuner was corrupted at some point, but that's just a guess.

Did you verify that the ECU worked before you tried reflashing? I mean, were you able to start the engine and idle, for example?

While you wait for your ECU to come back, try downloading another copy of your stock ROM from the archive at RomRaider (there's a sub-forum with stock ROMs, find the one with the same cal-id) and compare that to the ROM file that you read from the ECU. Put both files into the same directory and open up a command line window, and run this command:

fc /b YourRomFile.bin RomRaiderFile.bin

(Use the actual names of your files, of course.)

You should get a message like "no differences encountered." Or if there are differences, it will print out a bunch of numbers. If they're different, that would indicate that data was corrupted in the transfer from your ECU to your laptop, which would suggest that data may also have been garbled when your laptop sent your tuner's ROM to your ECU.

Come to think of it, you should also ask your tuner to email you another copy of the same ROM file that he sent you, and run "fc /b" on both copies. If they're different, then one copy was corrupted in transit.

Before flashing again, try doing a test write, and verify that you get no errors when that process completes. If you do a test write of the exact same file that you just read from your ECU, EcuFlash should end with a message that says the ECU's ROM matches the file that it just pretended to write. If it reports that they are different, then something is wrong, and you should NOT attempt a real write. I'd guess that your cable is hosed if that happens.
* Registered users of the site do not see these ads.
NSFW is offline   Reply With Quote