View Single Post
Old 12-24-2012, 10:33 PM   #1
Scooby Newbie
Member#: 279687
Join Date: Apr 2011
Default 1999 Subaru Forester Start, Sputter, Die - Need Additional Help Please & Thank You

I apologize for posting here but I feel I'm almost at a dead end and need to ask for additional thoughts and ideas. I have a 99' Forester. 11,000 miles ago I replaced the engine with an 05' Impreza engine with 40,000 miles on it. I swapped in my intake, swapped the proper timing gears, cam gears, put new plugs and wires in place, timing belt, etc. and it's run fine up until a few days ago.

I pulled the car up on my ramps and shut it off. I drained the tranny fluid from the 5MT, removed the air filter assembly to get better access to the fill point, and refilled. I went to start the car and the car would start, run for a few seconds, sputter, and quit. This seemed very odd as this had never happened before and I had it out running all morning before I started this tranny oil change. I hooked my buddies Snap on Computer up to the car to read the computer codes. I came up with the following:

P0136 -O2 sensor circuit bank 1 sensor 2

These fault codes really don't seem to coincide with problems I'm having although I haven't eliminated them. I knew that I had an issue with my charcoal canister as I cannot fill my fuel tank without disconnecting the tank vent tube at the charcoal canister(Picked up another canister today so hopefully this is fixed now). Yes, I already put in a new fuel neck assembly. I figured vapor lock so I removed the gas cap and tried again. Same issue still there. I disconnected the front O2 Sensor and still the same issue. I disconnected the MAF. This time the car would run great from 1000 plus RPM's but would not idle. I figured I had a bad MAF sensor so I bought a new one from the dealer and stuck it in. Still same issue persisted. I thought I might have a bad coil so I tried one from a running Subaru and still same issue. I removed the incoming fuel supply line and ran fuel into a cup and I'm getting plenty. I disconnected the battery to reset the ECU and still, same issue. The car smells of fuel when this happens as in it's getting plenty of fuel and not burning it all. Again I can still disconnect the MAF and the car will run but not idle. I don't know what to do next. I disconnected all the wiring connections around the intake where I filled the tranny with my long extension funnel thinking I might have a short or something to that effect. I reconnected all and still the same issue persists.

The only thing I can think of is to pull the belts, timing covers, etc. and check the timing but it will start and run for a few seconds or run above 1000 RPM's with the MAF disconnected so I don't think timing has anything to do with it. The MAF cost me $73.00 and the Coil cost me $30.00 plus dollars used so I'm not out much yet but none of this makes sense. I have not disconnected the rear O2 sensor yet and tried to start it but maybe I will do this tomorrow. I just don't logically understand why it ran fine all this time and I change the tranny fluid and it immediately acts up.

I feel I've almost exhausted all efforts here and I could really use some help with this so I look to the experts on this board. Thank You and all help is greatly appreciated!!
* Registered users of the site do not see these ads.
Bow_Extreme is offline   Reply With Quote