View Single Post
Old 06-30-2013, 01:40 AM   #36
Scooby Specialist
Member#: 242647
Join Date: Mar 2010
Chapter/Region: NWIC
Location: Lacey, WA


Originally Posted by 02 wrx roar View Post
I would check just to see but ur right it would do Italy the time most likely... Possible coil? Or bad ecu?
Have new coil packs and swapped them around more times that I can count now. Already threw a new ECU in it as well. I'm going to possibly switch to pump gas (92oct) to see if it follows. I've been running E85 for a few years now on different set-ups threw out my building process and have never ran into this issue.

I wish I would have payed more attention to the cylinders during my break in while running pump instead of trying to figure it out now.

I've also yet to swap the engine harness. A new development for whatever reason my shops computer will not read the front 02 sensor either it does not move on their scan gauge during any conditions idle or driving The sensor is brand new I do not get any codes and I've tried multiple 02 sensors that worked on different cars perfectly. We have looked through the main harness which goes into the ECU through the firewall and found no messed up wires etc. it's also not attached to the engine harness that I still want to swap to check the block. Is there a possible connection somewhere that I'm missing?
* Registered users of the site do not see these ads.
jtrakel is offline   Reply With Quote