View Single Post
Old 07-25-2019, 12:43 PM   #1144
ScoobyFreak86
Scooby Guru
 
Member#: 338329
Join Date: Nov 2012
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2017 STI
Lapis Blue

Default

Next mod I decided to tackle was the Subispeed S4 Fog light bezels. These always were in my cart, but removed them and said I would get them later. Decided to try them out and see if I could start making this front end a but more aggressive. I was growing a bit tired of the yellow DRL's that I have been running for 2.5 years and wanted to different/updated look. I did read some feedback that people have had some issues with these, but they were cheap enough that it wouldn't be the end of the world. Hopefully these last a while as the overall look is something I am a fan of.

I opened them up and surprised at the nice finish they had on them. I assumed they were just a gloss black, but they have a nice metallic to it. I believe it's the same black that is used on the black color choice of the car. Install was fairly simple, although it took some trial and error to get them working the way I wanted. I wanted them to run as DRL and turn off when I turn the low beams on. After some fiddling, putting the add a fuse in the 15 amp HI beam spot did the trick. They turn on when I put the ebrake handle down, turn off when the low beams are on, and turn on with the high beams (extra light). I also disabled the DRL's in the headlight (unplugging module) so the S4 LED strip is my new DRL. The overall look makes the front end look much nicer with the better finish. I am jealous of all the 18+ bumper people, so this will hold me over until I can get that done. I made sure all the wires associated with this install was tucked away and hidden so there was no visibility in the engine back that something was done. Wanted it as clean as possible. Ran the passenger side under the radiator supports and along the trim. The drive side wire is ran under the rain guards on the side of the fender. Lastly, the DRL module is double side tapped to the frame rail by the washer fluid tank. All wires were zip tied and tucked away. Sorry for the lack of pictures. I got invested into the install and forgot to snap progress pics. If anyone wants to see any specific part of the install, please let me know and I will be able to provide shots.





* Registered users of the site do not see these ads.

Last edited by ScoobyFreak86; 07-25-2019 at 12:55 PM.
ScoobyFreak86 is offline   Reply With Quote