View Single Post
Old 03-20-2007, 03:20 AM   #1
Nicklz
Scooby Specialist
 
Member#: 94096
Join Date: Aug 2005
Chapter/Region: MAIC
Location: WV
Vehicle:
2003 WRX
WRB

Default Need Help!! -- oil leaking from where???

I currently have 123k miles on my 03wrx.

power mods: full cobb stg2 since 60k miles, cobb up-pipe and egt probe installed 117k miles, also a replacement td04 at about the same time. (stock one had leaking oil past seals and seized up)


Two problems popped up at about the same time. Although the car continues to run as if there is no problem. Not sure if the 2 are connected or not.

A noise tick-tick-tick, which has been possibly diagnoised as a valve timing needs adjusted.

And my biggest concern is loss of oil. I can smell it burning, after I shut off the car. It is showing up on my back bumper. Little spots evenly dispursed over the bumper. I'm not sure if it is circulating from under the car, or coming through the exhaust. I have no clue. I can see there is wet oil on the passenger side, on the control arm, and behind but not from, where it is coming from. Oil loss is roughly 3~3.5qts every 3000 miles, I've been checking frequently and topping it off.


I have an appointment setup friday, but quite frankly I need to save money right now. I've been audited and the irs is raping me. And a slew of other expenses right now. I'd really like to figure out what's wrong myself.
* Registered users of the site do not see these ads.

Last edited by Nicklz; 03-20-2007 at 08:01 PM.
Nicklz is offline   Reply With Quote