View Single Post
Old 07-24-2017, 04:31 PM   #1
Luxkeiwoker
Scooby Newbie
 
Member#: 469111
Join Date: Jun 2017
Chapter/Region: International
Location: Europe
Vehicle:
2006 Impreza WRX STI
Black

Default Help troubleshooting P0448 (MY06 STI)

Hey guys,

I have had a CEL for the last couple of months and since I started to use the car more and more, it really started to annoy me, especially because cruise control is deactivated (blinking light).

I used my OBDLink LX to diagnose the code, and received

Code:
P0448 Evaporative Emission Control System Vent Valve/Solenoid Circuit Shorted
After deletion of the error, it popped back up after a few miles. I then started digging into possible root causes. Seems like it's the vent valve for the charocal canister.

Here is what I did so far (pictures below):

- inspection of the canister - looks fine
- took of the electrical plug of the valve and cleaned it from any debris/dirt
- put the car in test mode (2 green plugs under the steering column) and measured the voltage between both cables --> it was varying between ~7 to ~12 Volts which is presumably what it should do
- also checked if there is a shortage on the plug, but the voltmeter didn't beep
- measured the resistance between both connectors on the valve --> voltmeter shows ~27 Ohms (is that correct?)
- tried to remove the valve from the canister, but it sits in there pretty tight - not sure if it is even designed to be pulled out like that
- put the plug back on the valve actuator while in test mode to hear if there is any noise coming from the valve --> it stayed silent



I'm not sure what to conclude now. Is the valve defective? If so, can I replace it with a new one, or do I have to buy a completely new charocal can?

Since I'm based in Europe, I don't really care about the EVAP system, so if there is any way to just completely disable this while also not having a CEL, I'm open to it.
* Registered users of the site do not see these ads.
Luxkeiwoker is offline   Reply With Quote