View Single Post
Old 04-29-2019, 11:56 AM   #34
Fierysun
Scooby Guru
Member Sales Rating: (109)
 
Member#: 82745
Join Date: Mar 2005
Chapter/Region: SCIC
Location: So Cal
Vehicle:
2005 Subaru STI
2003 EJ207 S204 Wagon

Default

Quote:
Originally Posted by goodolmrwilson View Post
Quote:
Originally Posted by dLo R6 View Post
thought i'd bump this thread to PSA that hangers snapping after a few years is not uncommon - happened to me last night while it was parked (luckily not while I was driving). about 7 years old. don't remember how I installed them but it was a new exhaust.

My kartboys snapped as well after about 6-7 years also in the parking lot of my job. i did call kart boy submitted photos and they send new ones out to me. for the price after a few years i would care to be honest but good to know they stuck behind such a cheap part. it was crazy to see all 4 hangers and my exhaust on the ground
__________________
Sorry for digging up a year+ old thread, but this was all i could really find. I just had all 4 of mine snap in the driveway overnight, luckily the 3 day old Invidia exhaust was saved! Did I install wrong? I used white lithium grease, so I can't imagine that was a cause for failure. There is a good amount of tension in the middle hangar, so I guess it may have needed a longer one there, but the other 3? I have just replaced all 4 with factory stock ones, and they don't' seem too tensioned. I'm afraid if i use all long hangars, it will hang too low.
Unfortunately, KB bushing formulation is very poor and disintegrate after a short period of time (compared with other bushing manufacturers) .
* Registered users of the site do not see these ads.
Fierysun is offline   Reply With Quote