View Single Post
Old 02-13-2019, 07:41 PM   #104
cosworth89
Scooby Newbie
 
Member#: 497748
Join Date: Feb 2019
Default Help lol

Good evening. Sorry to bring this back to life but.. I have a 1995 impreza WRX which is a Japanese import, it had a hks FCD fitted which caused loads of issues so I removed it and it's running much better than it was (was fuel cutting at 0.5 bar!) It also has a electronic boost controller fitted which I have figured is nackered so have removed it and just looped the actuator and turbo direct so it boosts at between 0.6 and has spiked at 1.1Bar in 4th/5th gear where the ecu cuts the fuel and u end up head butting the windscreen!.... the car idles lovely has only done around 100k it has a FMIC and a straight through turbo back exhaust... the issue I'm getting recently is there is what looks to be a red light that looks like an exhaust cat that comes on the dash after hard acceleration in 4th/5th gear where it tends to splutter a little bit and has a loss of power... I have no idea what the light is or what it means, there is an aftermarket lambda sensor in the down pipe from the turbo as it has just been made to fit the original loom.... could this cheap lambda sensor be the issue? It only starts running crappy when it's warm and in 5th gear in wot and the red light comes on.... sorry for the long description but I've been scratching my head for days over this issue it's driving me mad

Cheers guys!
* Registered users of the site do not see these ads.
cosworth89 is offline   Reply With Quote