View Single Post
Old 12-16-2016, 06:43 AM   #29
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by schkemy182 View Post
So, I have a 2015 WRX Limited and I just installed the DD C-Lights with the DD DRL harness.

I have encountered a problem. With the DRL harness installed, the C-Light becomes the DRL instead of the high beam as expected. However, it is not at 100% brightness. It is the same brightness when the headlights are on. The issue is that when I engage the high beams, the C-Lights get brighter and the high beams do not come on. It is as if the DRL harness wired the C-Lights as the high beam.

I have quadruple checked the wiring and made sure all the connectors are connected the right way and have had 3 other people check it too.

I contacted DD about this and they said it sounded like I had a faulty DRL harness. I got a replacement DRL harness today, except that did not fix the problem.

Has anyone else with a Limited WRX or STI with the factory LED headlights experienced this? I find this to be odd and I am just trying to get some answers over the weekend while I wait to contact DD again on Monday.

Note: Everything works the same as it did from factory without the DRL harness installed.
Are you (or were you) running LEDs for your high beam/DRL 9005s? The trouble with Subaru's approach to DRL is the resistor setup leads to varying voltages at the DRL/HB bulb/harness. The voltage applied the the harness in DRL mode is a function of current through the circuit. The more current the more voltage your DRL resistor is going to drop and current is heavily dependent on what you're running, halogen or LED, with the latter consuming less.

Try running your factory halogen DRLs to see if that makes a difference.
* Registered users of the site do not see these ads.

Last edited by Brown1428; 12-16-2016 at 06:51 AM. Reason: Clarification
Brown1428 is offline   Reply With Quote