View Single Post
Old 05-20-2008, 04:51 PM   #1
Scooby Specialist
Member#: 108964
Join Date: Mar 2006
Chapter/Region: SCIC
Location: SoCal - Garden Grove
2013 Ford Focus ST
Performance Blue

Default A/C Clutch no engaging after compressor install?

Did some searches but couldn't come up with much (mostly because the search engine won't recognize "A/C" cause it's too short).

Anyway, when I bought my 04 WRX back in November, the A/C pulley had a horrible screech to it. So, not needing A/C in the winter, I pulled the belt off. Now it's about 5 months later and I finally got around to finding and installing a new compressor (From an 06 STi). I finished putting the belt back on, started the car up and hit the A/C button. The button lit up as normal but the clutch on the compressor pulley did not engage.

I know I will have to refill the system with refrigerant, but I wanted to check and make sure the thing worked first before starting to dump $50 worth of refrigerant into the system. I tried testing the 1-pin connector in the compressor with a voltmeter but got nothing (not even sure what kind of signal it uses).

Anyone have any suggestions as to why the clutch won't engage?

Any help would be appreciated!

* Registered users of the site do not see these ads.
Computergeek24 is offline   Reply With Quote