View Single Post
Old 10-23-2010, 03:20 PM   #1
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Grove City, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default IT RUNS!!! - My 500whp build - Element motor and Moore Performance Twin Scroll Kit!

Update, June 14th, 2014

My final graph and the official close of my project:



Note: The red lines are my car on April 17th, 2014 and the dashed lines are another customer's 2010 Stage 2+ WRX for a comparison.


It's official, my 500whp build project came to a successful conclusion on June 13th, 2014 after 3 years, 7 months, 22 days! This was obviously WAY longer than the original six months that I predicted in late 2010 but better late than never I guess. If you're wondering, it only took three motors (the original Element motor plus one that was rebuilt twice), three tuners, three different types of injectors, a few EMS platforms and many TENS of thousands of dollars but its finally done!

The car made 510wtq/508whp which are fantastic numbers for an EFR 7064 with a 1.05 hot side. However, the real story is not in the peak numbers, its in the spool characteristics and SUPER fat power band. The car is at or above 300wtq for nearly 5000 RPM and over 400wtq for nearly 3000 RPM which makes it feel pretty amazing. I cant thank Moore Performance, Element Tuning, Budds Auto Parts, Innovative Tuning and so many others enough for helping me over the past few years!



Here is my final mod list (Updated Today, June 14th 2014):

STI Power Mod List:

Engine:
Element Tuning Pro Comp motor w/8500RPM Redline
Manley 9.8:1 compression pistons
Element Tuning rods
ACL bearings
Cosworth 280 Cams
Element "Big Valve" Heads
Element competition valve springs
+1mm stainless intake valves
+1mm inconel exhaust valves
Mild head work (5 angle valve job, bowl blend, etc)
Cosworth billet aluminum timing belt guide
Element modified STi 12mm oil pump
Killer B Motorsport oil pickup
Killer B Motorsport oil pan

Performance Parts:
Stock ECU with Access Port v2 (Tuned by Innovative Tuning in Buffalo, NY)
Borgwarner EFR 7064 twin scroll turbo
APS DR725 FMIC
Moore Performance DR725 adapter pipes
Moore Performance twin scroll header
Moore Performance T4 twin scroll up-pipe/adapter (JDM TS to T4)
Dual TiAL MV-S 38mm Wastegates
Moore Performance down pipe
Moore Performance mid pipe
Cobb Tuning muffler
Injector Dynamics ID1300 injectors (1300cc)
Aeromotive A1000 fuel pressure regulator
Aeromotive A1000 fuel pump
Aeromotive fuel pump controller
Custom home-made electronics to provide a boost referenced input for the A1000 controller
JEGS fuel distribution block
JEGS 100 micron fuel filter
-10 PTFE fuel line between the A1000 and the distribution block
-6 PTFE fuel return line
2.2L in trunk surge tank
Walbro 255lph fuel pump (feeding the surge tank)
25 Row Setrab oil cooler w/-10 AN Lines
200F Mocal sandwich adapter
TGV deletes
GrimmSpeed phenolic Spacers
Element Tuning competition breather can
Mishimoto racing radiator
Exedy twin disk racing clutch (dual six pucks)

Suspension/misc stuff:
STI Suspension Mods:
245/17 Starspecs on stock 8" BBS rims
Ohlins Flag Coilovers with 10k front springs and 8k rear springs (corner balanced)
Ohlins Front Camber Plates
Ohlins pillow ball rear top Hats
STI Pink Pillow Ball Trailing Links
Whiteline ALK
Whiteline Bump Steer/Rollcenter Kit
Whiteline Subframe Lock Bolts
Cobb F&R Sway Bars
Cobb Endlinks
Cobb Adjustable Rear Swaybar Mount
Kartboy Rear Subframe Outrigger Bushings
TurnIn-Concepts Rear Diff Mount Bushings
Custom fender braces
STI Front Strut Tower Brace
STI Rear Strut Tower Brace
STI Group-N Motor Mounts
STI Group-N Transmission Mount
STI Group-N Pitch Stop Mount


For historical purposes, here are a number of my old updates and issues listed from earliest to most recent:



Dec 26th, 2011:

I know this thread has been around for a very long time but allow me to give a few cliff notes to those who haven't been reading it for the past year. I suggest you start by reading my original post below and the coming back to this point right here to get filled in on the 12 months that followed my original post.

To begin with, the experimental Evo style turbo kit didn't work well so that was totally abandoned in late May of 2011 and replaced with an amazing twin-scroll rotated kit from Moore Performance. There were a number of issues with the car and the new turbo that resulted in two failed tune attempts in June and July of 2011. With almost the entire season over I went back to element one last tune attempt in late August of 2011 and the block cracked on the fourth pull on the dyno. The damage from the crack was catastrophic resulting in the total destruction of the long block, turbo and nearly everything close by in the engine bay. The destruction can be seen on page 18 starting at post 880. My best guess was that the block was compromised from the very beginning and just waiting to fail. Needless to say, 2011 was a pretty bad year for me and my project.

After a ton of soul searching and lots of advice from many people (most notably my wife) I decided to keep my STI and give the project another chance. With a ton of help from Buddsautoparts.com I sent Element a full complement of engine parts for them to turn into a new Pro Comp motor. Phil didn't provide the parts that exploded on the first motor but he did give me pretty good break on the second one. After what seemed like forever, I took delivery of my second new motor on Dec 22nd and work started on Christmas Eve of 2011. The rebuild story begins at post 1086 on page 22. I plan on making a few very minor changes to my setup which are mostly bug fixes and the rest will simply be bolting the car back together just as it was.


April 2nd, 2012:

The car finally runs again! I put a new Element motor in and the start-up was at post 1279 / page 26.

August 2nd, 2012:

The car seemed to run fine through April of 2012 but as the break-in process neared the 500 mile mark I noticed the car was starting to have issues. The idle was really rough and the car was smoking pretty bad so it was really obvious that things were not right. I pulled all four plugs out to find that the two from the drivers side were totally blacked out while the two on the passenger side looked lean. [Check this post for info on the issue: Post 1419] Fearing the worst and with stress and anger taking its toll I parked the car in the garage for about two months and didn't even look at it. Thankfully, a few of my local friends gave me a hand in mid July which motivated me enough to fix the car. The problem ended up being something so simple that I intentionally overlooked it.

Unbelievably, I had two bad fuel injectors on the same side of the motor! The injectors on Cyl 2 and 4 were leaking while the injectors on 1 and 3 were working perfectly. Even though the very first thing that I suspected when I saw the badly fouled plugs were bad injectors, I didn't go through the steps to troubleshoot them. I found it very hard to accept that two injectors were bad at the same time let alone two on the same side so I chased my tail for weeks before letting the car sit for months. I was running down theories regarding fuel line issues (uneven pressure), AVCS problems and wiring which obviously made no difference.

As a final "Hail Mary pass" I swaped fuel injectors, change the engine wiring harness and re-routed my fuel lines. [Info here on the change in direction: Post 1731] Obviously the injectors were the only thing that ended up having any effect but that had to be proven for be to believe it. Once I had all the parts swapped I was stuck with the dilemma of trying to get the tune adjusted on my Hydra. There was no possibility of getting the car down to Element Tuning for Phil to tune on short notice. In addition, I was honestly very reluctant to spend the $1500 or so needed to trailer the car to Washington DC after having so many issues the year before. I didn't doubt Element, I doubted the car and I just couldn't do it.

I made the decision to swap the factory ECU back in so that I could have a local tuner take a shot at it while it was at my house. This process was some what of a pain in the butt because it required tons of work to get the related pieces of the car back to stock. Sensors, wires, meth parts, etc all had to come out for the factory ECU to go in. Fortunately, this all worked out pretty well as I was able to resolve the issues in my own garage without spending thousands of dollars. [Car is confirmed to work again: Post 1821]


Feb 17th, 2013:

Since I just cant get enough abuse, I have decided to play the game a little longer. Just after the August 2nd post above I was informed (by Phil from Element Tuning) that my engine block was likely to fail at high power levels due to a quality control issue related to Subaru's post-2011-Japan-Tsunami engine supply chain. Apparently the older blocks could hold power up into the 500whp range without an issue and the new blocks were cracking in the upper 300whp range. This was clearly not the issue with my motor that cracked and blew up in August 2011 as that block was much older.

Since I had just gotten over the ridiculous double fuel injector failure issues I posted about on Aug 2nd, 2012 only to find out that my block was possibly a time bomb I was pretty pissed. I decided to press on at wastegate boost pressure and finish out the year on low power. The car ran ok (lets say 75%) on the AccessPort until it started to get cold outside. Once the daily temp hit 50F things took a major turn for the worse and the car became un-drivable. This was obviously some kind of temp compensation issue and we were never really able to work it out.

The move back to the factory ECU wasn't something that I was extremely excited about to begin with. I did it in an attempt to figure out my fueling issues locally and I felt that anything else was a bonus. Had a not briefly moved to the factory ECU / AP I would most likely have parted the car out and moved on to something else. Since I was able to accomplish my goal of sorting out the mechanical pieces of the car in my own garage and finish out the year (even if it was only on low power), I feel that I made the right decision.

Since the car wasn't drivable as it was I made the pretty easy decision to move back to the Hydra (assuming that I kept on with this madness). However, I was faced with a much harder decision related to the motor. As I mentioned, Phil was convinced that it was only a matter of time until my block cracked again. Since I had no working ECU, a nearly impossible setup to tune and a time bomb motor, my old Cobb stage 2 setup form 2006 was looking pretty good. But as I said, I apparently enjoy the abuse so I decided to go "all in" just one more time.

In the November of 2012 I sent my Hydra 2.6 to Hydra USA and got it upgrade to a Hydra 2.7 with Flex Fuel support. Immediately after getting the Hydra back, I loaded my car on my trailer and took it down so that Phil could do a low boost road tune. No joke, 30 minutes into the tuning session with Phil and the car was running better than it had in two years! The sluggishness, slow boost response, roughness and drivability issues were GONE. Needles to say, I was extremely happy. The hardest thing at this point was coming to terms with the fact that I had a car that was running perfectly for the first time since October of 2010 and it needed totally torn apart to fix the block defect.

After getting the car home I pulled the motor out got it ready to take down to Element so that they could apply their "closed deck block reinforcement" plus re-blueprint the motor just to be sure that everything was 100%. The motor will arrive at Element on Feb 19th, 2013 and when it will be ready to pick up is anyone's guess. With a little luck it will be done before the end of march and the car will be back together by mid April 2013. I really hope this is it because I don't think I have another round of suffering left in me.

Nov 3rd, 2013:

I have had a pretty frustrating experience with the Hydra 2.7 and I am getting lots of advice to pull it and go back to the stock ECU/AP again. For whatever reason, the car likes to suddenly run at dramatically different AFRs randomly. Phil thinks the issue is related to the fuel system or possibly electrical but I am not sure thats the case.


March 29th, 2014:

I have my mind made up, I am moving back to the factory ECU AND STAYING THERE. I have really enjoyed working with Phil over the years but the frustration with the Hydra has hit a point where I cant continue. With the car already setup to run either the factory ECU or the Hydra, this shouldn't take much effort. At Moore Performance's advice, I am going to take the car to Innovative tuning in Buffalo, NY. The owner, Mike has a great reputation and I am really looking forward to the simplicity that running the factory ECU will bring. After all, I am at a point where it couldn't go any worse that what I currently have.


April 17th, 2014

Check out post 2890! I got the car tuned at Innovative and it produced a really amazing graph! The power is great and the spool-up is "super hero" like but unfortunately, it is however a modded Subaru so its still got issues as seen in post 2903. Hopefully I will get the remaining problems taken care of soon.

June 13th, 2014:

At the advice of both Moore Performance and Innovative tuning, I replaced the front O2 sensor and alternator. I also added a bunch of grounding wires and switched to much smaller ID1300 injectors. The results are PERFECT! (see post 2938) I couldn't be happier with the car right now and I am really glad that I stuck in there for the long haul.

P.S. If you're thinking of spending $100k on a car, it shouldn't be a Subaru!!!!!!!!!
* Registered users of the site do not see these ads.

Last edited by dexterous; 07-27-2014 at 02:27 PM.
dexterous is offline   Reply With Quote