View Single Post
Old 02-01-2020, 07:25 PM   #8
Jacob11531
Scooby Newbie
 
Member#: 506759
Join Date: Sep 2019
Location: Cary, IL
Vehicle:
2009 WRX

Default

Got the oil changed, took a little bit less than 5 qts instead of 4.2, also removed the felt liner for the skid plate since it was disintegrating and figured it is not serving its purpose at this point. In the process I seen some things wrong. Change every 3k correct?

1. There are 2 ground cables on either side of the motor. Upon inspection, The drivers side is intact but looks like it could be replaced however the passenger side is ripped into 2. Its connected to the frame and as expected I looked for the other part of it on the motor and I could not find it at all. Surprised the car runs normal since a ground cable could set off some codes imo. Where is this passenger ground cable suppose to go? First pic is broken passenger side, other 2 are the drivers side.




2. I think I may have a dent in the oil pan also. I took some pics to show. Maybe this is how Subaru designed them but I'm not sure. Too hard to tell if its designed that way or dented.




Never got the chance to pop off the power steering cap while hot but inspecting under the car I see no leaks, just a very light coating as you would see on a lot of cars imo. Will inspect for sure tomorrow as I will be trying my best attempt at removing the pedal assembly and fixing firewall welds.
* Registered users of the site do not see these ads.

Last edited by Jacob11531; 02-01-2020 at 07:39 PM.
Jacob11531 is offline   Reply With Quote