View Single Post
Old 03-15-2011, 10:29 PM   #1
llb_dll
Scooby Newbie
 
Member#: 273785
Join Date: Feb 2011
Chapter/Region: NWIC
Location: Behind my 3 Goggles in PDX
Vehicle:
2005 Impreza 2.5 RS
PSM

Default Need Help : 05 Impreza 2.5RS Fog light install help

Hi, I am quite a noob to the subarus (just got the RS a month ago). I just installed a set of 04-05 WRX fog lights from ebay (not OEM) and everything was plug and play. However, I didn't know what to do with the fog light relay. To the right of the fuse box, there were 5 relay slots. I think it is a relay; it is a black block with 4 prongs in the back. Anyways, assuming it is called a relay, I saw 5 relay slots on the right of the fuse box underneath the driver's side dash. The 3rd and 5th slots were occupied, so taking an educated guess after TRYING to find some help on the forums, I plugged in the relay into the 4th slot (counting downwards from the top).

In my RS, there are 4 blank buttons on the left side of the dash above the coin tray. The 2nd blank button from the left had a harness plug running to it. I assumed that was for the fog light switch since it was a perfect fit. When have the car running, I push the fog light button and my HIGH-BEAMS come on!? I am very confused. Maybe I plugged in the wrong switch or mis-placed the relay?

Also, For some stupid reason, my passenger's side low-beam head light is not working. I've gone through 3 bulbs today (and they're not very cheap) as I keep finding that they are breaking after I test the headlights. I have no idea what is going on. I have the foglights plugged in properly as well at the bumper. There were 2 harness plugs that I know were for the fog lights as they plugged in perfectly.

Anyways, ANY HELP IS GREATLY APPRECIATED! I have been searching and searching with no results. Thank you.
* Registered users of the site do not see these ads.
llb_dll is offline   Reply With Quote