View Single Post
Old 05-04-2017, 01:08 AM   #10
methaddict
Scooby Specialist
 
Member#: 159738
Join Date: Sep 2007
Chapter/Region: SCIC
Location: SGV
Vehicle:
2004 WRB STi 620awhp
OFCD V3, FR TS, BW8374EFR

Default

Fuelpro fuel controller was removed due to a circuit board failure so I just hardwired the primary Walbro 450lph pump. Change all rubber hoses, which will eventually expand and crack, to Flex tech reinforced heater hoses. I had a small leak with the turbo return line that I used 90 degree -10 an fittings, steel braided hose, and the Tigwerks -10AN male to o-ringed fitting into the block so I bought a 45 degree -10AN to barb for the return from a flange fitting with a gasket to the chra and a 90 degree -10AN to barb to the Tigwerks fitting and Flex tech silicone hose with some ss worm gear clamps.

To move the K&N filter away from direct heat soak from the turbo I added a 45 degree elbow and I cut up the stock air intake duct to get air to the filter. Also covered the ic piping with some aluminum 2.5" sleeves. I also had to get a new 4 port boost solenoid due to the original one failing.
I also extended the fuel pressure sensor to keep it away from heat soak and engine vibration.

Still using the Radium catch cans which I have to empty after doing any wot pulls on the freeway onramps. I still don't trust air oil separators. This also keeps my regiment of checking the oil levels frequently.
* Registered users of the site do not see these ads.

Last edited by methaddict; 07-05-2017 at 03:51 PM.
methaddict is offline   Reply With Quote