View Single Post
Old 01-15-2019, 05:54 PM   #9
Scooby Specialist
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
1996 Volvo 850 Turbo
with mods :)


Originally Posted by G1bby View Post
Recently got an 07 sti after my 06 wrx was rear ended.

Ive been trying to pair a spare fob i have from my old car (still the teardrop key) as the fob the car came with is a cheesy ebay fob that doesnt work half the time (even with a new battery.) I can't seem to be able to get the car into programming mode. Ive tried just about everything.

here's roughly the routine I have tried over and over:

1) key out of ignition, sitting in drivers seat, all doors and trunk closed

2) open and close driver door

3) put key in ignition and turn from "lock" to "on" 10 times in 15 seconds, finishing on lock and leaving the key in the ignition

4) open and close driver door (still no honk or que from the car of any kind)

5) enter the numbers inside the fob using the lock/unlock switch. Push lock the number of times that equals the value, then unlock between each digit.

6) hit unlock and re-enter the sequence

7) open and close driver door (still no audible or visual que from the car)

and the fob isnt programmed to the car. Ive tried making little tweaks like leaving the key in the "on" position but nothing.

Searching through the forums i see that a turbo timer can cause a problem with this. When i got the car, it came with a turbo timer 'somewhat' installed. The timer was mounted on the dash with the wire going underneath the dash and unplugged. it seems as though the box that the timer went into was taken. There is a ground wire bolted under the steering wheel that seems to be cut. However the black/dark green striped ignition wire is intact, which is what i heard can be the cause of the problem. I traced the wire from the keyless entry module to the ignition switch and a few other modules and it was intact, i even tested it with a multimeter between the connections and it is 100% good.

Im not sure if any other wires are cut or what the deal is. maybe im just doing something completely wrong.

I should add that the car has a custom street tune for the mods (perrin intake, inlet, outlet, catless dp, hks hi power exhaust) Maybe that could have something to do with it?

I tried a few other things to help diagnose the problem:

I am unable to enable the 'chirp' when you lock/unlock the car. the process involves taking the key out of the ignition 6 times. this leads me to believe there is some cut wire somewhere. (i know the chirp is enabled by default from the factory but it was disabled when i got the car)

Also, I AM ABLE to disable the seatbelt chime as the process doesnt involve the ignition switch, only taking the seatbelt in and out of the socket 20 times.

Any info or ideas would be greatly appreciated. The dealer wants $120 to program the fob!
According to the procedure in your owners manual, you need to leave the key in the 'ON' Position to start the programming (so vehicle has power). This might be your issue.

Also, make sure the car is not in valet mode.

I just keep turning the key on and off quickly until the signal. You might be miscounting.
* Registered users of the site do not see these ads.
RexyGirl is offline   Reply With Quote