View Single Post
Old 08-21-2019, 02:45 AM   #1
Ej20ForesterGuy
Scooby Newbie
 
Member#: 504717
Join Date: Jul 2019
Location: Canada
Vehicle:
02 Forester XT

Unhappy Surging Horsepower Under Hard Acceleration

Ok, so I've been having this issue since I got the car a month ago.

Car is a 2002 JDM Forester XT with EJ205 motor. In the last month I have changed the oil, air filter, spark plugs, coolant, serviced the rear dif, got an alignment, and I only run 94 octane in it. Yesterday, I pulled the MAF sensor out and cleaned it. It was really dirty and I'm already getting more power and mileage.

The issue is sometimes I feel like the car has 150 horsepower between 3000 and 4000rpm, then other times it feels like it has 220. It comes and goes. Sometimes while I'm driving, I'll have the throttle at a constant level, then the power will just kick in out of nowhere. Torque converter maybe?

I also occasionally hear a faint scratching sound coming from the front right of the car during hard acceleration. Like someone brushing a pop can with a wire brush. This is a little more often than the power changes, but as I said, only noticeable during hard acceleration. I also hear a moderately loud buzzing noise at idle, almost like a fan is hitting a piece of plastic. Not sure if all these symptoms are related. Just want to give as much info as possible.

Would really like to figure this out before something becomes seriously damaged if it's not already.

Thanks for the insight. You guys have been great so far.

* Registered users of the site do not see these ads.

Last edited by Ej20ForesterGuy; 08-21-2019 at 03:17 AM.
Ej20ForesterGuy is offline   Reply With Quote