View Single Post
Old 04-28-2019, 06:05 PM   #1
SubbieNoob
Scooby Newbie
 
Member#: 305546
Join Date: Jan 2012
Chapter/Region: NESIC
Location: Boston
Vehicle:
2016 WRX
World Rally Blue

Default 02 WRX Phantom Misfire

Hola Nasioc family,

I just bought another bugeye and it has been pissing me off lol but I still love it.

I have been trying to fix a misfire for like a month now but it was an array of issues before I narrowed down a misfire in cylinder 2 and 4. However, the car does not drive any different.

HISTORY

I bought the car with a cracked valve and I bought used OEM heads. Brought them to the machine shop for cleaning, warpage testing, and valve seating. Everything checked out.

Then had the heads replaced and I started experiencing bucking under boost, turned out to be a vacuum leak, checked with a smoke test. Swapped my intercooler, y pipe and leaking hose, now my bucking is gone but the random misfires on cylinder 2 and 4 are still there. Oxygen sensor had a rip on the signal wire, I rewired it and the CEL for that code and the rough idle disappeared. MAF was also changed for precautionary purposes.

I will be changing my coilpacks since I heard one coilpack may cause a misfire code for that bank. Any other ideas?

Timing is not off since I installed the timing belt with the tech. Vacuum is perfect and idle is great. Car pulls amazing with zero issues, the spark plugs were changed with iridium and the clutch is oem exedy with an oem flywheel. Misfires occur randomly at cruising speeds or at idle but never under full throttle.



UPDATES (In Order)
1. Coilpacks changed
2. Misfires more heavily at idle and stalls
3. Used Seafoam in gas with no luck
4. Changed spark plugs, gaped to 0.025
* Registered users of the site do not see these ads.

Last edited by SubbieNoob; 05-13-2019 at 01:10 PM.
SubbieNoob is offline   Reply With Quote