View Single Post
Old 11-18-2014, 05:01 PM   #38
Zeeper
Scooby Specialist
 
Member#: 299286
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Upstate NY
Vehicle:
2017 Legacy Limited
White

Default

Quote:
Originally Posted by danoz View Post
Yeh man, haters gonna hate.

For the hater - The only thing Im trying hard to do, is help people. I do expect some people will not like this and think it was a very simple thing to isolate and I dont deserve any credit. I mean who would have thought every clamp on a brand new engine from a reputable car maunfacturer was working loose or breaking after 3000kms? I agree, It sounds ludicrous, totally unrealistic and even more so the fact that Subaru is either unaware (still) or unwilling to rectify it. And just so you know, this is my first Subaru, and also the first turbo engine I had ever worked on so the learning curve was steep. Also worth mentioning is that I have not made a single dollar from this and I am not trying to sell anyone anything.

Anyway, for those of you who choose to do the job, I hope you enjoy the benefits. And for the people with words of encouragement, I thank you. For those that just want to spew forth abuse and criticism... well... what can you say to people like that really? I also wish you well and hope that you have a happier day tomorrow.
Well I hate that it is too cold in my garage to mess with this, though I have just bought the clamps...

Thanks for updating this thread with pictures, that I just found, it will make the job easier for sure!

As for the trolls, if it causes you any peace, they also troll other threads of NASIOC (hey, they also hate CVT's -- what a surprise!) and the best way to avoid them is using the Ignore feature.

Works for me.
* Registered users of the site do not see these ads.
Zeeper is offline