View Single Post
Old 11-10-2015, 03:36 PM   #3
Scooby Specialist
Member#: 313618
Join Date: Mar 2012
Location: South San Diego
2004 WRX


I kept blowing fuses on the line leading to the relay. I found a short and fixed it. Which was making the pump not come on.

My battery was low so i hooked up a second battery to help it out. The system ran fine during testing but on the second run the fav and pump stayed ON, even after the SYS jumper was disconnected and the amber thresh light stayed on.

I tested every harness to isolate the issue. First trunk, then fav. I figured out how the wiring worked on the Fav and figured out It relays power to the trunk. Which triggers the magnetic coil on the relay.

It was somehow receiving signal and after activation it would not stop. At first i noticed a click of the black coils on the hfs. But after a few resets and disconnecting harnesses depending on if i wanted the coils to trigger or not. I found the only time the amber light (gauge also showed w injection and sometimes both ambers) was if the ecu wire plug was unplugged. Then i saw the brown melted wire on the inside of the rj45 or 10P10C connector. At first it looked like 3 wires were bad but i saw pin 1 and 10 were there for possibly future/different applications. The wire after the connector is fine. So it must have been not making a good contact or arching on the black wire causing an issue after start up.
* Registered users of the site do not see these ads.
KornShaDoW097 is offline   Reply With Quote