View Single Post
Old 05-28-2012, 11:05 PM   #1
Buckchote69
Scooby Newbie
 
Member#: 247790
Join Date: May 2010
Location: colorado
Vehicle:
2007 Subaru WRX STi
Gunmetal Grey?

Default Pioneer AVIC- Z140BH install w/ backup camera/ xm on 2007 sti

yesterday i installed the new Pioneer AVIC Z140BH Nav unit in my 2007 sti. I thought it would be helpful to share my install tips.
Speed Sensor- the green connector connected to the speedometer, and the spliced wire is indeed Green with a black stripe.



Reverse Signal - Instead of having to feed a wire all the way back into the reverse light, i took off the right kick panel and spliced into the Brown/ yellow stripe wire running from the back of the vehicle.



Handbrake bypass option- There are a few videos on youtube showing the procedure to bypass the handbrake switch. the RCA cable wiring harness has a MUTE wire thats yellow/black stripe, all you do is move it one pin above its original connection and connect it with the handbrake wire located on the other wiring harness then you ground it to chassis( what i did is splice it into my ground wire on the harness, which when connected leads to ground in the original subaru wiring harness. which in turn grounds to the radio bracket with a connector. works very well


I installed my XM radio receiver box right below my clock/airbag on/of sensor trim
it seems to fit pretty well and i used double sided tape to hold it in place. it has a ground wire running of off it(i grounded all my wires to the bolt on the driver side under the carpet, the bolt holds the dead pedal in place.


Rear View Camera- I wired the camera from the trunk through the back seat and ran under the passenger carpet. it has 3 wires; brown RCA that runs to the nav unit, and a ground and power wire. the power wire had a 1 amp fuse, so i replaced that with a "add a fuse" wire (with 2 amp fuse) and connected it to #5 fuse behind the coin holder. i installed it this way so it has power when ignition is turned on, so there isn't any signal issues with the brown/yellow reverse signal wire.

Everything was ordered through crutchfield and i am very pleased. I also received the wiring harness that connects the nav unit harness to the original subaru harness and it in fact works. surprisingly the colors on the wires match up with the nav unit wires.


Heres the finished product.





All of the information i used to help me with this install did come from nasioc forums. great sources here

Thanks
Adam
* Registered users of the site do not see these ads.
Buckchote69 is offline   Reply With Quote