View Single Post
Old 08-14-2018, 12:39 AM   #553
White-o
Scooby Newbie
 
Member#: 363497
Join Date: Jul 2013
Chapter/Region: South East
Location: St. Augustine, Fl
Vehicle:
2003 Wrx
Black

Default

Seems like there are a range of different symptoms leading up to this. I have an 03 wrx with a jdm 205 and it started blipping the throttle from 2-3k rpms on my way home the other day. The rpms mostly stayed in that range, but sometimes would rev up to 4. I got it home and parked it. My mechanic thought it could be a vacuum leak, so I went out with a bottle of brake cleaner and started it up. But this time the rpms didn't blip, they just held steady at 3 until they started climbing higher and the engine was cold so I just shut it off. The next time I started it the rpms stayed at 2k but the engine was running terribly and sounded like it was misfiring, and the ecu threw a P1507 (Idle Air Control Valve Misfunction)

I'm going to order a gasket and clean my valve, but the way the car was running on the last start up has me worried.

Also, I loosened the two soft screws and coolant immediately started leaking out, which I didn't see mentioned in this write up. My mechanic told me it will spill out and you need to bleed the system after replacing the valve.

I'm just concerned that other people seem to just have a consistent high or low idle, whereas my car seems to do something worse every time I start it.
* Registered users of the site do not see these ads.
White-o is offline   Reply With Quote