Welcome to the North American Subaru Impreza Owners Club Tuesday March 19, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-20-2019, 09:38 PM   #1
cardude007617
Scooby Specialist
 
Member#: 216556
Join Date: Jul 2009
Chapter/Region: MWSOC
Location: Milwaukee WI
Vehicle:
2017 Impreza Limited
DGM

Default Stock stereo ground loop whine

Our 2017 Impreza Limited seems to have ground loop whine coming through the front passenger side door speaker. Any ideas what might make this happen with all stock stereo components?
* Registered users of the site do not see these ads.
cardude007617 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-20-2019, 09:49 PM   #2
Blktrax
Scooby Specialist
 
Member#: 220971
Join Date: Aug 2009
Chapter/Region: South East
Location: West, NC
Vehicle:
2002 WRX 223K Mi.

Default

Take it in and have it fixed, it's 99% the H/K Amp under the seat. There is a revised part# amp and you're probably 4 versions behind on the radio firmware. Both are covered under 3/36
Blktrax is offline   Reply With Quote
Old 01-20-2019, 10:00 PM   #3
cardude007617
Scooby Specialist
 
Member#: 216556
Join Date: Jul 2009
Chapter/Region: MWSOC
Location: Milwaukee WI
Vehicle:
2017 Impreza Limited
DGM

Default

Is this something that a dealer will be aware of? Itís been in three times for this already and they havenít been able to resolve it. 3/36 still luckily applies
cardude007617 is offline   Reply With Quote
Old 01-20-2019, 10:08 PM   #4
Blktrax
Scooby Specialist
 
Member#: 220971
Join Date: Aug 2009
Chapter/Region: South East
Location: West, NC
Vehicle:
2002 WRX 223K Mi.

Default

APPLICABILITY: 2018MY Legacy and Outback
2018MY Crosstrek
2017 and 2018MY Impreza
SUBJECT: Harman Kardon Gen 3 Audio Amplifier
Operational Concerns

NUMBER: 15-217-18
DATE: 02/19/18

This bulletin announces availability of new audio system amplifiers to address the following
operating concerns with the Harman Kardon Gen 3 infotainment system:
Symptom 1: No audio output is heard but, the volume level displayed changes when turning the
knob
Symptom 2: Audio volume increases to maximum intermittently without turning the knob
Symptom 3: A buzzing, screeching or crackling-type sound is heard coming through the speakers

NOTE: All exchange amplifiers have the new software and circuitry installed
Blktrax is offline   Reply With Quote
Old 01-20-2019, 10:10 PM   #5
Blktrax
Scooby Specialist
 
Member#: 220971
Join Date: Aug 2009
Chapter/Region: South East
Location: West, NC
Vehicle:
2002 WRX 223K Mi.

Default

Also tell them your radio keeps loosing its presets, and you read there is a software update.

The update should take you to version 18.43.20 if they do it correctly.
Blktrax is offline   Reply With Quote
Old 01-20-2019, 10:28 PM   #6
cardude007617
Scooby Specialist
 
Member#: 216556
Join Date: Jul 2009
Chapter/Region: MWSOC
Location: Milwaukee WI
Vehicle:
2017 Impreza Limited
DGM

Default

Was the HK an upgrade in 17? Our door cards by the speakers donít say HK on them. We do have the larger Apple car play stereo that came with the limited. Just want to make sure itís not a case like the wrx where it was an upgrade.
cardude007617 is offline   Reply With Quote
Old 01-20-2019, 11:28 PM   #7
Blktrax
Scooby Specialist
 
Member#: 220971
Join Date: Aug 2009
Chapter/Region: South East
Location: West, NC
Vehicle:
2002 WRX 223K Mi.

Default

It was an upgrade option. Check your window sticker if you still have it.

Package #35 Eyesight, Blind Spot Detection, Rear Cross Traffic Alert, Moonroof (tilt/slide with sunshade), Navigation, Harman/Kardon 432w equiv amp and 8 speakers
MSRP $3845

It's either an external amp or the internal amp in the head unit is bad.

Last edited by Blktrax; 01-20-2019 at 11:56 PM.
Blktrax is offline   Reply With Quote
Old 01-22-2019, 10:12 AM   #8
SirBrass
Scooby Specialist
 
Member#: 207263
Join Date: Mar 2009
Chapter/Region: Tri-State
Location: Northern PA
Vehicle:
2019 WRX Limited
World Rally Blue

Default

Quote:
Originally Posted by cardude007617 View Post
Was the HK an upgrade in 17? Our door cards by the speakers donít say HK on them. We do have the larger Apple car play stereo that came with the limited. Just want to make sure itís not a case like the wrx where it was an upgrade.
Unless WRX is a 2019, you don't have apple carplay with the stock unit. And for those, Android Auto/Apple Carplay is standard on all trims, all options.

And if you have the HK system, your door speakers will have the Harmon Kardon tag. If you don't see it, you don't have it.
SirBrass is offline   Reply With Quote
Old 01-22-2019, 12:10 PM   #9
Blktrax
Scooby Specialist
 
Member#: 220971
Join Date: Aug 2009
Chapter/Region: South East
Location: West, NC
Vehicle:
2002 WRX 223K Mi.

Default

I believe weíre talking about a 17í Impreza, not a WRX
Blktrax is offline   Reply With Quote
Old 01-22-2019, 12:11 PM   #10
SirBrass
Scooby Specialist
 
Member#: 207263
Join Date: Mar 2009
Chapter/Region: Tri-State
Location: Northern PA
Vehicle:
2019 WRX Limited
World Rally Blue

Default

Quote:
Originally Posted by Blktrax View Post
I believe weíre talking about a 17í Impreza, not a WRX
Wasn't sure. Poster didn't specify and his profile only lists the 16 WRX.
SirBrass is offline   Reply With Quote
Old 01-24-2019, 02:21 PM   #11
cardude007617
Scooby Specialist
 
Member#: 216556
Join Date: Jul 2009
Chapter/Region: MWSOC
Location: Milwaukee WI
Vehicle:
2017 Impreza Limited
DGM

Default

Correct, itís a 17 Impreza Limited. Not the WRX in my profile.
cardude007617 is offline   Reply With Quote
Old 02-18-2019, 12:46 PM   #12
cardude007617
Scooby Specialist
 
Member#: 216556
Join Date: Jul 2009
Chapter/Region: MWSOC
Location: Milwaukee WI
Vehicle:
2017 Impreza Limited
DGM

Default

Quote:
Originally Posted by Blktrax View Post
Take it in and have it fixed, it's 99% the H/K Amp under the seat. There is a revised part# amp and you're probably 4 versions behind on the radio firmware. Both are covered under 3/36
Hi-
Where is the amplifier? is it under the carpet beneath the seat? I looked this weekend and didn't see/feel anything...
cardude007617 is offline   Reply With Quote
Old 02-18-2019, 01:24 PM   #13
Blktrax
Scooby Specialist
 
Member#: 220971
Join Date: Aug 2009
Chapter/Region: South East
Location: West, NC
Vehicle:
2002 WRX 223K Mi.

Default

Under the front part of the passenger seat if there is one.
Blktrax is offline   Reply With Quote
Old 02-18-2019, 01:56 PM   #14
cardude007617
Scooby Specialist
 
Member#: 216556
Join Date: Jul 2009
Chapter/Region: MWSOC
Location: Milwaukee WI
Vehicle:
2017 Impreza Limited
DGM

Default

Quote:
Originally Posted by Blktrax View Post
Under the front part of the passenger seat if there is one.
Unless there is carpet over it, it wasnt there.

The TSB is still valid if I don't have the stand alone amp right?

The car has been in 2 more times since I started this thread and they are telling me its a cvt pump noise and it's normal. This is completely wrong.

This weekend it was making the noise and I pulled the fuse for the radio and the noise stopped immediately. It's the radio (or the alternator's current is dirty).

Any advise to get this fixed?
cardude007617 is offline   Reply With Quote
Old 02-18-2019, 05:42 PM   #15
Blktrax
Scooby Specialist
 
Member#: 220971
Join Date: Aug 2009
Chapter/Region: South East
Location: West, NC
Vehicle:
2002 WRX 223K Mi.

Default

Its the internal amp then , basically you're going to have to show them exactly what you did; pull the fuse and the noise quits.

Also be aware there is an internal Fan in the head unit.
Blktrax is offline   Reply With Quote
Old 02-20-2019, 07:54 AM   #16
Onyanineza
Scooby Newbie
 
Member#: 495426
Join Date: Dec 2018
Default

In your backsits?
Onyanineza is offline   Reply With Quote
Old 02-23-2019, 12:09 AM   #17
cardude007617
Scooby Specialist
 
Member#: 216556
Join Date: Jul 2009
Chapter/Region: MWSOC
Location: Milwaukee WI
Vehicle:
2017 Impreza Limited
DGM

Default

Update:
So since we pulled the radio fuse a few times messing around with things...now the noise has stopped for a few days. What the heck?
cardude007617 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.