Welcome to the North American Subaru Impreza Owners Club Tuesday March 2, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-20-2020, 03:04 PM   #1
The Bone
Scooby Newbie
 
Member#: 517567
Join Date: Aug 2020
Vehicle:
2020 WRX
Rally Blue

Default rear camera actuator switch burnt out ?

2020 wrx

rear camera isnt working
service dept says the switch that sits on the tranny that tells the camera to engage is burnt out...was not operational from the factory at time of delivery

car has 101 miles on it
have owned it 7 days
it has been in service for 4 of them

anyone have this issue?

fml
* Registered users of the site do not see these ads.
The Bone is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-20-2020, 04:50 PM   #2
The Bone
Scooby Newbie
 
Member#: 517567
Join Date: Aug 2020
Vehicle:
2020 WRX
Rally Blue

Default

at least i have a really cool powder blue forester loaner "until further notice"
The Bone is offline   Reply With Quote
Old 10-22-2020, 12:03 PM   #3
The Bone
Scooby Newbie
 
Member#: 517567
Join Date: Aug 2020
Vehicle:
2020 WRX
Rally Blue

Default

ill take that as a no

anyone know an active wrx/subaru forum?
The Bone is offline   Reply With Quote
Old 10-31-2020, 10:46 AM   #4
Elbert Bass
Scooby Specialist
 
Member#: 283429
Join Date: May 2011
Chapter/Region: South East
Location: Down yonder.
Vehicle:
2016 Fuji Sunfire 03
Silver

Default

If that is the real cause AND it is a manual transmission that is just the back-up light switch - nothing special or new - all manual transmissions have one. 9 years working Subaru Dealer and never seen one bad on a new car - replaced 3 of them on cars over 50,000 miles, maybe one or two over 15,000.

Given they did not catch the fault at PDI before you bought the car I personally would question whether they have made the proper diagnosis. When I have seen the back-up camera not work in new cars it was usually a software glitch that was cured by capacitive discharge (disconnecting battery). The equivalent of restarting your computer. I have heard of some models having BIU issues, but given that model has the newer radio I am not familiar with the communication and data flow which may be different in 2020.

The car has been at the dealer 4 days? What day did they tell you what the problem was? Once they have diagnosed the problem if they don't stock the part most dealers are 1-2 days shipping from their PDC, unless their nearest PDC is out of stock. Then it could take 3-5 days unless it is on national back-order. Manual trans back-up switch takes about 1/2 hour to replace

But hey - I quit Subaru before the 2020 new model updates were out, I'm not there, I'm not the tech looking at your car, and ANYTHING I say is just speculation. I will say that if it is the back-up light switch you are that 1 in 500,000 lucky persons that got a bad switch out of the box and that is why no one has responded to your post.

Last edited by Elbert Bass; 10-31-2020 at 11:02 AM.
Elbert Bass is offline   Reply With Quote
Old 11-02-2020, 01:53 PM   #5
The Bone
Scooby Newbie
 
Member#: 517567
Join Date: Aug 2020
Vehicle:
2020 WRX
Rally Blue

Default

car is CVT
they say it was an actuator switch, then they wanted to change the tranny harness just to be safe

now they have brought in 2 engineers from SOA to work on the car.
its been at service about 2 weeks now

they are already talking about compensation packages and such(valueless if im in service every few weeks with a mystery electrical glitch)

my loaner crosstrek sucks
The Bone is offline   Reply With Quote
Old 11-03-2020, 04:50 PM   #6
TheClutchRider
Scooby Newbie
 
Member#: 519866
Join Date: Nov 2020
Location: Cleveland, OH
Vehicle:
2017 WRX Premium
WRB, what else

Default

does the image change when it goes to reverse? Do you get a blank black screen? I had that issue on mine when i upgraded the head unit, and it turned out to be that i did not plug the harness into the OBD2 port because of the access port. My 17 had a separate harness going into the CAN from the head unit.
TheClutchRider is offline   Reply With Quote
Old 11-03-2020, 07:51 PM   #7
Elbert Bass
Scooby Specialist
 
Member#: 283429
Join Date: May 2011
Chapter/Region: South East
Location: Down yonder.
Vehicle:
2016 Fuji Sunfire 03
Silver

Default

Quote:
Originally Posted by The Bone View Post
car is CVT
they say it was an actuator switch, then they wanted to change the tranny harness just to be safe

now they have brought in 2 engineers from SOA to work on the car.
its been at service about 2 weeks now

they are already talking about compensation packages and such(valueless if im in service every few weeks with a mystery electrical glitch)

my loaner crosstrek sucks
Then forget everything I posted. Obviously if they have two engineers at the dealer for that problem you got some serious LAN/CAN bus problems. I would push for a buyback.
Elbert Bass is offline   Reply With Quote
Old 11-04-2020, 09:52 AM   #8
The Bone
Scooby Newbie
 
Member#: 517567
Join Date: Aug 2020
Vehicle:
2020 WRX
Rally Blue

Default

Quote:
Originally Posted by TheClutchRider View Post
does the image change when it goes to reverse? Do you get a blank black screen? I had that issue on mine when i upgraded the head unit, and it turned out to be that i did not plug the harness into the OBD2 port because of the access port. My 17 had a separate harness going into the CAN from the head unit.
no image change or anything, its like its not there

funny part is when i realized it wasnt working i got out of the car to make sure the camera was there and then checked my window sticker to make sure it was paid for
The Bone is offline   Reply With Quote
Old 11-07-2020, 11:58 AM   #9
The Bone
Scooby Newbie
 
Member#: 517567
Join Date: Aug 2020
Vehicle:
2020 WRX
Rally Blue

Default

day 18....their update is "a few more days but sometime this upcoming week"...i keep asking them for a detailed explanation but im getting nothing

but they keep saying "my compensation package is growing"
The Bone is offline   Reply With Quote
Old 11-09-2020, 08:09 PM   #10
Elbert Bass
Scooby Specialist
 
Member#: 283429
Join Date: May 2011
Chapter/Region: South East
Location: Down yonder.
Vehicle:
2016 Fuji Sunfire 03
Silver

Default

Quote:
Originally Posted by The Bone View Post
day 18....their update is "a few more days but sometime this upcoming week"...i keep asking them for a detailed explanation but im getting nothing

but they keep saying "my compensation package is growing"
YOU ARE DONE WITH THIS CAR.
Subaru's only option at this point is a buy back or give another car. You need to make this point very clear to them. You know a lawyer that will write a letter for you?
Elbert Bass is offline   Reply With Quote
Old 11-10-2020, 02:38 PM   #11
The Bone
Scooby Newbie
 
Member#: 517567
Join Date: Aug 2020
Vehicle:
2020 WRX
Rally Blue

Default

the dealer is on my side(personal acquaintance)
the claim has been submitted to Subaru Corp

day 21 currently
The Bone is offline   Reply With Quote
Old 11-10-2020, 03:36 PM   #12
The Bone
Scooby Newbie
 
Member#: 517567
Join Date: Aug 2020
Vehicle:
2020 WRX
Rally Blue

Default

they just called me....

they are ordering me a new identical car and sending this one back to subaru(redflagged cant be sold)
The Bone is offline   Reply With Quote
Old 11-14-2020, 11:47 AM   #13
Elbert Bass
Scooby Specialist
 
Member#: 283429
Join Date: May 2011
Chapter/Region: South East
Location: Down yonder.
Vehicle:
2016 Fuji Sunfire 03
Silver

Default

Quote:
Originally Posted by The Bone View Post
they just called me....

they are ordering me a new identical car and sending this one back to subaru(redflagged cant be sold)
Good, Subaru usually does the right thing - sadly there seems to be a marked increase in QC according to my friends that are still working at Subaru.
Elbert Bass is offline   Reply With Quote
Old 12-18-2020, 08:31 PM   #14
The Bone
Scooby Newbie
 
Member#: 517567
Join Date: Aug 2020
Vehicle:
2020 WRX
Rally Blue

Default

Quote:
Originally Posted by Elbert Bass View Post
Good, Subaru usually does the right thing - sadly there seems to be a marked increase in QC according to my friends that are still working at Subaru.
i might need to make another thread.....lol
the saga continues
The Bone is offline   Reply With Quote
Old 12-18-2020, 08:49 PM   #15
The Bone
Scooby Newbie
 
Member#: 517567
Join Date: Aug 2020
Vehicle:
2020 WRX
Rally Blue

Default

The Bone is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:58 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.