Welcome to the North American Subaru Impreza Owners Club Thursday April 2, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-21-2015, 10:04 PM   #3101
Smurftastic
Scooby Guru
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
17.4 PSI ECUtuned 02
BLOD Cofounder|TopScoob31

Default

Two years ago I did a tuck and shave job in the engine bay with all new sheet metal. After two years paint started flaking off the sheet metal... had to strip allllll the paint down, add new filler to smooth out imperfections... and now get to repaint... with the engine still in >
* Registered users of the site do not see these ads.
Smurftastic is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-22-2015, 06:21 PM   #3102
vadersaysno
Scooby Newbie
 
Member#: 414300
Join Date: Feb 2015
Location: Alexandria, VA
Vehicle:
2011 Impreza 2.5i
Gray

Default

Yesterday I actually placed the order for my Hella Sharptones.

Took the car through the touch less car wash (Shell across from Edison HS). It usually does a nice job, but this time the rear still looks dirty. I'm quite disappointed.
vadersaysno is offline   Reply With Quote
Old 03-22-2015, 09:23 PM   #3103
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

T6 oil change with oem subaru filter, balanced summer wheels and put those on.

http://www.imgur.com/Br3hG9O.jpeg
EvileyeZ88 is offline   Reply With Quote
Old 03-22-2015, 10:30 PM   #3104
justanotherjeep
Scooby Newbie
 
Member#: 347956
Join Date: Feb 2013
Chapter/Region: MAIC
Location: MD
Vehicle:
2012 STI
PBP

Default

After two years of ownership I finally flashed to stage one and installed a Q300 exhaust. I also mounted some Michelin Pilot Super Sports.
justanotherjeep is offline   Reply With Quote
Old 03-23-2015, 02:53 PM   #3105
cagustin
Scooby Newbie
 
Member#: 298152
Join Date: Oct 2011
Chapter/Region: MAIC
Location: Dale City, VA
Vehicle:
2009 Impreza WRX
Satin White Pearl

Default

I finally got back into another Subaru last week, 2009 satin white pearl WRX wagon. I picked up an Accessport v3 this morning!
cagustin is offline   Reply With Quote
Old 03-23-2015, 08:23 PM   #3106
Oaf02Z
Scooby Specialist
 
Member#: 263219
Join Date: Nov 2010
Chapter/Region: MAIC
Location: NOVA
Default

Jim, let's see them mounted up.
Oaf02Z is offline   Reply With Quote
Old 03-23-2015, 10:46 PM   #3107
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Here's a crappy night time picture.

http://www.imgur.com/H5JufYY.jpeg

Had to run a 5mm spacer to clear the brembos up front

http://www.imgur.com/bPGDbIu.jpeg

This would be acceptable if I had sedan front end..
EvileyeZ88 is offline   Reply With Quote
Old 03-23-2015, 11:42 PM   #3108
Oaf02Z
Scooby Specialist
 
Member#: 263219
Join Date: Nov 2010
Chapter/Region: MAIC
Location: NOVA
Default

Pokeage, what are the wheel and tires specs?
Oaf02Z is offline   Reply With Quote
Old 03-24-2015, 12:10 AM   #3109
Red-Rex
Scooby Newbie
 
Member#: 343261
Join Date: Jan 2013
Chapter/Region: MAIC
Location: Shacklefords VA
Vehicle:
2012 WRX Hatch
Lightning Red

Default

Did several things today.
Changed Spark plugs
Transmission and Diff service
Hella's
Cobb SF intake and box
Accesport V3 & Stage 1 Tune
CNT Racing Catback
LED Plate bulbs
Grimspeed license plate relocator
Wrx plate delete

Still have a few more parts to put on just ran out of time today
Red-Rex is offline   Reply With Quote
Old 03-24-2015, 06:13 AM   #3110
RavensFan7
Scooby Specialist
 
Member#: 346388
Join Date: Feb 2013
Chapter/Region: MAIC
Location: PA
Vehicle:
2001 Ej205 Impreza L
SRP

Default

Yesterday I journeyed down to AndrewTech for an alignment. Also had the trans and rear diff fluid changed.
RavensFan7 is offline   Reply With Quote
Old 03-24-2015, 10:17 AM   #3111
Mingwhying
Scooby Newbie
 
Member#: 333675
Join Date: Sep 2012
Chapter/Region: SCIC
Vehicle:
2009 Impreza WRX
Satin Pearl White

Default

This week i changed the spark plugs and finally got an accessport v3 and sf intake with box! WOOOHOOOOO!!!




Mingwhying is offline   Reply With Quote
Old 03-24-2015, 10:32 AM   #3112
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Motegi sp10 18x8 +40 with a 5mm hub centric spacer. Tires are BFG KDW 215/40/18

Fenders are slightly rolled, so I'm not worried about cutting the tires.
http://www.imgur.com/Aw9qpCu.jpeg

http://www.imgur.com/aJwMgNo.jpeg

its not even that wide of a setup, I'm just really limited by the wagon fenders.

Last edited by EvileyeZ88; 03-24-2015 at 11:21 AM.
EvileyeZ88 is offline   Reply With Quote
Old 03-24-2015, 10:46 AM   #3113
Oaf02Z
Scooby Specialist
 
Member#: 263219
Join Date: Nov 2010
Chapter/Region: MAIC
Location: NOVA
Default

For 215 looks meaty. Maybe BC of the poke?


Flares coming your way?
Oaf02Z is offline   Reply With Quote
Old 03-24-2015, 11:28 AM   #3114
Abnormal
Lil Curious
Moderator
 
Member#: 149626
Join Date: May 2007
Chapter/Region: MAIC
Location: zip22182
Vehicle:
2005 CGM FXT
Rocket Box! :D

Default

Quote:
Originally Posted by Oaf02Z View Post
For 215 looks meaty. Maybe BC of the poke?


Flares coming your way?
Looks like he could use just a smidge of extra camber in the front and be ok!
Abnormal is offline   Reply With Quote
Old 03-24-2015, 12:09 PM   #3115
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

No flares, I'll do STI front end before I do flares.

I'll settle the alignment this week, I ran out of time on sunday, had to unmount 4 tires and then re mount them on my wifes summer wheels, then put them on her car too.
EvileyeZ88 is offline   Reply With Quote
Old 03-24-2015, 12:51 PM   #3116
15WRX_MD
Scooby Newbie
 
Member#: 404807
Join Date: Oct 2014
Chapter/Region: MAIC
Location: Baltimore, Maryland
Vehicle:
2015 WRX
Crystal Black Silica

Default What did you really do to your car today? V3.1

Installed these. I'll post up some pics on the car later.

ImageUploadedByNASIOC1427215871.337366.jpg

Should've bought TPMS's. Lights already getting on my nerves.


Sent from my iPhone using NASIOC
15WRX_MD is offline   Reply With Quote
Old 03-24-2015, 01:52 PM   #3117
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

^Put a piece of electrical tape over the light. Problem solved lol.
EvileyeZ88 is offline   Reply With Quote
Old 03-24-2015, 02:18 PM   #3118
Squattro
Scooby Specialist
 
Member#: 357064
Join Date: May 2013
Chapter/Region: MAIC
Location: SoPA
Vehicle:
2015 Subaru WRX
GBP

Default

Quote:
Originally Posted by EvileyeZ88 View Post
^Put a piece of electrical tape over the light. Problem solved lol.
Ha, that's a perfect idea. When I had my winter set on, my seat position and wheel position was perfectly lined up to when I sat normally, I couldn't see the light
Squattro is offline   Reply With Quote
Old 03-24-2015, 05:32 PM   #3119
15WRX_MD
Scooby Newbie
 
Member#: 404807
Join Date: Oct 2014
Chapter/Region: MAIC
Location: Baltimore, Maryland
Vehicle:
2015 WRX
Crystal Black Silica

Default

My summer setup until stock rubber is shot. These will become my winter wheels and I'll go for some 18's for summer. 17x8 +45 Rota Titans Hyper Black. God it's good to be back on summer tires...

ImageUploadedByNASIOC1427232661.454550.jpg
ImageUploadedByNASIOC1427232685.204547.jpg
ImageUploadedByNASIOC1427232702.903993.jpg
ImageUploadedByNASIOC1427232728.556408.jpg


Sent from my iPhone using NASIOC
15WRX_MD is offline   Reply With Quote
Old 03-24-2015, 05:39 PM   #3120
15WRX_MD
Scooby Newbie
 
Member#: 404807
Join Date: Oct 2014
Chapter/Region: MAIC
Location: Baltimore, Maryland
Vehicle:
2015 WRX
Crystal Black Silica

Default

Quote:
Originally Posted by EvileyeZ88 View Post
^Put a piece of electrical tape over the light. Problem solved lol.

I like it! The '15s not only give you a light but every time you start the car it gives the warning chime, the TPMS light flashes for a few minutes then stays lit and the yellow "I" indicator by the odometer stays lit. For some reason just a simple light did not suffice.


Sent from my iPhone using NASIOC
15WRX_MD is offline   Reply With Quote
Old 03-25-2015, 09:51 AM   #3121
idrivea911
Scooby Newbie
 
Member#: 380935
Join Date: Feb 2014
Chapter/Region: MAIC
Location: Alexandria, VA
Vehicle:
2006 Saab 9-2x Aero
Silver

Default

Quote:
Originally Posted by 15WRX_MD View Post
I like it! The '15s not only give you a light but every time you start the car it gives the warning chime, the TPMS light flashes for a few minutes then stays lit and the yellow "I" indicator by the odometer stays lit. For some reason just a simple light did not suffice.
Thanks, Obama!
idrivea911 is offline   Reply With Quote
Old 03-25-2015, 10:06 AM   #3122
ThatGy
Scooby Newbie
 
Member#: 137791
Join Date: Jan 2007
Chapter/Region: RMIC
Location: Holly Ridge, NC
Vehicle:
2002 Impreza WRX
WR Blue

Default

Quote:
Originally Posted by 15WRX_MD View Post
I like it! The '15s not only give you a light but every time you start the car it gives the warning chime, the TPMS light flashes for a few minutes then stays lit and the yellow "I" indicator by the odometer stays lit. For some reason just a simple light did not suffice.


Sent from my iPhone using NASIOC
Here's a crazy idea, get more TPMS sensors for your other wheels.
ThatGy is offline   Reply With Quote
Old 03-25-2015, 11:12 AM   #3123
acumenhokie
Scooby Specialist
 
Member#: 271479
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Talleyville, DE
Vehicle:
2010 LGT
2009 FXT

Default



acumenhokie is offline   Reply With Quote
Old 03-25-2015, 02:30 PM   #3124
rtpurdum
Scooby Newbie
 
Member#: 392146
Join Date: May 2014
Chapter/Region: MAIC
Location: Frederick, MD
Vehicle:
2011 WRX Hatch
SWP

Default

Oh nooooo. Looks like the one that came out of my 04 wrx. Shambles! Sorry to see that
rtpurdum is offline   Reply With Quote
Old 03-25-2015, 02:49 PM   #3125
acumenhokie
Scooby Specialist
 
Member#: 271479
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Talleyville, DE
Vehicle:
2010 LGT
2009 FXT

Default

Weak a55 split case PoS.

Too bad I have a total of 0 upgrade options without fabrication. ****!
acumenhokie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 02:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.