Welcome to the North American Subaru Impreza Owners Club Tuesday October 15, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-25-2014, 01:46 PM   #1
Levi3434
Scooby Newbie
 
Member#: 327489
Join Date: Jul 2012
Default 2008 Impreza 2.5i, CEL P0134

Having a P0134 (Front o2 sensor) and occasionally a P0031 (misfired?) Which from what I've read are related and both point to a bad front o2 sensor.

I'd like to do the work myself, since it seems pretty simple.

Not 100% sure which sensor is the o2 sensor. I have one before the cat, that has a grey cable/plug and one that goes into the cat(i think) that's orange. I can post pictures later if needed. I think the grey one is the one I need to replace. Anyway, I found 2 Denso (I think these are OEM?) sensors, not sure which one I need.

If I take the old one out will it have the part number written on it somewhere?

Here's a link of the 2 sensors.

Denso 234-4445
http://www.amazon.com/Denso-234-4445-Oxygen-Sensor/dp/B001F7CFPU/ref=sr_1_4?s=automotive&ie=UTF8&qid=1411655347&vehicle=2008-13-62-233-----167------1-0&sr=1-4&ymm=2008%3Asubaru%3Aimpreza
Denso 234-9123
http://www.amazon.com/Denso-234-9123-Oxygen-Sensor-Ratio/dp/B001F7EK44/ref=pd_sim_auto_1?ie=UTF8&refRID=1X6H0KKHY5K3TTHBDEKG
Any help would be great, thanks.
Levi3434 is offline   Reply With Quote
Old 08-28-2019, 07:16 PM   #2
Goliat6288
Scooby Newbie
 
Member#: 297080
Join Date: Oct 2011
Location: Pittsburgh, PA
Vehicle:
2008 WRX
Black

Default

hate to revive an old thread but its the only one i found that'close to what i have to ask/post.

i have 2008 WRX. ive owned it for all of three deys. im new to subbys.

i have a CEL, TPMS and Stability control light on and a blinking cruise control light. the only codes that come up are
-P0031- HO2S heater control circuit low (bank 1 sensor 1)
-P0134 - O2 sensor circuit no activity detected (bank 1 sensor 1)

car also turns off once in a while when im either slowing down in neutral or stopped completely in neutral. steering also gets hard during some turns but im guessing thats the car trying to turn off and power steering not working.

any insight or help is much appreciated
Goliat6288 is offline   Reply With Quote
Old 09-02-2019, 10:28 AM   #3
CaptainSlowbaru
Scooby Newbie
 
Member#: 445600
Join Date: Apr 2016
Chapter/Region: Tri-State
Location: Rafferty Subaru, PA
Vehicle:
2002 Outback Sport
Green

Default

You most likely need a new A/F sensor. The A/F (air/ fuel) sensor is what Subaru's use for an upstream O2 sensor.
CaptainSlowbaru is offline   Reply With Quote
Old 09-11-2019, 06:53 PM   #4
Goliat6288
Scooby Newbie
 
Member#: 297080
Join Date: Oct 2011
Location: Pittsburgh, PA
Vehicle:
2008 WRX
Black

Default

Thanks captain

i tried replacing it and ended up rounding it out. took it to shop and they got it out and replaced. cel, cruise control and stability control light off now. TPMS light still on and blinking so im guessing the sensors are out of battery. no biggie though

edit; oh and my car isnt turning off anymore when slowing down or coming to a stop

Last edited by Goliat6288; 09-11-2019 at 06:54 PM. Reason: more info
Goliat6288 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:50 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.