Welcome to the North American Subaru Impreza Owners Club Thursday October 28, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-23-2021, 01:33 PM   #1
Brandon Wedderburn
Scooby Newbie
 
Member#: 492858
Join Date: Oct 2018
Location: Jamaica
Vehicle:
2011 JDM Impreza STi
Grey

Default Fuel Pressure dropping when car warms up/ becomes hot

Good Day, Just Rebuilt my 2011 STi broke it in and have been trying to tune but the car develops a weird issue after a few pulls where it starts to lean out, (while on the dyno we checked the mechanical gauge connected to the fpr and noticed the fuel pressure started falling which seems to be the cause) I have installed a brand new pump, hardwired the pump, changed the fuel filter, changed injectors, changed the map sensor, checked the FPR (functions just fine), tested the 02 sensor, disconnected the water injection as well as checked the voltage from the controller to the pump during the pull (seems stable), has anyone experienced this issue or possibly has any insight on this as my tuner and mechanic are both stumped. As a sidenote or it may be completely unrelated but we realized as well when it starts doing this and the AC is running the car starts idling funny AFR is running from full lean to full rich at idle.

Relevant Mods:
Grimmspeed 3 port abcs
Grimmspeed TMIC
GFB Respons BOV
AEM Water/Methanol Kit
DW1000cc Injectors
Dw300c fuel pump
Radium Fuel Pressure Regulator
Twin Scroll Blouch Dom 1.5 XT-R
IAG V3 Competition AOS
Omni-Power 4 Bar map sensor
HKS 3 Inch Super Turbo Exhaust
3 Inch Downpipe
Loudvalves 3" Boost activated exhaust cutout
Perrin 3 inch silicone Turbo Inlet Hose
* Registered users of the site do not see these ads.
Brandon Wedderburn is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-23-2021, 04:21 PM   #2
subaru_gc8
Scooby Specialist
 
Member#: 29292
Join Date: Nov 2002
Chapter/Region: SCIC
Location: Orange County CA
Vehicle:
2004 WRX wagon
silver

Default

have you tried changing the rails?
subaru_gc8 is offline   Reply With Quote
Old 09-24-2021, 09:42 AM   #3
Brandon Wedderburn
Scooby Newbie
 
Member#: 492858
Join Date: Oct 2018
Location: Jamaica
Vehicle:
2011 JDM Impreza STi
Grey

Default

Quote:
Originally Posted by subaru_gc8 View Post
have you tried changing the rails?
It's really not something we've looked at as we were running the same stock rails before at 19psi but the issue is still occurring now with the car turned down to 15 and performs within parameters for the first few pulls.
Brandon Wedderburn is offline   Reply With Quote
Old 09-24-2021, 02:32 PM   #4
umscooby
Scooby Specialist
 
Member#: 50902
Join Date: Dec 2003
Chapter/Region: RMIC
Location: The Mountains
Vehicle:
98 GM6
60mm WB

Default

New pump and you've monitored voltage so perplexing. However, I would definitely ditch the DW1000's as they have a bad reputation for being a tuners worst nightmare. Ask me how I know.
umscooby is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:05 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.