Welcome to the North American Subaru Impreza Owners Club Friday November 27, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-20-2020, 04:21 PM   #1
Conster102
Scooby Newbie
 
Member#: 519178
Join Date: Oct 2020
Unhappy Reverted to stock airbox and AFR's are trash

2003 usdm wrx 5mt hatchback. It was running a garbage plastic k&n air intake with no tune when I bought it so I went back to stock airbox so my AFR's would go back to normal but this was not the case.

My only MOD is a grimmspeed decatted uppipe. Got a smoke test no vacuum leaks nor exhaust leaks nor CEL's. I have 2 logs one of me chilling under 3k rpms and one of me flooring it in 2nd gear. People tell me you can have a decatted uppipe with no tune so I do not understand what is going on.

I have recently changed oil, replaced AFR sensor in the exhaust manifold, cleaned my MAF, replaced both front cv's and it was recent adding the grimmspeed uppipe.

Do I need to tune it? If so what would you recommend? There is less backpressure so that would make me run rich anyway right? But my AFR correction is positive 25 meaning its running lean so I am confused. Also I do NOT have a wideband is that a necessity when looking at AFR's even with a mostly stock car.

Logs: https://drive.google.com/file/d/1nA8...ew?usp=sharing -cruisin
https://drive.google.com/file/d/1Va2...ew?usp=sharing - WOT

Also I am a noob so feel free to correct me on anything I assumed here
* Registered users of the site do not see these ads.

Last edited by Conster102; 11-20-2020 at 04:27 PM. Reason: I don't have a wideband
Conster102 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-20-2020, 04:26 PM   #2
supermarkus
Scooby Guru
 
Member#: 6971
Join Date: May 2001
Chapter/Region: NWIC
Location: Edmonds, Washington, USA
Vehicle:
2008 WRX STi
SSM

Default

Did you reset the ECU and give it a chance to relearn? Also be sure you didn't cut the MAF o-ring or otherwise damage it when you cleaned it off, even a small cut in it will lead to weird behavior on throttle.
supermarkus is offline   Reply With Quote
Old 11-20-2020, 04:32 PM   #3
Conster102
Scooby Newbie
 
Member#: 519178
Join Date: Oct 2020
Default

O-ring like the thing that seals the MAF to the airbox? I honestly don't remember seeing one but wouldn't that be easy to detect with the smoke test? I did reset it and gave it a chance to learn and I was still regularly getting knock correction if I got into boost at all which prompted me to reset it this most recent time. How long does the learning process take? I guess the first time I only gave it a few days to learn but my IAM was at 4/16 so I decided to reset it.
Conster102 is offline   Reply With Quote
Old 11-20-2020, 04:39 PM   #4
Conster102
Scooby Newbie
 
Member#: 519178
Join Date: Oct 2020
Default

So should I just baby it for like a month or two and check again?

Last edited by Conster102; 11-20-2020 at 04:43 PM. Reason: I found IAM on romraider. IAM an idiot
Conster102 is offline   Reply With Quote
Old 11-20-2020, 04:47 PM   #5
supermarkus
Scooby Guru
 
Member#: 6971
Join Date: May 2001
Chapter/Region: NWIC
Location: Edmonds, Washington, USA
Vehicle:
2008 WRX STi
SSM

Default

No, i don't use ROM raider. Don't own a WRX anymore. You can remove the maf and take the o-ring off and gently pinch and roll it around in your fingers. If there are cracks or nicks in it, those can be a source of error in your MAF readings. I had one little pacman bite out of my o-ring after pinching it during a cleaning and that made my car stutter and stumble on tip-in.

There's a technique to resetting your IAM and forcing it to 16 but I forget how it was done in those cars. something like left foot braking to hold rpm at 2500 in 2nd or 3rd gear for a number of seconds.
supermarkus is offline   Reply With Quote
Old 11-20-2020, 05:16 PM   #6
Conster102
Scooby Newbie
 
Member#: 519178
Join Date: Oct 2020
Default

Oh yea I saw that somewhere on here before just need to find it again. I will check my O-ring. But my car doesn't like stumble or anything I just logged with IAM with romraider and I am at 8 which is an improvement but still not great. It just bothers me that with all OEM parts, save for the up pipe, the car would be struggling so hard to get correct AFRs and have to cut the ignition timing in half to run correctly.
Conster102 is offline   Reply With Quote
Old 11-20-2020, 05:20 PM   #7
Zak6182
Scooby Newbie
 
Member#: 481754
Join Date: Feb 2018
Location: Beaufort, SC
Vehicle:
2017 STi Base
Black

Default

What did you clean your MAF with?
Zak6182 is offline   Reply With Quote
Old 11-20-2020, 05:31 PM   #8
Conster102
Scooby Newbie
 
Member#: 519178
Join Date: Oct 2020
Default

Inspected my O-ring and it was fine. Cleaned my MAF with this https://www.googleadservices.com/pag...gQIAxBa&adurl=
Conster102 is offline   Reply With Quote
Old 11-20-2020, 06:01 PM   #9
Conster102
Scooby Newbie
 
Member#: 519178
Join Date: Oct 2020
Unhappy

Found the trick https://forums.nasioc.com/forums/sho...d.php?t=302047 and I did the trick exactly as instructed but my IAM is still at 8. Is the air/fuel reading drawn exclusively from the o2 sensor in my exhaust manifold? I might try to return it and get another one. If the Subie dealer says I have no exhaust leaks nor vacuum leaks and my MAF is seated correctly there is no reason my IAM shouldn't be 16 right?
Conster102 is offline   Reply With Quote
Old 11-20-2020, 07:58 PM   #10
Zak6182
Scooby Newbie
 
Member#: 481754
Join Date: Feb 2018
Location: Beaufort, SC
Vehicle:
2017 STi Base
Black

Default

Can you try swapping out the maf with a good one? I had weird issues with mine running rich and lean when the maf was going bad. Cleaning helped for little while but eventually I was cleaning it almost everyday
Zak6182 is offline   Reply With Quote
Old 11-20-2020, 09:52 PM   #11
Conster102
Scooby Newbie
 
Member#: 519178
Join Date: Oct 2020
Default

Yea that is prolly gonna be my last resort is getting a new MAF. The cleaner **** did not change anything so I donít feel like the MAF is going bad but I am going to return the afr sensor I got from NAPA and buy one straight from Subaru. If that doesnít work then I might try cleaning my fuel injectors with some of that gas additive (before I do that is that stuff baloney or does it actually work has anyone had success with it?) then I might cave and go for the MAF. Does anyone have any cheaper solutions or more simple solutions I could have potentially overlooked?
Conster102 is offline   Reply With Quote
Old 11-21-2020, 02:50 AM   #12
tabrad
Scooby Specialist
 
Member#: 157229
Join Date: Aug 2007
Chapter/Region: RMIC
Location: SLC, Utah
Vehicle:
2006 STi
Wrapped Blue

Default

A cheap option that many people do, is find someone with a similar suby that will let you borrow their MAF for an hour and take the car for a spin and see if the problem is solved.
tabrad is offline   Reply With Quote
Old 11-21-2020, 05:03 PM   #13
Conster102
Scooby Newbie
 
Member#: 519178
Join Date: Oct 2020
Default

Yea changed out the AFR sensor and nothing changed still trash Iím currently looking for someone to borrow their MAF
Conster102 is offline   Reply With Quote
Old 11-22-2020, 10:29 AM   #14
benflynn
Scooby Newbie
 
Member#: 515308
Join Date: Jun 2020
Default

I can send u a known good MAF, I have half a dozen around here. Iíll throw a spare in my forester to make sure itís still legit and then send it on to ya.
benflynn is offline   Reply With Quote
Old 11-22-2020, 06:49 PM   #15
Conster102
Scooby Newbie
 
Member#: 519178
Join Date: Oct 2020
Default

Forreal? That would be super dope thank you so much man. A forester MAF will work?
Conster102 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.