Welcome to the North American Subaru Impreza Owners Club Friday July 20, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-14-2018, 09:12 PM   #1
silverbullet55
Scooby Newbie
 
Member#: 445403
Join Date: Apr 2016
Location: Upstate NY
Vehicle:
2003 WRX
PSM

Default Im TRUELY lost with this!!!!!!!! HELP!

So recently Ive been having intermittent issues with loss of boost when I get this "harmonica/bazooka" air intake noise when the engine gets hot and at approx. 2500rpms. Its a 2003 WRX with a VF39 with approx. 8k on it, no shaft play or wastegate crack at all! Spearco TMIC, ID1000s,Walbro fuel pump, Turbosmart recir bov, catless uppipe/downpipe,3" catback, Cobb short stack CAI,Grimmspeed EBCS. tuned on E85. The car boosts strong through rpm range and WOT with no boost surge at all. I know its not a boost leak because of how it boosts cold and hot.. IF I do a brake rev at up to approx. 2500rpm when the motor is hot, I can sometimes get it to make the noise and hear it coming through the CAI filter.(completely different noise of the turbo spooling) Now, can a leaky upipe create this noise? I have checked the flanges and don't see any black soot, furthermore, I don't hear an exhaust leak that would sound like that noise, and even if it was an exhaust leak in the uppipe, id imagine it would do it all the time, especially when hot, but it doesn't, it occurs intermittently. Im still in the process of getting fine tuned via Etune, so I notice this when im data logging, and daily driving. Do I bite the bullet and assume its the uppipe, or should I look more closely at the turbo? Any help is much appreciated!
* Registered users of the site do not see these ads.

Last edited by silverbullet55; 07-14-2018 at 09:28 PM.
silverbullet55 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-15-2018, 10:30 AM   #2
silverbullet55
Scooby Newbie
 
Member#: 445403
Join Date: Apr 2016
Location: Upstate NY
Vehicle:
2003 WRX
PSM

Default

I attached a couple of video clips of the sound,tell me what you guys think...
https://imgur.com/a/HkU2QoV
https://imgur.com/a/h81uoXw
silverbullet55 is offline   Reply With Quote
Old 07-15-2018, 12:03 PM   #3
subaru_gc8
Scooby Specialist
 
Member#: 29292
Join Date: Nov 2002
Chapter/Region: SCIC
Location: Orange County CA
Vehicle:
2004 WRX wagon
silver

Default

sounds like you have bad bearings somewhere to me. you should have am afr gauge instead of that battery gauge too
subaru_gc8 is offline   Reply With Quote
Old 07-15-2018, 02:23 PM   #4
silverbullet55
Scooby Newbie
 
Member#: 445403
Join Date: Apr 2016
Location: Upstate NY
Vehicle:
2003 WRX
PSM

Default

I have the afr gauge, just haven't had time to put it in....Im leaning towards a bad turbo with my research....SUCKS!
silverbullet55 is offline   Reply With Quote
Old 07-16-2018, 01:46 AM   #5
subaru_gc8
Scooby Specialist
 
Member#: 29292
Join Date: Nov 2002
Chapter/Region: SCIC
Location: Orange County CA
Vehicle:
2004 WRX wagon
silver

Default

Quote:
Originally Posted by silverbullet55 View Post
I have the afr gauge, just haven't had time to put it in....Im leaning towards a bad turbo with my research....SUCKS!
hey its a good opportunity to upgrade.
subaru_gc8 is offline   Reply With Quote
Old 07-16-2018, 07:20 AM   #6
silverbullet55
Scooby Newbie
 
Member#: 445403
Join Date: Apr 2016
Location: Upstate NY
Vehicle:
2003 WRX
PSM

Default

Yup! Just trying to decide what turbo to go with to compliment my set up! Thanks to all!!
silverbullet55 is offline   Reply With Quote
Old 07-16-2018, 10:00 AM   #7
HoosierBuddy
Scooby Newbie
 
Member#: 443465
Join Date: Mar 2016
Location: Southern Indiana
Vehicle:
2004 WRX
Silver

Default

Sorry it this is a dumb question...but would rebuilding the existing turbo be a possibility?

Phil
HoosierBuddy is offline   Reply With Quote
Old 07-16-2018, 11:16 AM   #8
subaru_gc8
Scooby Specialist
 
Member#: 29292
Join Date: Nov 2002
Chapter/Region: SCIC
Location: Orange County CA
Vehicle:
2004 WRX wagon
silver

Default

Quote:
Originally Posted by HoosierBuddy View Post
Sorry it this is a dumb question...but would rebuilding the existing turbo be a possibility?

Phil
yes you can rebuild, but the problem with that is you put your turbo in the hands of a machine shop that might have a good day or a bad day.... sometimes buying something like a new 16g is a better way to go
subaru_gc8 is offline   Reply With Quote
Old 07-16-2018, 12:57 PM   #9
CarmelValleyWRX
Scooby Newbie
 
Member#: 453872
Join Date: Sep 2016
Vehicle:
2005 wrx wagon
48w

Default

for some reason Imgur vids wont play, but harmonica noise reminds me of when i forgot to tighten down my bypass valve. i twas only finger tight and made a crazy noise.
CarmelValleyWRX is offline   Reply With Quote
Old 07-16-2018, 07:42 PM   #10
silverbullet55
Scooby Newbie
 
Member#: 445403
Join Date: Apr 2016
Location: Upstate NY
Vehicle:
2003 WRX
PSM

Default

When you click on the play button the video starts to play in the upper right corner of the screen there is a speaker symbol click on it for sound. Iíve verified with my tuner today that my turbo is shot, ordered a new Cobb 20g.... canít wait!😬
silverbullet55 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.