Welcome to the North American Subaru Impreza Owners Club Saturday April 17, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-12-2021, 04:40 PM   #1
Ej20xHawkeye
Scooby Newbie
 
Member#: 514415
Join Date: May 2020
Chapter/Region: South East
Vehicle:
2006 Ej20x wrx

Default Leaking boost noise been plaguing me please help!!!

Im thinking ive got a boost leak but im not sure where ive replaced all my intercooler piping, and gaskets my silicone tomei inlet is in great shape. ive done countless smoke tests and still nothing and im still getting the full boost im tuned for on my boost gauge but at wot and under heavy boost the car is reading pretty rich on my WB02 although my cruising and idle afrs are great . I feel like the symptoms all started once i began to hear my turbo get way louder. i have the stock tdo4 and stock bpv, stock intake with a K&N drop in (should i replace with oem?) with a hks tbe and ive never heard any turbo blow off but now there is a noticeable and sometime loud hissing woosh on spool and blow off. I really would like to fix whatever is causing the sound because im almost positive that is my culprit. my tuner initially thought it was a issue with my ebcs plug and advised me to replace it, i havent been able to see him since then as he is far and busy but im trying to schedule some more diagnostics. The noise sounds like its coming from the passengers glovebox so something with the ebcs could make sense im stumped tbh, any insight is appreciated.
Ej20xHawkeye is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.