Welcome to the North American Subaru Impreza Owners Club Saturday May 25, 2024
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-14-2024, 08:22 PM   #126
SamsMK
Scooby Newbie
 
Member#: 481225
Join Date: Jan 2018
Default

I will say that this post is overwhelming, but I want to know if anyone with 2015 Still/ Harmon Kardon has done the CarPlay swap and retained all functionality? I want to do this when I get back to the states.
* Registered users of the site do not see these ads.
SamsMK is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-17-2024, 04:54 PM   #127
protivakid
Scooby Newbie
 
Member#: 265148
Join Date: Nov 2010
Location: MA
Vehicle:
2016 WRX
White

Default

Quote:
Originally Posted by SamsMK View Post
I will say that this post is overwhelming, but I want to know if anyone with 2015 Still/ Harmon Kardon has done the CarPlay swap and retained all functionality? I want to do this when I get back to the states.
If you think this is overwhelming look at my crosstrek conversion post haha. That said yes everything should work as it does in your 2015 if wired up correctly.
protivakid is offline   Reply With Quote
Old 04-27-2024, 09:56 AM   #128
caffale
Scooby Newbie
 
Member#: 368559
Join Date: Sep 2013
Location: Twin Cities, MN
Vehicle:
2017 WRX Limited
WRB

Default

Hi, sorry to resurrect an old thread. I have a 2017 wrx that I have swapped a 2020 head unit (86431VA660) into. I have a 2.1a USB charger installed in the center console. Everything works, except CarPlay/AA. It doesn't seem like there is USB connectivity between the USB module and the head unit when I go into the diagnostic mode, however my phone charges when it's plugged into the USB module. Any insight here?
caffale is offline   Reply With Quote
Old 04-28-2024, 10:53 AM   #129
protivakid
Scooby Newbie
 
Member#: 265148
Join Date: Nov 2010
Location: MA
Vehicle:
2016 WRX
White

Default

Quote:
Originally Posted by caffale View Post
Hi, sorry to resurrect an old thread. I have a 2017 wrx that I have swapped a 2020 head unit (86431VA660) into. I have a 2.1a USB charger installed in the center console. Everything works, except CarPlay/AA. It doesn't seem like there is USB connectivity between the USB module and the head unit when I go into the diagnostic mode, however my phone charges when it's plugged into the USB module. Any insight here?
What is the part # on the 2.1a USB module you picked up? My best guess is it's newer and perhaps has the pin mapping changed like I found when I converted my sister's base Impreza in this thread here: https://forums.nasioc.com/forums/sho....php?t=2944986
protivakid is offline   Reply With Quote
Old 04-28-2024, 05:09 PM   #130
caffale
Scooby Newbie
 
Member#: 368559
Join Date: Sep 2013
Location: Twin Cities, MN
Vehicle:
2017 WRX Limited
WRB

Default

Quote:
Originally Posted by protivakid View Post
What is the part # on the 2.1a USB module you picked up? My best guess is it's newer and perhaps has the pin mapping changed like I found when I converted my sister's base Impreza in this thread here: https://forums.nasioc.com/forums/sho....php?t=2944986
I am 99% sure itís 86257SJ131. I have tried swapping pin 5 and 6 with no change.
caffale is offline   Reply With Quote
Old 05-01-2024, 12:35 PM   #131
protivakid
Scooby Newbie
 
Member#: 265148
Join Date: Nov 2010
Location: MA
Vehicle:
2016 WRX
White

Default

Quote:
Originally Posted by caffale View Post
I am 99% sure it's 86257SJ131. I have tried swapping pin 5 and 6 with no change.
I'd verify the exact part number on the piece before spending time troubleshooting too much else. I wouldn't be surprised if Subaru changed it for even newer years. If they did, TechNet should give you access to any newer factory service manuals for $35.

Also make sure you are using a 10gbps usb-c DATA cable, not just a charging one. https://www.amazon.com/gp/product/B0...e?ie=UTF8&th=1
protivakid is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:20 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2024 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.

When you click on links to various merchants on this site and make a purchase, this can result in this site earning a commission
Affiliate programs and affiliations include, but are not limited to, the eBay Partner Network.