Welcome to the North American Subaru Impreza Owners Club Sunday January 20, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-12-2018, 02:01 AM   #1
bugeyyyeeeeeeeeee
Scooby Newbie
 
Member#: 480080
Join Date: Jan 2018
Chapter/Region: NWIC
Location: Arlington, Wa
Vehicle:
2002 Impreza wrx
Alittle darker than wrb

Default Turbo Sounds Like Supercharger

Hello everyone I was driving home from work last week and my journeyman was in his work van and he looked at me and wanted to race (jokingly) so we did a lil pull I hit 20 psi as usual and it rode fine for the next 10 minutes. About 100ft from the exit my turbo started to loose boost only hitting about 12psi full throttle and making the weird supercharger noise then the rest of the drive home boost got lower and lower until it made 0 WOT and still made the noise. I rebuilt the turbo tonight with one of those kits on eBay and itís still making the noise! Iím really stumped. Please help me. Mod list 2002 wrx vf39 650cc injectors full turbo back straight pipe Cobb intake Mishimoto inlet 08 sti intercooler Cobb EBCS aem fuel pump and other supporting mods... tuned by mike at pia in Tacoma at 20psi 296hp 254tq
* Registered users of the site do not see these ads.
bugeyyyeeeeeeeeee is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-12-2018, 10:31 PM   #2
RBYM
Scooby Newbie
 
Member#: 315294
Join Date: Mar 2012
Default

Boost leak?
RBYM is offline   Reply With Quote
Old 12-13-2018, 09:06 AM   #3
bugeyyyeeeeeeeeee
Scooby Newbie
 
Member#: 480080
Join Date: Jan 2018
Chapter/Region: NWIC
Location: Arlington, Wa
Vehicle:
2002 Impreza wrx
Alittle darker than wrb

Default

Quote:
Originally Posted by RBYM View Post
Boost leak?
No go on the boost leak I triple checked last night Iíll link the video I took of me revving it up from idle and you can hear it
bugeyyyeeeeeeeeee is offline   Reply With Quote
Old 12-13-2018, 09:07 AM   #4
bugeyyyeeeeeeeeee
Scooby Newbie
 
Member#: 480080
Join Date: Jan 2018
Chapter/Region: NWIC
Location: Arlington, Wa
Vehicle:
2002 Impreza wrx
Alittle darker than wrb

Default

Here is the link to the video I took


https://youtu.be/Fey84CVqEFA
bugeyyyeeeeeeeeee is offline   Reply With Quote
Old 12-13-2018, 09:49 PM   #5
CarmelValleyWRX
Scooby Specialist
 
Member#: 453872
Join Date: Sep 2016
Vehicle:
2005 wrx wagon
48w

Default

so you rebuilt it... did it have a ton of play in the shaft? the compressor might be ground down and out of balance and just simply no good anymore.
CarmelValleyWRX is offline   Reply With Quote
Old 12-13-2018, 10:19 PM   #6
bugeyyyeeeeeeeeee
Scooby Newbie
 
Member#: 480080
Join Date: Jan 2018
Chapter/Region: NWIC
Location: Arlington, Wa
Vehicle:
2002 Impreza wrx
Alittle darker than wrb

Default

Quote:
Originally Posted by CarmelValleyWRX View Post
so you rebuilt it... did it have a ton of play in the shaft? the compressor might be ground down and out of balance and just simply no good anymore.
it had a little extra shaft play but Iím thinking what you said:/ sadly have to save up for a 16g
bugeyyyeeeeeeeeee is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.