Welcome to the North American Subaru Impreza Owners Club Saturday September 26, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-15-2020, 05:19 PM   #176
imprezahawkeye45
Scooby Newbie
 
Member#: 510743
Join Date: Jan 2020
Default

Quote:
Originally Posted by tornado542 View Post
2012 Impreza Sport Premium CVT
10,500 miles so far...no issues besides the squeaky seat that i fixed myself.'

Whos got the most miles so far?
Im at 165xxx
* Registered users of the site do not see these ads.
imprezahawkeye45 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-12-2020, 09:57 PM   #177
2012sti500hp
Scooby Newbie
 
Member#: 511637
Join Date: Feb 2020
Default So many

Quote:
Originally Posted by tornado542 View Post
2012 Impreza Sport Premium CVT
10,500 miles so far...no issues besides the squeaky seat that i fixed myself.'

Whos got the most miles so far?
I have over 207000 on now my 3rd engine . If you do any mods start with the block and go from there
2012sti500hp is offline   Reply With Quote
Old 03-10-2020, 10:59 PM   #178
clavette88
Scooby Newbie
 
Member#: 465863
Join Date: Apr 2017
Default

194,000 manual,bought it with under 20 miles and only have filled gas tank, change oil/brakes/ tires. At 175,000 got throw out baring replaced with plugs and accessorie belt. I neglected the poor thing but keeps going
clavette88 is offline   Reply With Quote
Old 09-16-2020, 01:07 AM   #179
GarbageDay
Scooby Newbie
 
Member#: 371213
Join Date: Oct 2013
Location: DC Metro Area
Vehicle:
2013 Imp Spt Lmtd
Ice Silver Metallic

Default

Just took my car in for the 112,500 mileage maintenance. Just an oil change and front brake change. Still runs good but I have noticed ever since doing the valve spring replacement around the 80k mark, it has been burning oil. The light will come on after 3-4k miles. I'll throw in half a quart and the light goes away. It'll come back on after 1-2k miles and I'll throw in another.
GarbageDay is offline   Reply With Quote
Old 09-16-2020, 12:55 PM   #180
DieselDorf
Scooby Specialist
 
Member#: 454773
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Traverse City, MI
Vehicle:
2012 Impreza Sport
Pearl White

Default

Could be due to mileage unless it was directly after the work was done. That isnít terrible for burning oil most burn around that amount.

If it bothers you 0w-40 works fine and doesnít burn as much. I ran if dor 20k miles no issues.
DieselDorf is offline   Reply With Quote
Old 09-19-2020, 11:25 PM   #181
IHaveAHorse
Scooby Newbie
 
Member#: 507873
Join Date: Oct 2019
Location: all over the place
Default

Is it pretty normal to have to put a quart or two in over a roughly 6000 mile oil change? My car seems like it randomly goes months without burning oil, but then I'll check it one week and it's fine, then randomly like a week or two later it's down a quart, but maybe the surface I check it on is unlevel or something. Weird. I don't know. I haven't really had any other mechanical problems. An extra $5-10 an oil change is very insignificant compared to some other maintenance costs.
IHaveAHorse is offline   Reply With Quote
Old 09-20-2020, 09:54 AM   #182
hinkmeister
Scooby Newbie
 
Member#: 427471
Join Date: Aug 2015
Default

Quote:
Originally Posted by IHaveAHorse View Post
Is it pretty normal to have to put a quart or two in over a roughly 6000 mile oil change? My car seems like it randomly goes months without burning oil, but then I'll check it one week and it's fine, then randomly like a week or two later it's down a quart, but maybe the surface I check it on is unlevel or something. Weird. I don't know. I haven't really had any other mechanical problems. An extra $5-10 an oil change is very insignificant compared to some other maintenance costs.
What model ? I have had two STIs and my first one,14 STI was Stg1 and was pretty consistent on 1qt between oil changes. However my second one, 12 STI is Stg2 protuned and is a little less. Between 1/2 qt and 1 qt. Sometimes it depends on how youíre driving it. All highway, city, or just ďspiritedĒ (I added quotations on purpose)
hinkmeister is offline   Reply With Quote
Old 09-20-2020, 10:38 PM   #183
IHaveAHorse
Scooby Newbie
 
Member#: 507873
Join Date: Oct 2019
Location: all over the place
Default

2.0i with a CVT

I drive a lot more calmly than I used to, in general I go for MPG over fun now. But that doesn't mean I don't use full throttle now and then.
IHaveAHorse is offline   Reply With Quote
Old 09-21-2020, 06:01 AM   #184
DieselDorf
Scooby Specialist
 
Member#: 454773
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Traverse City, MI
Vehicle:
2012 Impreza Sport
Pearl White

Default

Quote:
Originally Posted by IHaveAHorse View Post
Is it pretty normal to have to put a quart or two in over a roughly 6000 mile oil change? My car seems like it randomly goes months without burning oil, but then I'll check it one week and it's fine, then randomly like a week or two later it's down a quart, but maybe the surface I check it on is unlevel or something. Weird. I don't know. I haven't really had any other mechanical problems. An extra $5-10 an oil change is very insignificant compared to some other maintenance costs.
Mine burns it the exact same way, seems fine for months then within a week drops a quart. Not sure why or if itís an error in reading it on my part.
DieselDorf is offline   Reply With Quote
Old 09-22-2020, 08:12 PM   #185
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by DieselDorf View Post
Could be due to mileage unless it was directly after the work was done. That isnít terrible for burning oil most burn around that amount.



If it bothers you 0w-40 works fine and doesnít burn as much. I ran if dor 20k miles no issues.


The start up wear on 0w30 and 0w40 is significantly higher than 0w20. I have gone back to 0w20.........
flyboy1100 is offline   Reply With Quote
Old 09-23-2020, 05:24 PM   #186
DieselDorf
Scooby Specialist
 
Member#: 454773
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Traverse City, MI
Vehicle:
2012 Impreza Sport
Pearl White

Default

Quote:
Originally Posted by flyboy1100 View Post
The start up wear on 0w30 and 0w40 is significantly higher than 0w20. I have gone back to 0w20.........
Iíve gone back as well since I do a lot of shorter trips. I was doing more long distance highway type driving so 0w40 wasnít too bad for that.
DieselDorf is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:49 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.