Welcome to the North American Subaru Impreza Owners Club Monday December 11, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Vancouver Impreza Club
Go Back   NASIOC > NASIOC Chapters > Vancouver Impreza Club Forum -- VIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-14-2001, 10:16 PM   #1
j y
Scooby Specialist
 
Member#: 8829
Join Date: Jul 2001
Chapter/Region: VIC
Location: Vancouver
Vehicle:
GRB STI
SWP

Question Where was everyone???

Mine was the only Impreza representing at the autocross today!

You guys missed out. Only 28 cars, 8 runs + some funruns I didn't do. The course was nice and long. Times around 1:16.

Surface was slick in the morning! Lots of slipping and sliding. Fun

A bunch of people went for rides. I may have given one to a couple I-club guys...
* Registered users of the site do not see these ads.
j y is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-14-2001, 10:17 PM   #2
j y
Scooby Specialist
 
Member#: 8829
Join Date: Jul 2001
Chapter/Region: VIC
Location: Vancouver
Vehicle:
GRB STI
SWP

Default

by the way... Is the burning clutch smell normal on a new car by any chance?

-Jeff
j y is offline   Reply With Quote
Old 10-14-2001, 10:59 PM   #3
Ken
NASIOC Supporter
 
Member#: 34
Join Date: Jun 1999
Chapter/Region: VIC
Location: Richmond, BC Canada
Vehicle:
2005 WRX STi
World Rally Blue

Default

I was there checking things out for a short while. Was your's the blue WRX sedan? The course seemed longer than what I'm used to running on (almost 2min long today) with a lot of cross overs. Yeah, I noticed there were a only a few cars out today. Pretty laid back.
Ken is offline   Reply With Quote
Old 10-14-2001, 11:26 PM   #4
Keiho
Scooby Guru
 
Member#: 610
Join Date: Dec 1999
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2003 Lexus IS300
Graphite Gray Pearl

Default

I was in bed sleeping. Too tired to make it out to race today.
Keiho is offline   Reply With Quote
Old 10-14-2001, 11:32 PM   #5
-S-
Scooby Specialist
 
Member#: 6979
Join Date: May 2001
Location: Burnaby, B.C. Canada/Toronto, ON
Default

ahhhhhhhhhhhhh! nooooooooooooo!

that's it... i'll fail my yearly proficency next time so i can go
-S- is offline   Reply With Quote
Old 10-14-2001, 11:58 PM   #6
Petrie
Scooby Specialist
 
Member#: 1260
Join Date: Apr 2000
Chapter/Region: VIC
Location: Squamish
Vehicle:
09 STi, DGM
04 WRX Stage 2, red

Default

I was mounting my new light bars. Slowly, slowly catchie monkey. Not finished yet. I don;t recommend do this stuff when you have a cold, it sort of slows things down.
Petrie is offline   Reply With Quote
Old 10-15-2001, 02:52 AM   #7
Prostho
Scooby Newbie
 
Member#: 3388
Join Date: Dec 2000
Location: Richmond, B.C, Canada
Vehicle:
1992 E34
Mauritius Blue

Default

Hey thanks for the ride man!!!!!!! new tires. heheheheeehe
Prostho is offline   Reply With Quote
Old 10-15-2001, 10:52 AM   #8
tora
Scooby Guru
 
Member#: 5851
Join Date: Apr 2001
Chapter/Region: VIC
Location: Vancouver
Vehicle:
17 Ford Escape SE
Blk

Default

jy, how new is your car??
I couldn't make it cause I was bushwackin' my way around Cheakamus lake. So sore today..arg.
tora is offline   Reply With Quote
Old 10-15-2001, 01:08 PM   #9
j y
Scooby Specialist
 
Member#: 8829
Join Date: Jul 2001
Chapter/Region: VIC
Location: Vancouver
Vehicle:
GRB STI
SWP

Default

yep, blue WRX.

I think this autocross is going to be the last for the RE92s. Or at least for Boundary Bay! This is their second and we're seeing some pretty bad tread deformation already.

Car is just over a month old now... with 2600kms!

-Jeff
j y is offline   Reply With Quote
Old 10-16-2001, 10:42 AM   #10
tora
Scooby Guru
 
Member#: 5851
Join Date: Apr 2001
Chapter/Region: VIC
Location: Vancouver
Vehicle:
17 Ford Escape SE
Blk

Default

Isn't that a bit early to be racing it? I waited 'ti lover 3000km's before getting even close to WOT.
tora is offline   Reply With Quote
Old 10-16-2001, 12:46 PM   #11
j y
Scooby Specialist
 
Member#: 8829
Join Date: Jul 2001
Chapter/Region: VIC
Location: Vancouver
Vehicle:
GRB STI
SWP

Default

There's a lot of debate on how to properly break-in a new vehicle. For the first 1500kms I did keep RPMs under 4000 with an occasional spike into the upper reaches.

I don't drive on the street like I do at an autocross (of course). I'm still shifting early around town, as much to save gas as being gentle on the engine. I figure it can't hurt to make an occasional run to the redline or at WOT, though.

Truthfully, I'm not worried about the engine at all. I'm more concerned about the other driveline components like the clutch and transmission... time will tell I guess, eh?

-Jeff
j y is offline   Reply With Quote
Old 10-16-2001, 05:52 PM   #12
patr
NASIOC Supporter
 
Member#: 97
Join Date: Jul 1999
Location: Vancouver, BC, CANADA
Default

Hey the stock clutch can take a lot of abuse (IMHO), dont even worry if it smells (hehe). I'm not talking drag launches, but once in a while a spool up from 4.5k to 6k seems to not be so bad on the PGT rally car (we do abuot 15 of these a rally). We are using stock clutch to be nice to the tranny.

Did you get it slideways jeff ?

I would have gone but Ian and I were out practising pace notes in Chilliwack for the upcoming big race at Charlevoix in 2 weeks.
patr is offline   Reply With Quote
Old 10-16-2001, 05:58 PM   #13
Penphoe
Friendly Neighbourhood
Moderator
 
Member#: 269
Join Date: Sep 1999
Chapter/Region: VIC
Location: Burnaby, B.C., Canada
Vehicle:
2005 ABP LGT LTD BP6
00 Impreza RS GM6 RIP

Default I'm Mr. stinky clutch at the auto-x.

Ask any of the boys and girls who auto-x here - You can smell my clutch when I launch my car at the auto-x, and it seems to be holding quite well for 42000km of driving, a few auto-x's mixed in here and there.

For my fast launches, I usually rev up to 4-5k, and slip the clutch a bit until it grabs, then mash down on the gas. Lotz of fun, but it's pretty stinky -- I can smell it inside the car too! Yeah, it wears down my clutch, but I"d rather replace a clutch than a broken tranny. Besides, I find that my clutch doesn't shudder as much after a day of auto-x'ing!

LaterZ!
Darren!!
Penphoe is offline   Reply With Quote
Old 10-16-2001, 06:11 PM   #14
Ken
NASIOC Supporter
 
Member#: 34
Join Date: Jun 1999
Chapter/Region: VIC
Location: Richmond, BC Canada
Vehicle:
2005 WRX STi
World Rally Blue

Default

I can make my clutch sudder at will now - cold or hot. I think it's just due to me taking off in 1st. gear from really low rpm's, not more attributed to my clutch wearing out. I think I take off at 1k or 1.1k rpm... maybe it's even too low for my good.
Ken is offline   Reply With Quote
Old 10-16-2001, 06:16 PM   #15
j y
Scooby Specialist
 
Member#: 8829
Join Date: Jul 2001
Chapter/Region: VIC
Location: Vancouver
Vehicle:
GRB STI
SWP

Default

haha! My tire pressures were 46f 37r... sideways??? yes please! There's plenty of understeer too, thanks to the craptacular RE92s.

I noticed that as long as I'm not braking too hard or not on the gas in a turn, the front will hold well enough and the rear will gently break out nicely. I was using this to some effect last weekend to get through the zig-zag crossovers.

I love this car...

One of the guys said you (Pat) disconnected/removed the front bar on your WRX. I dunno... the spring rates seem really soft already. Not sure if I can take any more of this crazy rolling.

Nice to know about the clutch thing. I experimented a couple times launching by slipping at 5000. Noticed the nasty smell after (with numerous comments from other people). Went back down to slipping at 3500.

-Jeff
j y is offline   Reply With Quote
Old 10-16-2001, 08:45 PM   #16
tora
Scooby Guru
 
Member#: 5851
Join Date: Apr 2001
Chapter/Region: VIC
Location: Vancouver
Vehicle:
17 Ford Escape SE
Blk

Default

Darren's got sweeeet launches. Hope to see you all at the Auto-x's next summer!!
tora is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pompei meet 1/24: Where was everyone? sluflyer06 Mid West Subaru Owners Club Forum -- MWSOC 29 01-25-2008 06:58 PM
Where was everyone at the Dragon? Crash477 South East Region Forum 37 06-07-2004 06:23 PM
Where was everyone? (Cici's in Arlington) LinuxRacr Texas Impreza Club Forum -- TXIC 0 12-14-2002 10:25 AM
englishtown auto-X 6/9...where was everyone!?!? jetfire67 Tri-State Area Forum 4 06-10-2001 09:51 PM
So how was everyones weekend? paultg New England Impreza Club Forum -- NESIC 11 09-05-2000 07:16 PM

All times are GMT -4. The time now is 01:38 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.