Welcome to the North American Subaru Impreza Owners Club Monday September 16, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-05-2019, 07:53 PM   #1
Umbriss
Scooby Newbie
 
Member#: 504839
Join Date: Aug 2019
Location: Alberta
Vehicle:
2005 SAAB 9-2X Aero

Default New Saabaru owner

Hey everyone,

Just picked up an 05 Saab 9-2X Aero. This is my first Subaru that I've owned but not my first Saab. I've always been a lover of cars and JDM goodness, and just like working on cars in general. Not sure how you all feel about the Saabs considering they were just rebadged WRX wagons.

* Registered users of the site do not see these ads.
Umbriss is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-06-2019, 12:22 AM   #2
AZ-GT
NASIOC Supporter
 
Member#: 192
Join Date: Aug 1999
Chapter/Region: SWIC
Location: Las Vegas, NV.
Vehicle:
2011 WRB WRX
2000 Impreza 2.5RS

Default

Nice looking Saabaru. Welcome aboard!
AZ-GT is offline   Reply With Quote
Old 08-06-2019, 02:47 AM   #3
Umbriss
Scooby Newbie
 
Member#: 504839
Join Date: Aug 2019
Location: Alberta
Vehicle:
2005 SAAB 9-2X Aero

Default

Thanks! Have a few ideas for the next few months on what to do and will run into some issues so I'll probably be frequenting here a but.
Umbriss is offline   Reply With Quote
Old 08-06-2019, 11:50 AM   #4
ericsson
Scooby Specialist
 
Member#: 208672
Join Date: Apr 2009
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2013 WRX STI Limited
Obsidian Black

Default

I always wanted one of these, but couldn't find one priced right
ericsson is offline   Reply With Quote
Old 08-08-2019, 02:25 PM   #5
lord_galathon
Scooby Newbie
 
Member#: 505077
Join Date: Aug 2019
Chapter/Region: E. Canada
Location: Montreal
Vehicle:
2005 Saab 92x Aero
Silver

Default

Hey I have the exact same car - same color and all except I have the stock Saab 18" wheels. (they might be 17s I'm not sure I don't remember I did buy tyres for it.)

I picked it up from a friend for 1000$CDN last fall. He wasn't using it and the car had been sitting for almost 2 years, I figured what the heck: I'll use it as a winter beater while my Abarth is away.

Not sure if the photos will show up but they're from last winter. It has 170.000 miles - US car (I'm in Canada...)





Car has some mods too! Tuned engine, complete 3" STi exhaust + catless, 1/2" lowered and stiffened + poly bushings and big brake kit.

Since I got I replaced the oil pan (leak) and front brakes were seized so they had to be replaced including the calipers, stuck with big brake kit. 2x oil changes so far and it's not taking any oil. Changed the tyres.

AC doesn't work, when I bought the car it was missing the AC belt and tensioner assembly so I picked all those parts up and installed them but the AC won't hold a charge which is a bummer but the car runs great. 270HP with the mods, it's a hoot to drive.

One thing I'm not a huge fan of is the lowered part, sure handles great but last winter I hit a block of ice and the exhaust broke, I had a garage weld it back into place and it's been fine eversince.

Did I mention it's 5sp manual? Clutch is a bit hard but it works fine.

I just wish I could get the keyfob/module sorted out. It works randomly, changed the battery in the keyfob but it still won't always work so I set it in "valet" mode just so that it doesn't set off the alarm each time I unlock the door with the key.
lord_galathon is offline   Reply With Quote
Old 08-10-2019, 04:15 PM   #6
curiousfish
Scooby Specialist
 
Member#: 89283
Join Date: Jun 2005
Chapter/Region: Tri-State
Location: Queens, NYC
Vehicle:
2017 WRX Premium
ISM

Default

my brother has 1, original owner, also MY05, 5 speed. stage 2 since, cant even remember. Still runs great! Even original clutch!
Took the saabaru to Wicked Big Meet one year, got a lot of "why's a Saab at a Subaru meet" looks.
curiousfish is offline   Reply With Quote
Old 08-10-2019, 04:34 PM   #7
Blktrax
Scooby Specialist
 
Member#: 220971
Join Date: Aug 2009
Chapter/Region: South East
Location: West, NC
Vehicle:
2002 WRX 223K Mi.

Default

Quote:
Originally Posted by lord_galathon View Post
I just wish I could get the keyfob/module sorted out. It works randomly, changed the battery in the keyfob but it still won't always work so I set it in "valet" mode just so that it doesn't set off the alarm each time I unlock the door with the key.
Check all the door switches, overtime the rubber covers wear thin or come off completely. Results in random door open signal. Second pull up the center console next to the parking brake; there may be an optional shock sensor for the alarm. Iíve been seeing this go bad after about 10years. Just unplug box , it will be labeled security sensor, and hopefully that takes care of it.
Blktrax is offline   Reply With Quote
Old 08-12-2019, 11:05 AM   #8
lord_galathon
Scooby Newbie
 
Member#: 505077
Join Date: Aug 2019
Chapter/Region: E. Canada
Location: Montreal
Vehicle:
2005 Saab 92x Aero
Silver

Default

Quote:
Originally Posted by Blktrax View Post
Check all the door switches, overtime the rubber covers wear thin or come off completely. Results in random door open signal. Second pull up the center console next to the parking brake; there may be an optional shock sensor for the alarm. Iíve been seeing this go bad after about 10years. Just unplug box , it will be labeled security sensor, and hopefully that takes care of it.
Thanks for the information - I'll take a look tonight when I get home. Car drives great but the keyfob is unusable right now. I wonder if there's an antenna on the car that got disconnected somehow.
lord_galathon is offline   Reply With Quote
Old 08-12-2019, 06:02 PM   #9
Blktrax
Scooby Specialist
 
Member#: 220971
Join Date: Aug 2009
Chapter/Region: South East
Location: West, NC
Vehicle:
2002 WRX 223K Mi.

Default

Quote:
Originally Posted by lord_galathon View Post
Thanks for the information - I'll take a look tonight when I get home. Car drives great but the keyfob is unusable right now. I wonder if there's an antenna on the car that got disconnected somehow.
There just the keyless module box that is just above the fuse panel on the left side of the dash. Then the shock sensor is added on in the center console. Also look under the hood and back by the turbo if there is another horn bolted to the strut tower , thatís a sure sign it has the optional alarm.
Blktrax is offline   Reply With Quote
Old 08-12-2019, 06:29 PM   #10
DesertArrow
Scooby Newbie
 
Member#: 321664
Join Date: May 2012
Default Nice

Good looking car man! I had one a while back. Desert silver color, but I like yours better. That was a fun car.
DesertArrow is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.