Welcome to the North American Subaru Impreza Owners Club Thursday July 19, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 02-18-2018, 09:43 PM   #1
blAAAm
Scooby Newbie
 
Member#: 468581
Join Date: May 2017
Chapter/Region: MWSOC
Vehicle:
2018 WRX
WR Blue Pearl

Default Base 2018 WRX Wiring Help - Back-Up Camera

Hi!

I have a base model 2018 WRX and I recently installed one of the GCS Apex Head Units. I also bought everything the Subi Speed site said i needed to get the back-up camera working but im running into problems finding the right wires i need to connect the 12v to 6v converter and the RCA Quick Connect Pig Tail.

The Image and the install Video on their site both have details about the 28 PIN factory harness, but the color wires do not match up.

Does any one have a PIN Out of the 2018 WRX or has anyone installed something similar in a new WRX?

* Registered users of the site do not see these ads.
blAAAm is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-19-2018, 10:02 AM   #2
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

it should have the 5 pin connector for back up camera on back of radio, if it does look below. If it doesnt what color wires are populated in those positions??

6V Camera Power - White
Camera Ground - Black
Video(+) - Red (center conductor of rca plug)
Video(-) - Gray (shield wire of rca plug)

Last edited by phd12v; 02-19-2018 at 10:08 AM.
phd12v is offline   Reply With Quote
Old 02-19-2018, 10:49 AM   #3
blAAAm
Scooby Newbie
 
Member#: 468581
Join Date: May 2017
Chapter/Region: MWSOC
Vehicle:
2018 WRX
WR Blue Pearl

Default

Guess the 5 PIN connector i have is not for the camera, what im really looking for were each wire goes to (subispeed support sent me this)


Metra 12v to 6V

Black Wire goes to ?
Blue/White Wire goes to ?
Blue/Red Wire goes to?

Reverse IN Wire goes to?

RCA Quick Connect

Positive goes to?
Negative goes to?

Last edited by blAAAm; 02-19-2018 at 01:28 PM.
blAAAm is offline   Reply With Quote
Old 02-19-2018, 03:55 PM   #4
blAAAm
Scooby Newbie
 
Member#: 468581
Join Date: May 2017
Chapter/Region: MWSOC
Vehicle:
2018 WRX
WR Blue Pearl

Default

After talking back and forth with SubiSpeed support I finally got the info i needed. Everything will use the 28 PIN Factory Harness

Metra 12v to 6V

Black Wire goes to Pin 20
Blue/White Wire goes to Pin 2
Blue/Red Wire goes to Pin 11

Reverse IN Wire goes to Pin 2

RCA Quick Connect

Ground(Solid Blue) goes to Pin 20
Positive(Blue/White) goes to Pin 12
blAAAm is offline   Reply With Quote
Old 02-20-2018, 08:41 AM   #5
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

if you take the 12v input to ACC instead of reverse........ you can turn your camera on while driving........not sure why you would want to but you could.... and still do the reverse trigger to your radio into pin 2
phd12v is offline   Reply With Quote
Old 02-20-2018, 08:36 PM   #6
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by phd12v View Post
it should have the 5 pin connector for back up camera on back of radio
...
So far (2016-2018), only the car models with the OEM HUs with 7" screens use the separate 5-pin harness for the rear camera. Models with 6.2" screens connect the camera via the 28-pin. Don't assume all WRXs have the 7"; there are still some low-end models with the 6.2".

Quote:
Originally Posted by phd12v View Post
if you take the 12v input to ACC instead of reverse........ you can turn your camera on while driving........not sure why you would want to but you could.... and still do the reverse trigger to your radio into pin 2
It can be handy in some cases when you're parking and repeatedly alternating between inching forward and backing up, and want the rear camera image to just stay visible the whole time.
SVXdc is offline   Reply With Quote
Old 02-20-2018, 09:04 PM   #7
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by blAAAm View Post
Guess the 5 PIN connector i have is not for the camera ...
Your car shouldn't have a 5-pin harness at the OEM radio at all. I'm curious to learn what you saw. Are you sure it has 5-pins?

On your car's 10- & 6-pin power/speaker harness, the latter half only has 5 wires populated (with the 6th slot vacant).

Recently there was a post (I think here on NASIOC, but might have been elsewhere) from someone who mis-identified their radio's chassis ground harness (which only has 1 wire and terminal) as the 5-pin camera harness. Funny thing is that in the picture he posted of him holding that ground harness, his car's 5-pin camera harness was right below/behind it.
SVXdc is offline   Reply With Quote
Old 02-21-2018, 01:30 PM   #8
blAAAm
Scooby Newbie
 
Member#: 468581
Join Date: May 2017
Chapter/Region: MWSOC
Vehicle:
2018 WRX
WR Blue Pearl

Default

Quote:
Originally Posted by SVXdc View Post
Your car shouldn't have a 5-pin harness at the OEM radio at all. I'm curious to learn what you saw. Are you sure it has 5-pins?

On your car's 10- & 6-pin power/speaker harness, the latter half only has 5 wires populated (with the 6th slot vacant).
The 5 PIN one i mentioned i accidentally mistook for the 6 PIN connector that was for the speakers.

I am hoping to get back-up camera setup this week but ive been super slammed at work and got asked to take a last minute trip next week to a remote office so it may not happen until next Friday.

Thanks again for all who posted, im not super skilled at this stuff but i prefer to learn and do it myself.

My next step is installing my new speakers and audio deadening then eventually this spring installing an AMP under my front seat for the new speakers.
blAAAm is offline   Reply With Quote
Old 02-21-2018, 01:47 PM   #9
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

Quote:
Originally Posted by SVXdc View Post
So far (2016-2018), only the car models with the OEM HUs with 7" screens use the separate 5-pin harness for the rear camera. Models with 6.2" screens connect the camera via the 28-pin. Don't assume all WRXs have the 7"; there are still some low-end models with the 6.2".


i said that above....if it has the 5 pin look below, if it doesnt it is in the 28 pin. LOL
phd12v is offline   Reply With Quote
Old 02-23-2018, 04:38 PM   #10
zexo
Scooby Newbie
 
Member#: 482509
Join Date: Feb 2018
Default

Not looking forward to working on this. Might just end up paying someone to deal with it.
zexo is offline   Reply With Quote
Old 02-23-2018, 04:57 PM   #11
Darkcyde108
Scooby Newbie
 
Member#: 481039
Join Date: Jan 2018
Location: SoCal
Vehicle:
2018 WRX
White

Default

Quote:
Originally Posted by blAAAm View Post
Hi!

I have a base model 2018 WRX and I recently installed one of the GCS Apex Head Units. I also bought everything the Subi Speed site said i needed to get the back-up camera working but im running into problems finding the right wires i need to connect the 12v to 6v converter and the RCA Quick Connect Pig Tail.

The Image and the install Video on their site both have details about the 28 PIN factory harness, but the color wires do not match up.

Does any one have a PIN Out of the 2018 WRX or has anyone installed something similar in a new WRX?


What are you doing to retain the dual USB?
Darkcyde108 is offline   Reply With Quote
Old 02-23-2018, 06:24 PM   #12
blAAAm
Scooby Newbie
 
Member#: 468581
Join Date: May 2017
Chapter/Region: MWSOC
Vehicle:
2018 WRX
WR Blue Pearl

Default

Quote:
Originally Posted by Darkcyde108 View Post
What are you doing to retain the dual USB?
The base model has a single USB, there was an adapter i bought from metra Subispeed that allowed an easy plug and play option.
blAAAm is offline   Reply With Quote
Old 02-23-2018, 06:52 PM   #13
Darkcyde108
Scooby Newbie
 
Member#: 481039
Join Date: Jan 2018
Location: SoCal
Vehicle:
2018 WRX
White

Default

Quote:
Originally Posted by blAAAm View Post
The base model has a single USB, there was an adapter i bought from metra Subispeed that allowed an easy plug and play option.
Lucky! There are no options as of now for the dual usb hub like I have in my premium. Guess I have to play the waiting game otherwise i'm switching out to a single pod.
Darkcyde108 is offline   Reply With Quote
Old 06-30-2018, 02:08 PM   #14
mikelisa0212
Scooby Newbie
 
Member#: 487812
Join Date: Jun 2018
Chapter/Region: South East
Vehicle:
2016 WRX
BLUE

Subaru Stars

I have a 2016 WRX with 7" radio, no navigation. I bought the Seicane head unit and have the 12v to 6 v converter and the RCA quick connect. I followed the instructions in this post and the stock camera is still not showing up on the display when in reverse. I made sure my reverse lights are still working (to eliminate a fuse issue).

Metra 12v to 6V

Black Wire goes to Pin 20
Blue/White Wire goes to Pin 2
Blue/Red Wire goes to Pin 11

Reverse IN Wire goes to Pin 2

RCA Quick Connect

Ground(Solid Blue) goes to Pin 20
Positive(Blue/White) goes to Pin 12


Any ideas? The Reverse IN I am using the orange wire that came with the seicane head unit wiring connections (Orange wire with Cam Reverse In on the label).

Thanks,
Mike
mikelisa0212 is offline   Reply With Quote
Old 06-30-2018, 05:00 PM   #15
mikelisa0212
Scooby Newbie
 
Member#: 487812
Join Date: Jun 2018
Chapter/Region: South East
Vehicle:
2016 WRX
BLUE

Default

Update, the HU is now recognizing when I put the car in reverse. I get the red/yellow/green guidelines, but instead of a camera, I am getting a yellow triangle sign with an exclamation mark.

I have also tested the camera is still working, by hooking up the stock head unit. For some reason, not getting a camera feed.
mikelisa0212 is offline   Reply With Quote
Old 07-02-2018, 01:07 PM   #16
mikelisa0212
Scooby Newbie
 
Member#: 487812
Join Date: Jun 2018
Chapter/Region: South East
Vehicle:
2016 WRX
BLUE

Unhappy

I went and bought another 12v to 6v conversion in case that was bad. Still getting the same results. In the subispeed video, they hooked up the ground to the black/blue wire on the 6 pin. I tried that for the ground also and no results.

Frustrated.
mikelisa0212 is offline   Reply With Quote
Old 07-03-2018, 09:26 PM   #17
mikelisa0212
Scooby Newbie
 
Member#: 487812
Join Date: Jun 2018
Chapter/Region: South East
Vehicle:
2016 WRX
BLUE

Default

So, I put the volt meter to test things out. When I go in reverse, should the Pin 11 (6V Camera) go to around 6 volts? It is still coming through at 12+ with both the 12v to 6 v converters. Any help would be appreciated
mikelisa0212 is offline   Reply With Quote
Old 07-05-2018, 08:42 AM   #18
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

Quote:
Originally Posted by mikelisa0212 View Post
So, I put the volt meter to test things out. When I go in reverse, should the Pin 11 (6V Camera) go to around 6 volts? It is still coming through at 12+ with both the 12v to 6 v converters. Any help would be appreciated
which converter did you get?
phd12v is offline   Reply With Quote
Old 07-05-2018, 08:56 AM   #19
mikelisa0212
Scooby Newbie
 
Member#: 487812
Join Date: Jun 2018
Chapter/Region: South East
Vehicle:
2016 WRX
BLUE

Default

I got this one from subispeed: METRA 12 VOLT TO 6 VOLT CONVERTER FOR STOCK REARVIEW CAMERA RETENTION - UNIVERSAL .

http://www.subispeed.com/2015-subaru...l#.Wz4VA9JKi71


Thought maybe it was bad and bought the same from best buy.


THANKS, Mike
mikelisa0212 is offline   Reply With Quote
Old 07-05-2018, 02:18 PM   #20
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

ok i see the issue.

pin 20 needs to get ground.......pin 20 on 28 pin AND the black wire from your converter need grounded.

Blue/White goes to Pin 2 on 28 pin and Blue/Red goes to pin 11 on the 28 pin for camera 6v power
phd12v is offline   Reply With Quote
Old 07-05-2018, 02:55 PM   #21
mikelisa0212
Scooby Newbie
 
Member#: 487812
Join Date: Jun 2018
Chapter/Region: South East
Vehicle:
2016 WRX
BLUE

Default

Thanks, so if I understand you right, I need to ground Pin 20 to the chassis. I thought Pin 20 was ground. So, now I have pin 20 grounded to the chassis. I have the black wire and the solid blue (ground) from the rca jack to Pin 20. So, they all should be grounded in theory? I did that and still not seeing the camera in reverse. I put the Voltmeter on Pin 11 and thought it would be around 6v when put in reverse, it is still showing 10.69 when in reverse.


https://ibb.co/kFPGwd

https://ibb.co/iZFpGd

Thanks,
Mike

Last edited by mikelisa0212; 07-05-2018 at 03:28 PM. Reason: aDDING PICS
mikelisa0212 is offline   Reply With Quote
Old 07-05-2018, 04:05 PM   #22
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default



2018 pin out for vehicles without the 5 pin camera harness
phd12v is offline   Reply With Quote
Old 07-05-2018, 04:39 PM   #23
mikelisa0212
Scooby Newbie
 
Member#: 487812
Join Date: Jun 2018
Chapter/Region: South East
Vehicle:
2016 WRX
BLUE

Default

Right, I have a 2016 wrx, but don't have the 5 pin harness, so using the 28 pin for everything. I guess I am confused by you saying to ground the black wire and pin 20. Looking at Pin 20 it says ground camera, so I thought Pin 20 was grounded. I have the black wire to Pin 20 and the RCA Ground going to Pin 20, both grounded? So, I grounded Pin 20 to the chassis. Maybe if you can answer below what goes to where. I have a volt meter to test also. Sorry I am not getting what you are saying.

Black Wire goes to ??
Blue/White Wire goes to ??
Blue/Red Wire goes to Pin ??

Reverse IN Wire goes to Pin ??

RCA Quick Connect

Ground(Solid Blue) goes to Pin ??
Positive(Blue/White) goes to Pin ??
mikelisa0212 is offline   Reply With Quote
Old 07-07-2018, 06:23 PM   #24
mikelisa0212
Scooby Newbie
 
Member#: 487812
Join Date: Jun 2018
Chapter/Region: South East
Vehicle:
2016 WRX
BLUE

Default

Ok, by trial and error, I know have the 12v to 6V part working when putting it in reverse. 12V going to Pin 2 and 6V going to Pin 11 (and black grounded).

My problem has to be with the RCA jack. I am still not getting a camera signal. I am assuming Pin 12 should be at 12v when put in reverse? It is showing 0. Does the ground from the RCA Jack need to be grounded to chassis or is pin 20 good enough. Any ideas how I can test it? I know the camera is still good, as I hook up stock and get picture. So close.

Thanks,
Mike
mikelisa0212 is offline   Reply With Quote
Old 07-09-2018, 09:22 AM   #25
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

video signal wont show 12v also check your PM....i sent you something
phd12v is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.