Welcome to the North American Subaru Impreza Owners Club Wednesday October 23, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-06-2017, 02:02 PM   #126
PizzaBoyX
Scooby Newbie
 
Member#: 474796
Join Date: Sep 2017
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2016 WRX
WRB

Default

Quote:
Originally Posted by Jesone View Post
So you recently was having my car tuned and while on the dyno a seal blew or a head. Black smoke came out of the exhaust (passenger side). So all mods were put back to stock and my question is will they be able to see that it was modded before from the ecu?? It has been flashed back to normal with AP V3 but did die trying to get it home. Which it was towed to my house. I知 trying to get info as to what to be aware of. I知 under 60k so the power train is covered but I知 sketchy on the ecu part... please advise!!!
first; this is in the wrong section.

second; yes they can tell as I believe the ignition count resets to 0 when you flash the ECU. It's also the first thing they will check being that it's an engine failure.

third; even if they somehow miss that it was flashed, any competent tech can tell when bolts are removed/replaced for the most common mods. they'll see the nicks from the socket, or if you put new ones on, they'll see that they're too new for the age of the car.

bring it in, and see what happens; don't offer anymore information than they ask you.
* Registered users of the site do not see these ads.
PizzaBoyX is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-07-2017, 08:23 AM   #127
RobM
Scooby Newbie
 
Member#: 177056
Join Date: Apr 2008
Location: Alberta, Canada
Vehicle:
2015 WRX - CVT
2009 Forester XT

Default

Or you can pretend to be responsible, and own up to what you did.
RobM is offline   Reply With Quote
Old 12-09-2017, 11:48 AM   #128
Knotsure
Scooby Specialist
 
Member#: 41730
Join Date: Aug 2003
Location: Jersey
Vehicle:
1415 Legacy/Forester
D.Grey/White

Default

Quote:
Originally Posted by Jesone View Post
So you recently was having my car tuned and while on the dyno a seal blew or a head. Black smoke came out of the exhaust (passenger side). So all mods were put back to stock and my question is will they be able to see that it was modded before from the ecu?? It has been flashed back to normal with AP V3 but did die trying to get it home. Which it was towed to my house. I知 trying to get info as to what to be aware of. I知 under 60k so the power train is covered but I知 sketchy on the ecu part... please advise!!!


Not 都ketchy on the ECU part. Just SKETCHY
Knotsure is offline   Reply With Quote
Old 12-29-2017, 12:00 AM   #129
Alexisti
Scooby Newbie
 
Member#: 469528
Join Date: Jun 2017
Default

I have this problem with my sti 2011, the light you see in the picture is show up for couple minute or I can turn off the car and turn back on and the light stay off so I dont why they turn on randomly or what can cause the problem
Alexisti is offline   Reply With Quote
Old 01-01-2018, 09:13 AM   #130
Charlie-III
Scooby Guru
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: USA, North NJ, 07456
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper BK, 5MT

Default

Quote:
Originally Posted by Alexisti View Post
I have this problem with my sti 2011, the light you see in the picture is show up for couple minute or I can turn off the car and turn back on and the light stay off so I dont why they turn on randomly or what can cause the problem?
Wrong thread, should be in electrical since you don't appear to have a warranty denial.
Charlie-III is offline   Reply With Quote
Old 01-01-2018, 11:05 PM   #131
Alexisti
Scooby Newbie
 
Member#: 469528
Join Date: Jun 2017
Default

Quote:
Originally Posted by Charlie-III View Post
Wrong thread, should be in electrical since you don't appear to have a warranty denial.
Thanks
Alexisti is offline   Reply With Quote
Old 09-04-2018, 09:23 PM   #132
Optimus_Cr1m35
Scooby Newbie
 
Member#: 488180
Join Date: Jul 2018
Location: Phoenix, AZ
Vehicle:
2017 WRX
WR Blue

Default

Name: Josh

Make: 2017 Subaru WRX

Mileage:18000

Time Out Of Use:5 days

Problem And Likely Cause:AC compressor failure, no cause given

Modifications:All cosmetic at this point, Nameless Axle Back.

Submitted For Warranty Work (Yes/No):Yes

Reason Given For Denial:None

Your Story: Bought the car in July. About 2 weeks ago, the AC stopped getting cold. Cooled intermittently. Scheduled service, dropped it off Friday. I asked for a loaner if the repairs were going to take a while. Service manager walked out, started it, ran the AC, said "You're getting a loaner".

Since it was the Friday before a holiday, they couldn't order anything until today. I'm expecting the car back on Thursday/Friday.

They gave me no issue at all with the warranty. Said "Don't worry about it, it's all covered. Now try to sell your wife this new Outback when you get home..."

The last Dealer I spoke to wasn't so decent. Seemed pretty shady. Talked about co-pays, tried to get me to trade in a car I just bought, etc. And I was just picking up clips I ordered from SOA.
Optimus_Cr1m35 is offline   Reply With Quote
Old 09-19-2018, 05:48 AM   #133
FlySense88
Scooby Newbie
 
Member#: 327665
Join Date: Jul 2012
Default

Name: Ty

Make: 2019 Subaru STI limited

Mileage: 269

Time Out Of Use: 6 days and counting

Problem And Likely Cause: presumed to be a fried ECM, no cause given

Modifications: Tints

Submitted For Warranty Work (Yes/No):Yes

Reason Given For Denial: Appeared to be tampered with, ECM doesn't fry on it own

Your Story: I get in my car (after letting it sit for 6 days), and attempt to go to work. I noticed all the lights on the dash are on, blinking, and something isn't right. I turn it off, thinking it needed to be reset, I unplug the battery, and the car hasn't cut back on since. I get it towed to the dealer. They said its a hole in the firewall grommet, and 3 copper strands in the fuse box under the hood. The dealer say it appears as the car's electrical systems have been tampered with, there for it will not be covered. I am blown.
FlySense88 is offline   Reply With Quote
Old 09-20-2018, 05:23 PM   #134
vlad11591
Scooby Specialist
 
Member#: 295970
Join Date: Sep 2011
Chapter/Region: Tri-State
Location: Hamilton, NJ
Vehicle:
2019 STI
CWP

Default

That's ridiculous.

I would go to another dealership or try SOA.
vlad11591 is online now   Reply With Quote
Old 01-14-2019, 02:25 PM   #135
zaggy07
Scooby Newbie
 
Member#: 420235
Join Date: May 2015
Location: Albany, NY
Vehicle:
2015 WRX
WR Blue

Default Had to Replace BCM

Quote:
Originally Posted by JRim View Post
Yes, it is common for LED bulbs to damage BCMs. Not just on Subarus either. Google it. Subaru put it out in a TechTips newsletter to look out for BCM failures related to aftermarket LED bulb installations. Doesn't seem like a big deal but it is and the repair is not cheap.
Subaru needs to start using LEDs or warn customers about doing this. I had to replace my BCM after installing LEDs (interior, trunk and license plate lights). It was so easy finding replacement LEDs on a variety of websites but no warnings about the damage it can cause.
zaggy07 is offline   Reply With Quote
Old 09-16-2019, 04:54 PM   #136
bizzlezx10r
Scooby Newbie
 
Member#: 439586
Join Date: Feb 2016
Chapter/Region: MWSOC
Location: Omaha, NE
Vehicle:
2015 WRX
ISM

Default

Quote:
Originally Posted by FlySense88 View Post
Name: Ty

Make: 2019 Subaru STI limited

Mileage: 269

Time Out Of Use: 6 days and counting

Problem And Likely Cause: presumed to be a fried ECM, no cause given

Modifications: Tints

Submitted For Warranty Work (Yes/No):Yes

Reason Given For Denial: Appeared to be tampered with, ECM doesn't fry on it own

Your Story: I get in my car (after letting it sit for 6 days), and attempt to go to work. I noticed all the lights on the dash are on, blinking, and something isn't right. I turn it off, thinking it needed to be reset, I unplug the battery, and the car hasn't cut back on since. I get it towed to the dealer. They said its a hole in the firewall grommet, and 3 copper strands in the fuse box under the hood. The dealer say it appears as the car's electrical systems have been tampered with, there for it will not be covered. I am blown.
Did you ever get this resolved??
bizzlezx10r is offline   Reply With Quote
Old 09-16-2019, 08:05 PM   #137
fishfangs
Scooby Newbie
 
Member#: 425438
Join Date: Jul 2015
Chapter/Region: BAIC
Vehicle:
2015 WRX
ISM

Default

Quote:
Originally Posted by bizzlezx10r View Post
Did you ever get this resolved??
I would guess paid out of pocket for the repairs. Other thread poster has up noted that they had run cabling for aftermarket stereo equipment:

https://forums.nasioc.com/forums/sho....php?t=2884747
fishfangs is online now   Reply With Quote
Old 09-17-2019, 09:35 AM   #138
bizzlezx10r
Scooby Newbie
 
Member#: 439586
Join Date: Feb 2016
Chapter/Region: MWSOC
Location: Omaha, NE
Vehicle:
2015 WRX
ISM

Default

Quote:
Originally Posted by fishfangs View Post
I would guess paid out of pocket for the repairs. Other thread poster has up noted that they had run cabling for aftermarket stereo equipment:

https://forums.nasioc.com/forums/sho....php?t=2884747
Great find
bizzlezx10r is offline   Reply With Quote
Old 09-17-2019, 09:14 PM   #139
ascho078
Scooby Newbie
 
Member#: 466144
Join Date: Apr 2017
Chapter/Region: E. Canada
Location: Near Ottawa, Canada
Vehicle:
2017 WRX
White

Default Engine Wiring Harness

Name: Adam

Make: 2017 WRX 6MT

Mileage: 40,385miles (65,000km)

Time Out Of Use: 1 month, and counting

Problem And Likely Cause: 24020AG430 wiring harness failed between connectors E3 and E158, failed while vehicle in operation. immobilizer freaked out, forced car out of gear and stall after stopped.

Modifications: fluids

Submitted For Warranty Work (Yes/No): Yes

Reason Given For Denial: past 60,000km warranty, Subaru Canada doesn't consider the engine wiring harness as part of the 100,000km power-train warranty. refuses to admit the wiring harness is defective, and refuses to cover it under good will warranty.

Your Story: Driving to a job one day and the car slowly starts revving up but i'm slowly going slower (was in neutral), so I put the car in neutral, and then back into gear but it still revved without doing anything. I was going around 80 km/h, and had to pull off into a exit lane into a line of traffic. I was thinking to myself it might have been the clutch (no reason other than symptoms) the car stalled, I tried putting it into neutral and starting it again, it started and stalled out of idle immediately. tried once more and put it into neutral, and pushed it across 3 lanes and onto a less busy side road. got it towed.

problem is the wiring harness failed, the diagnostic code is B1578, no continuity between connectors E3 and E158. the new part number is different than the installed part, it was "superseded", and the new part has a technical service bulletin regarding water ingress caused failure. The dealership told me I'd need to replace the high pressure fuel lines if they needed to be removed, because they aren't reusable. (I don't understand why the Assenmacher AH8028 fuel line disconnect exists then). I ordered the new part (24020AG431) from another country (USA) at a significant discount (from a Subaru dealership), and I'm not sure if I'll have the dealership do it (at 2.5-3 hours shop labour) or do it myself with a friend (over-qualified, but not used to working on a Subaru). I've never done a engine wiring harness in a Subaru flat engine, and from inspection there is a LOT of a insulating foam between the block and the intake manifold on the drivers side and the wiring harness is smack dab under it.

I've got some time before the part comes in, once I get the repair done i'm definitely going to be keeping the old harness and checking that out.
ascho078 is offline   Reply With Quote
Old 10-11-2019, 08:39 PM   #140
dsldog
Scooby Newbie
 
Member#: 507305
Join Date: Oct 2019
Default

Quote:
Originally Posted by North Ursalia View Post
I had a discussion with Nick a few weeks back, and in an effort to consolidate the troubles people are having with their cars, which will in turn make the issues more apparent and/or harder to ignore (not to mention making this forum neater ) we decided to make sticky threads where people can report their troubles and/or denied warranty stories by problem area, much akin to my http://www.deniedmywarranty.org website, only with a much larger audience. SOA knows about I-Club.com and Deniedmywarranty.org, but the lack of coordination of trouble reports here on I-club (of course it's going to happen... a 'net forum is a stream-of-consciousness kind of thing) and the lack of the sheer number of them on the Deniedmywarranty.org site makes the actual impact far less than what it could be. We decided to utilize these stickied threads to organize and emphasize what is going wrong. I want to emphasize that these threads are not solely for Impreza WRX owners, nor just Impreza owners. We want to hear from everyone in these threads who is having issues. You can use these stickied threads to report warranty denials or simply to say that something's broken that you didn't submit for warranty repair. To keep these threads neat, there will be a standard format used, as found below (I will place an example reply below this post):



Name:

Make:

Mileage:

Time Out Of Use:

Problem And Likely Cause:

Modifications:

Submitted For Warranty Work (Yes/No):

Reason Given For Denial:

Your Story:



Replies deviating from this format will be deleted, no questions asked... sorry, but this has to remain neat and easy to read to be effective. In addition, please do not use this as a chance to bitch about a dealership or SOA- keep it professional and to-the-point, and this will help us all out in the long run .


Brian
http://www.northursalia.com
http://www.imprezamods.com
http://www.scoobymods.com
http://www.deniedmywarranty.org
Name: dsldog

Make: subaru legacy turbo wagon 2005

Mileage: 125k

Time Out Of Use: months

Problem And Likely Cause: ECU failure known recall

Modifications: none

Submitted For Warranty Work (Yes/No): no

Reason Given For Denial: none

Your Story: I'd like a thread please, I want to drag the responses I am getting from SOA into the light of day and publicly embarrass them here and in other venues. Please help by letting me have a thread.
dsldog is offline   Reply With Quote
Old 10-11-2019, 08:40 PM   #141
dsldog
Scooby Newbie
 
Member#: 507305
Join Date: Oct 2019
Post

Quote:
Originally Posted by North Ursalia View Post
I had a discussion with Nick a few weeks back, and in an effort to consolidate the troubles people are having with their cars, which will in turn make the issues more apparent and/or harder to ignore (not to mention making this forum neater ) we decided to make sticky threads where people can report their troubles and/or denied warranty stories by problem area, much akin to my http://www.deniedmywarranty.org website, only with a much larger audience. SOA knows about I-Club.com and Deniedmywarranty.org, but the lack of coordination of trouble reports here on I-club (of course it's going to happen... a 'net forum is a stream-of-consciousness kind of thing) and the lack of the sheer number of them on the Deniedmywarranty.org site makes the actual impact far less than what it could be. We decided to utilize these stickied threads to organize and emphasize what is going wrong. I want to emphasize that these threads are not solely for Impreza WRX owners, nor just Impreza owners. We want to hear from everyone in these threads who is having issues. You can use these stickied threads to report warranty denials or simply to say that something's broken that you didn't submit for warranty repair. To keep these threads neat, there will be a standard format used, as found below (I will place an example reply below this post):



Name:

Make:

Mileage:

Time Out Of Use:

Problem And Likely Cause:

Modifications:

Submitted For Warranty Work (Yes/No):

Reason Given For Denial:

Your Story:



Replies deviating from this format will be deleted, no questions asked... sorry, but this has to remain neat and easy to read to be effective. In addition, please do not use this as a chance to bitch about a dealership or SOA- keep it professional and to-the-point, and this will help us all out in the long run .


Brian
http://www.northursalia.com
http://www.imprezamods.com
http://www.scoobymods.com
http://www.deniedmywarranty.org
Name: dsldog

Make: subaru legacy turbo wagon 2005

Mileage: 125k

Time Out Of Use: months

Problem And Likely Cause: ECU failure known recall

Modifications: none

Submitted For Warranty Work (Yes/No): no

Reason Given For Denial: none

Your Story: I'd like a thread please, I want to drag the responses I am getting from SOA into the light of day and publicly embarrass them here and in other venues. Please help by letting me have a thread.
dsldog is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble/Warranty Denial Report Thread: Drivetrain (Engine, Tranny, Diff, Etc.) North Ursalia Warranty Issues & SOA Problems 3164 Today 04:22 PM
Trouble/Warranty Denial Report Thread: Suspension North Ursalia Warranty Issues & SOA Problems 58 10-19-2019 04:03 PM
Trouble/Warranty Denial Report Thread: Braking System North Ursalia Warranty Issues & SOA Problems 97 09-27-2019 12:46 PM
Trouble/Warranty Denial Report Thread: Body/Exterior of Vehicle North Ursalia Warranty Issues & SOA Problems 146 03-02-2019 12:31 PM
Trouble/Warranty Denial Report Thread: Interior North Ursalia Warranty Issues & SOA Problems 71 11-14-2018 08:18 AM

All times are GMT -4. The time now is 04:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.