Welcome to the North American Subaru Impreza Owners Club Monday January 20, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Water/Methanol Injection, Nitrous & Intercooler Cooling

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-02-2009, 11:52 AM   #2551
Aquamist
NASIOC Manufacturer
 
Member#: 110029
Join Date: Mar 2006
Location: Sussex, England
Vehicle:
2004 Citroen Picasso
Silver

Default

Quote:
Originally Posted by Slimsti View Post
I have the new HFS-6 kit and every 3 or 4 days while driving ill stop at a light and i hear a VERY loud repeated clicking noise coming from behind my guages.AFter further inspection it seem the black box mounted against the firewall is clicking.Even after i stop the car,turn off the ignition and turn the key to accessory it starts click again. Any ideas? After sitting overnight though the problem disappears.
Can you check where the +12V (red) and ground (white and black) is connected to. I am referring the the 4-way molex connector. Make certain they are all firmly terminated and bolted down respectively.

Did you install the system yourself?

Richard
* Registered users of the site do not see these ads.
Aquamist is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-02-2009, 11:55 AM   #2552
Aquamist
NASIOC Manufacturer
 
Member#: 110029
Join Date: Mar 2006
Location: Sussex, England
Vehicle:
2004 Citroen Picasso
Silver

Default

Quote:
Originally Posted by LittleBlueGT View Post
My buddy just decided to get the HFS-6 (looks like I was finally a positive influence on him!), what I need is the wiring schematics of an 09 WRX.

(injector negative, MAP wire, but even a positive ignition wire, and a headlamp switch would be nice too!)
Does anyone have the ECU pinout for the 09wrx? If so, I would be grateful if you can email them to me [email protected] Thanks in advance.



LittleBlueGT,

Thanks very much for your constant support for the aquamist product

Richard
Aquamist is offline   Reply With Quote
Old 12-03-2009, 12:49 PM   #2553
LittleBlueGT
Scooby Specialist
 
Member#: 96204
Join Date: Sep 2005
Chapter/Region: W. Canada
Location: Winnipeg
Vehicle:
2013 STI GR
White

Default

Quote:
Originally Posted by Aquamist View Post
Does anyone have the ECU pinout for the 09wrx? If so, I would be grateful if you can email them to me [email protected] Thanks in advance.



LittleBlueGT,

Thanks very much for your constant support for the aquamist product

Richard

I will always support good manufacturers that come up with the best products!
LittleBlueGT is offline   Reply With Quote
Old 12-03-2009, 01:12 PM   #2554
Edo Performance
Former Vendor
 
Member#: 70537
Join Date: Sep 2004
Chapter/Region: SCIC
Location: Huntington Beach, CA
Default

Hey Richard, sent you a message

Hey Guys, we have this system HSF 6 in stock and please call us if you need to inquire about this product

regards,
Edwin
Edo Performance is offline   Reply With Quote
Old 12-10-2009, 05:35 PM   #2555
underpowerd
Scooby Newbie
 
Member#: 118442
Join Date: Jun 2006
Location: CC, MD
Vehicle:
05 LGT+PE1818+HFS6
OBP

Default

Quote:
Originally Posted by LittleBlueGT View Post
I will always support good manufacturers that come up with the best products!
+1, not to mention outstanding customer support -- Richard, thanks again for the help with the fittings, you are the tops

I need a .9 nozzle/4mm; could you please direct me to the quickest way could I buy one?

thanks in advance.
underpowerd is offline   Reply With Quote
Old 12-10-2009, 05:54 PM   #2556
IA Performance
Former Vendor
 
Member#: 25194
Join Date: Sep 2002
Chapter/Region: RMIC
Location: Boulder, CO
Vehicle:
2008 Forester XT 5mt
Dark Gray

Default

I agree with everyone else, Aquamists customer service to Customers as well as Dealers is top notch!

We have 0.9mm/4mm hose jets ready to ship. $21.95 + $6.50 ship (assuming Maryland). We can have 1 in your hands early next week. More information available here:
http://www.iaperformance.com/product...oducts_id=2173



Please let us know how else to help.
[email protected]
Aquamist Dealer
IA Performance is offline   Reply With Quote
Old 12-11-2009, 08:18 PM   #2557
666stars
NASIOC Supporter
 
Member#: 221364
Join Date: Aug 2009
Chapter/Region: MAIC
Location: Baltimore
Vehicle:
2002 Wrx EJ207 Ver 8
Wrb Dccd jdm 6 speed now!

Default

Quote:
Originally Posted by underpowerd View Post
+1, not to mention outstanding customer support -- Richard, thanks again for the help with the fittings, you are the tops

I need a .9 nozzle/4mm; could you please direct me to the quickest way could I buy one?

thanks in advance.
i have one. let me know
666stars is offline   Reply With Quote
Old 12-14-2009, 09:13 AM   #2558
triniscoob
Scooby Specialist
 
Member#: 143225
Join Date: Mar 2007
Location: The Caribbean
Vehicle:
2004 JDM Sti
WRB

Default

quick question, imn plannign to mount the pump behind the front bumper for the HSF-5 kit- does ti make a difference if i mount the pump vertically or horizontally?

if i would like to mount it Vertically which side should face upwards?- The side of the pump with the Motor or the side with the inlet and outlets for the hoses?

Thanks!
triniscoob is offline   Reply With Quote
Old 12-14-2009, 09:37 PM   #2559
Aquamist
NASIOC Manufacturer
 
Member#: 110029
Join Date: Mar 2006
Location: Sussex, England
Vehicle:
2004 Citroen Picasso
Silver

Default

Quote:
Originally Posted by triniscoob View Post
quick question, imn plannign to mount the pump behind the front bumper for the HSF-5 kit- does ti make a difference if i mount the pump vertically or horizontally?

if i would like to mount it Vertically which side should face upwards?- The side of the pump with the Motor or the side with the inlet and outlets for the hoses?

Thanks!

The pump can run in all orientations. We normally ask user to install it vertically, pump head down. (motor on the top).
Aquamist is offline   Reply With Quote
Old 12-14-2009, 10:08 PM   #2560
Aquamist
NASIOC Manufacturer
 
Member#: 110029
Join Date: Mar 2006
Location: Sussex, England
Vehicle:
2004 Citroen Picasso
Silver

Default

Quote:
Originally Posted by underpowerd View Post
+1, not to mention outstanding customer support -- Richard, thanks again for the help with the fittings, you are the tops

I need a .9 nozzle/4mm; could you please direct me to the quickest way could I buy one?

thanks in advance.
Did you managed to get your jet? Many thanks for your support.
Aquamist is offline   Reply With Quote
Old 12-14-2009, 11:42 PM   #2561
Murphdog
Scooby Specialist
 
Member#: 75414
Join Date: Nov 2004
Chapter/Region: RMIC
Location: Rock Springs,Wyoming
Vehicle:
2004 STi
Its the Blue one

Default

I have the HSF-6. I started to do my prechecks. When I try to simulate 100% injection I hear the pump turn on and the flow control module clicks but no spray. I removed the large in line off the flow module and tried it and it is pumping out fluid. The first time I tried a small amount filled the out line but no spray. Is there anything I missed.
Murphdog is offline   Reply With Quote
Old 12-15-2009, 06:13 AM   #2562
Aquamist
NASIOC Manufacturer
 
Member#: 110029
Join Date: Mar 2006
Location: Sussex, England
Vehicle:
2004 Citroen Picasso
Silver

Default

Quote:
Originally Posted by Murphdog View Post
I have the HSF-6. I started to do my prechecks. When I try to simulate 100% injection I hear the pump turn on and the flow control module clicks but no spray. I removed the large in line off the flow module and tried it and it is pumping out fluid. The first time I tried a small amount filled the out line but no spray. Is there anything I missed.
Can you remove the small line (4mm) off the FCM and tell me if the liquid is coming out. (remove the inline restrictor first)

Richard
Aquamist is offline   Reply With Quote
Old 12-15-2009, 12:14 PM   #2563
Murphdog
Scooby Specialist
 
Member#: 75414
Join Date: Nov 2004
Chapter/Region: RMIC
Location: Rock Springs,Wyoming
Vehicle:
2004 STi
Its the Blue one

Default

I'll will check later today. When I first started to prime it the small line filled with fluid for a second than nothing. I tried putting a little vacume to the small out line but it seems like it is closed off.
Murphdog is offline   Reply With Quote
Old 12-15-2009, 12:48 PM   #2564
Aquamist
NASIOC Manufacturer
 
Member#: 110029
Join Date: Mar 2006
Location: Sussex, England
Vehicle:
2004 Citroen Picasso
Silver

Default

pm me your phone number so that we can do the test together, might help.

Richard
Aquamist is offline   Reply With Quote
Old 12-15-2009, 01:02 PM   #2565
AkumaMotorsports
Former Vendor
 
Member#: 214570
Join Date: Jun 2009
Chapter/Region: Tri-State
Location: NJ/SLC
Vehicle:
2008

Default

Bump for hands down the best meth injection unit on the market! The guys and girls over at Aquamist is top notch, we've been working closely with them to develop the meth kits for the Nissan R35 GT-R's. We have nothing but excellent things about them!

Cheers!
-Alex
AkumaMotorsports is offline   Reply With Quote
Old 12-15-2009, 06:10 PM   #2566
Murphdog
Scooby Specialist
 
Member#: 75414
Join Date: Nov 2004
Chapter/Region: RMIC
Location: Rock Springs,Wyoming
Vehicle:
2004 STi
Its the Blue one

Default

Figured it out. I had the restrictor in backwards. I'm an idiot. Thanks again for the help. This is why Aquamist is the best; amazing product and beyond top notch customer service. Richard I hope you get paid well. You deserve it.
Murphdog is offline   Reply With Quote
Old 12-18-2009, 05:30 PM   #2567
Aquamist
NASIOC Manufacturer
 
Member#: 110029
Join Date: Mar 2006
Location: Sussex, England
Vehicle:
2004 Citroen Picasso
Silver

Default

Alex, welcome. Thanks for the ECU information for the R35 - without it, I would not be able to work on the kit.
Aquamist is offline   Reply With Quote
Old 12-21-2009, 01:42 PM   #2568
dailo13
Scooby Newbie
 
Member#: 39083
Join Date: Jun 2003
Location: Diamond Bar, CA
Vehicle:
2002 Impreza WRX
Black

Default

Hi Richard,

If you answered this question before, I'm apologize, but I didn't want to search through 105 pages of this thread since the search function didn't really give me an answer.

I'm trying to import my US 02 WRX to Taiwan as I miss my car dearly. Over here, on top of smog and noise tests, there is a gas mileage test. In my current state of tune with a Cobb Protune of a 2.5l (EJ255) longblock and pink STi injectors (560cc?), I average about 22mpg(US) or about 9.3km/liter. The local guidebook states that my car has to run at least 10.5km/liter or about 25mpg(US). My question is, I understand you have a product that will allow injection starting from idle all the way up to full boost. The car will be tested on a dyno running very conservatively. I checked and the test will only run the car at low to mid rpm only up to 90kmph, so doubtful it will see a large amount of boost. Do you see any way for your product, given the right tuner and amount of time, allow me to gain an extra 3mpg(US) from injecting starting at idle on a very economical tune? This seems to be the only stumbling block preventing me from legally importing my car over here. I thank you in advance for any advice you can give.
dailo13 is offline   Reply With Quote
Old 12-22-2009, 04:51 AM   #2569
Aquamist
NASIOC Manufacturer
 
Member#: 110029
Join Date: Mar 2006
Location: Sussex, England
Vehicle:
2004 Citroen Picasso
Silver

Default

There are other simplier methods you can consider before using water injection.
- Using higher octane fuel
- You can run leaner AFR outside the boost range (Cobb)

The above methods will get you there.

Or you can use the Aquamist to get you there without standard octane pump fuel. There is no problem covering the range from idle to full boost. Knock resistance and advanced timing is the one of the way forward.
Aquamist is offline   Reply With Quote
Old 12-22-2009, 10:03 AM   #2570
dailo13
Scooby Newbie
 
Member#: 39083
Join Date: Jun 2003
Location: Diamond Bar, CA
Vehicle:
2002 Impreza WRX
Black

Default

Thanks for your response, Richard. I was hoping that an aquamist controller will help me keep the car running safely as I lean out the AFR for more mpg all the while being off of boost. I will once again be united with my car. Thanks, again!
dailo13 is offline   Reply With Quote
Old 01-04-2010, 03:46 PM   #2571
Hyper
Scooby Guru
 
Member#: 15822
Join Date: Feb 2002
Location: MOCKBA
Vehicle:
1999 WRB GM6
2.34 LR destroker

Default

hm..
with my system rewired, and FIA disconnected I get the warning orange light bleep dim time to time under load
is there a shortage somewhere?
Hyper is offline   Reply With Quote
Old 01-04-2010, 04:04 PM   #2572
Aquamist
NASIOC Manufacturer
 
Member#: 110029
Join Date: Mar 2006
Location: Sussex, England
Vehicle:
2004 Citroen Picasso
Silver

Default

Can you remind me your system details and setup... saving me looking up old mails.
Aquamist is offline   Reply With Quote
Old 01-04-2010, 04:16 PM   #2573
Hyper
Scooby Guru
 
Member#: 15822
Join Date: Feb 2002
Location: MOCKBA
Vehicle:
1999 WRB GM6
2.34 LR destroker

Default

oh sure, my bad

2d system w/optionary accumulator

engine bay mounted, boost failsafe connected

from the main 40A relay red goes straight to battery, black to ground, purple goes inside the cabin and hooks up to switched 12v source

the whole system is currently disconnected, which is what surprised me
pump is off (through aux button I hooked up), FIA2 is disconnected, MPS is not connected to a boost source

I assume it might be feeding off injector pulse or boost controller since it only lights up under load

odd)
Hyper is offline   Reply With Quote
Old 01-04-2010, 04:47 PM   #2574
Aquamist
NASIOC Manufacturer
 
Member#: 110029
Join Date: Mar 2006
Location: Sussex, England
Vehicle:
2004 Citroen Picasso
Silver

Default

Thanks for the reminder.

The 2d sytem will not without the FIA2. The 2d has under gone many electronic/mechanical updates, with know the exact version, the yellow LED is responsible to indicate low tank level?

The please check the wire that goes to the water level sensor is not grounded.

Richard
Aquamist is offline   Reply With Quote
Old 01-04-2010, 05:17 PM   #2575
Hyper
Scooby Guru
 
Member#: 15822
Join Date: Feb 2002
Location: MOCKBA
Vehicle:
1999 WRB GM6
2.34 LR destroker

Default

I don't have the low tank level hooked up yet, only boost cutting when failsafe is enabled

I can check the exact version if you tell me how I believe it's the older generation with the wiring harness that doesn't have a pre out for tank low level
Hyper is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Passing the NEW required OBDII Emissions test in PA Questions and Answers!! mrtrex Mid Atlantic Impreza Club -- MAIC 29 03-10-2013 08:23 PM
Snow Performance questions and answers... Ultimate Collision Center Water/Methanol Injection, Nitrous & Intercooler Cooling 374 09-23-2008 05:36 PM
Motörhead Guidlines, questions and answers here: GO LEMMY!! El Camino Off-Topic 9 01-20-2006 03:39 PM
Roll Center, questions and answers Arnie Brakes, Steering & Suspension 5 12-21-2004 04:26 PM

All times are GMT -4. The time now is 07:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.