Welcome to the North American Subaru Impreza Owners Club Monday May 10, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-10-2021, 06:36 PM   #1
LakixPompa
Scooby Newbie
 
Member#: 521740
Join Date: Jan 2021
Default Can anyone help me indenting these wires ? 04 WRX

The 1 black wire comes up from the dash I知 not sure what it should be connected to.
https://ibb.co/GTbhJV6

These two wires blue/black and black are come from the floor underneath the seat, I also found a connector (the white on on the pic) that has been connected to something underneath the seat , and it had no wires, I assume it could be these two wires , whereas which wire should go into what hole of the plug. (I have a airbag light on my dash, could it be from this ? ) Apologies for the mess, I知 working on fixing the carpets but noticed these wires underneath the seat that don稚 connect to anything

https://ibb.co/yYTmqyS
* Registered users of the site do not see these ads.
LakixPompa is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-10-2021, 11:47 PM   #2
AliBenn
Scooby Guru
 
Member#: 487
Join Date: Nov 1999
Chapter/Region: TXIC
Location: Greatwood/Sgrlnd
Vehicle:
1998 /2005 STunIcorn
Acadia Green RS-T

Default

Dang
Those wire so thin I would guess speaker wires
AliBenn is offline   Reply With Quote
Old 04-11-2021, 01:26 AM   #3
LakixPompa
Scooby Newbie
 
Member#: 521740
Join Date: Jan 2021
Default

Speaker wires form underneath the driver seat ? It痴 super weird because the connector I showed (white) was plugged in , but the wires were missing , I assumed that these wires were for it, but now I知 even more confused ***128514;***128514;. Any idea about the black wire from the dash . Appreciate you for taking your time to respond .
LakixPompa is offline   Reply With Quote
Old 04-11-2021, 03:52 AM   #4
Diavolo_
Scooby Newbie
 
Member#: 522840
Join Date: Mar 2021
Location: California
Default

Did you strip them back that far? or just find them like that?
do you have a volt meter?

I would bet that black wire from the dash is a ground wire someone added for something that isnt there anymore. gauge pod maybe? On the other end theres probably just a screw through the body on the other side of that kick panel. Did you see where the wire goes?
Looks like its headed to a common spot to ground something, and black is a typical ground wire color.

The other wires under the seat could be for a factory subwoofer. I couldnt find a picture of a harness to confirm colors but a picture of a factory sub looks like that clip could go right in. Usually an under seat factory sub attaches with a bracket to a seat rail on the the drivers seat, on the rail closest to the center console. does it look like there used to be something there? maybe an impression in the carpet or a mark from a bolt on the rail?

Maybe someone who didnt know what they were doing tried to wire into an audio signal there and chopped off the plug.
Regardless it looks like a speaker harness plug. do the doors have aftermarket speakers in them?

Airbag wiring will all be yellow or pink. I think in Subarus its all yellow. It will be very bright and obvious and separated from other wires. Therefore I do not think that blue/black wire under the seat has anything to do with your airbag light being illuminated on the dash.

Last edited by Diavolo_; 04-11-2021 at 04:09 AM.
Diavolo_ is offline   Reply With Quote
Old 04-11-2021, 11:33 AM   #5
LakixPompa
Scooby Newbie
 
Member#: 521740
Join Date: Jan 2021
Default

Thank you so much for this information, I値l double check underneath the seat if there used to be something there. I found the wires broken off (stripped only a little bit) and then I decided to strip them. I wonder what is causing my airbag light to be on then .
LakixPompa is offline   Reply With Quote
Old 04-11-2021, 03:47 PM   #6
Diavolo_
Scooby Newbie
 
Member#: 522840
Join Date: Mar 2021
Location: California
Default

Quote:
Originally Posted by LakixPompa View Post
Thank you so much for this information, I'll double check underneath the seat if there used to be something there. I found the wires broken off (stripped only a little bit) and then I decided to strip them. I wonder what is causing my airbag light to be on then .
in my 05 Legacy the air bag light came on and i had to re-solder a connection up by the rear view mirror to fix it.
so it could be something strange like that in your car too.

lucky for me someone on the Legacy forum knew about that problem, because even trained mechanics might not have known about that. some people spent a lot of money and time and frustration chasing down those problems. fortunately it took me about an hour of time and a little blob of solder.
coincidentally the problem for me occurred right after i had replaced my heater core, so I had taken the dash out and stuff, and was worried i had left one of the airbags unhooked or something, but nope. it was a solder joint.

just be careful not to set your airbags off if you go poking around while the battery is hooked up. theres sensors that if you unmount and turn over the airbags will think the cars in a roll over and they will deploy.

if you have a similar problem, and a similar overhead console check this out:
https://legacygt.com/forums/showthre...149073p13.html
Diavolo_ is offline   Reply With Quote
Old 04-11-2021, 08:06 PM   #7
AliBenn
Scooby Guru
 
Member#: 487
Join Date: Nov 1999
Chapter/Region: TXIC
Location: Greatwood/Sgrlnd
Vehicle:
1998 /2005 STunIcorn
Acadia Green RS-T

Default

All airbag harnesses are wrapped in a yellow sheath by every manufacturer in US
Those are not airbag wires

Could have 2 separate issues
Guessing the seat mounted airbag yellow pigtail is not connected
Any way you can turn on radio, jump in back seat and make sure your hear sound from both rear speakers?
AliBenn is offline   Reply With Quote
Old 04-12-2021, 03:13 PM   #8
LakixPompa
Scooby Newbie
 
Member#: 521740
Join Date: Jan 2021
Default

I checked today, turned on the radio went to the back, and the sound coming out of the rear door speakers, so that's fine I assume, (the wires that were under the seat still disconnected) also, the airbag wires under the seat are connected (yellow wrapped wires), I took off the airbag from the steering wheel and the airbag was also connected, I'm so lost rn. I don't know why i still have the airbag light on... Is there a way to check exactly what it could be? With romraider or something IDK. I have a digiprog 3 and ,xtool x100 scanner, and that doesn't really tell me anything.
LakixPompa is offline   Reply With Quote
Old 04-13-2021, 04:27 PM   #9
Diavolo_
Scooby Newbie
 
Member#: 522840
Join Date: Mar 2021
Location: California
Default

Did you see my post about the over head console and the airbag light?
i put a link above. maybe thats your problem.

also, its an airbag fault light? or is it telling you your passenger airbag is off because no one is in the seat?
Diavolo_ is offline   Reply With Quote
Old 04-13-2021, 05:13 PM   #10
snow_bound26
Scooby Specialist
 
Member#: 395793
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: SLC and Lake Placid
Vehicle:
2005 92x Aero
Beige

Default

Does your horn work? If the clock spring is broken then it typically trigger the airbag light and the horn won't work.
snow_bound26 is offline   Reply With Quote
Old 04-13-2021, 11:46 PM   #11
LakixPompa
Scooby Newbie
 
Member#: 521740
Join Date: Jan 2021
Default

Quote:
Originally Posted by Diavolo_ View Post
Did you see my post about the over head console and the airbag light?
i put a link above. maybe thats your problem.

also, its an airbag fault light? or is it telling you your passenger airbag is off because no one is in the seat?
I have checked, and I do not have a overhead console, since its a 04 wrx, I don't think they come with that, at least mine doesnt.
LakixPompa is offline   Reply With Quote
Old 04-13-2021, 11:48 PM   #12
LakixPompa
Scooby Newbie
 
Member#: 521740
Join Date: Jan 2021
Default

Yes, my horn works just fine. I'm so confused now. Everything is plugged in except the two wires underneath the seat which I shared the photo, and the airbag light is still on...
LakixPompa is offline   Reply With Quote
Old 04-13-2021, 11:58 PM   #13
Diavolo_
Scooby Newbie
 
Member#: 522840
Join Date: Mar 2021
Location: California
Default

edit:
the blue/black wires under the seat have NOTHING to do with the airbag light, because you can see the yellow airbag wires under the seat correct? and its plugged in?


Quote:
Originally Posted by LakixPompa View Post
I have checked, and I do not have a overhead console, since its a 04 wrx, I don't think they come with that, at least mine doesnt.
you dont have map lights?
P/N 84621AE020NEG

I tried to look at a pic of what might be in your car, it doesnt seem like it has a circuit board in it, like the Legacy's from around the same time period does.
however its probably a similar problem with some corroded or broken solder joint somewhere.

Grab the yellow connectors under the seats, and squeeze the two sides of the connectors toward each other.

then report back

Last edited by Diavolo_; 04-14-2021 at 12:10 AM.
Diavolo_ is offline   Reply With Quote
Old 04-14-2021, 12:09 AM   #14
Diavolo_
Scooby Newbie
 
Member#: 522840
Join Date: Mar 2021
Location: California
Default

Quote:
Originally Posted by LakixPompa View Post
I don't know why i still have the airbag light on... Is there a way to check exactly what it could be?
im not 100% certain but the airbag module is different than the ECU. the dealer can connect to it, or theres some other sort of scanner thing you need. i think it flashes a certain amount of times to indicate where the problem is.
probably just easier /cheaper to call a shop on that instead of buying a device you're not likely to use again and might not be qualified to.

Last edited by Diavolo_; 04-14-2021 at 12:09 AM. Reason: typos
Diavolo_ is offline   Reply With Quote
Old 04-14-2021, 12:57 PM   #15
LakixPompa
Scooby Newbie
 
Member#: 521740
Join Date: Jan 2021
Default

Quote:
Originally Posted by Diavolo_ View Post
edit:
the blue/black wires under the seat have NOTHING to do with the airbag light, because you can see the yellow airbag wires under the seat correct? and its plugged in?



you dont have map lights?
P/N 84621AE020NEG

I tried to look at a pic of what might be in your car, it doesnt seem like it has a circuit board in it, like the Legacy's from around the same time period does.
however its probably a similar problem with some corroded or broken solder joint somewhere.

Grab the yellow connectors under the seats, and squeeze the two sides of the connectors toward each other.

then report back

Will do , thank you so much , I値l let you guys know as soon as I do it
LakixPompa is offline   Reply With Quote
Old 04-17-2021, 12:49 AM   #16
Diavolo_
Scooby Newbie
 
Member#: 522840
Join Date: Mar 2021
Location: California
Default

did that work?
Diavolo_ is offline   Reply With Quote
Old 04-18-2021, 02:08 AM   #17
LakixPompa
Scooby Newbie
 
Member#: 521740
Join Date: Jan 2021
Default

Nope , still on
LakixPompa is offline   Reply With Quote
Old 04-18-2021, 02:40 PM   #18
AliBenn
Scooby Guru
 
Member#: 487
Join Date: Nov 1999
Chapter/Region: TXIC
Location: Greatwood/Sgrlnd
Vehicle:
1998 /2005 STunIcorn
Acadia Green RS-T

Default

Your probably going to have the airbag code read
Tip a tech to hook up to his $2000 code reader
Or
Take to dealership and pay $200+ just to read
Smaller shops are cheaper and easier to deal with BTW

Possible as easy as a front seat buckle
AliBenn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 06:41 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.