Welcome to the North American Subaru Impreza Owners Club Sunday January 26, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-13-2010, 03:54 PM   #26
OrbitalEllipses
Scooby Guru
 
Member#: 178811
Join Date: Apr 2008
Chapter/Region: MAIC
Location: MoCo
Vehicle:
2011 White Corolla
Over 400hp

Default

I think the pill is the same per turbo; I know for sure WG spring pressure is different year to year as stock max PSI is different year to year.

As has previously been stated I would just go for a new EBCS or MBC, stock BCS is crap anyway.
* Registered users of the site do not see these ads.
OrbitalEllipses is online now   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-13-2010, 04:09 PM   #27
Jerembo47
Scooby Newbie
 
Member#: 249219
Join Date: Jun 2010
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
2007 WRX TR
World Rally Blue

Default

Quote:
Originally Posted by While At Rome View Post
well thanks for jacking my thread. Jer;embo go read up so u know what parts are supposed to be there


I am missing the restrictor pill in my inlet-to-T vac line. is there a part no i can get from autozone or do i need to get that from the dealer??? If that doesnt fix it, new boost control it will be.

There are a few yards around here, is the vac line/pill the same for 02-05, or even more cars?

Thanks, Bill


Sorry didnt mean to jack your thread but your post related to my problem.
Jerembo47 is offline   Reply With Quote
Old 06-14-2010, 01:39 PM   #28
While At Rome
Scooby Newbie
 
Member#: 247550
Join Date: May 2010
Chapter/Region: RMIC
Location: Salt Lake
Vehicle:
09 STI

Default

ok im going to pick up an MBC today. hopefully that fixes it.

Another important question... If i DC the OE boost controller and use say a turbo xs mbc, do i need a re-tune, even if i run it at 13.5 psi?
While At Rome is offline   Reply With Quote
Old 06-14-2010, 03:15 PM   #29
XanRules
Scooby Guru
 
Member#: 157348
Join Date: Aug 2007
Location: Hell and Jail
Vehicle:
180+ IQ Genius
Mindset Lifestyle

Default

Quote:
Originally Posted by While At Rome View Post
ok im going to pick up an MBC today. hopefully that fixes it.

Another important question... If i DC the OE boost controller and use say a turbo xs mbc, do i need a re-tune, even if i run it at 13.5 psi?
yes. Definitely yes.
XanRules is offline   Reply With Quote
Old 06-14-2010, 05:33 PM   #30
While At Rome
Scooby Newbie
 
Member#: 247550
Join Date: May 2010
Chapter/Region: RMIC
Location: Salt Lake
Vehicle:
09 STI

Default

Quote:
Originally Posted by XanRules View Post
yes. Definitely yes.
are you sure?

after researching, im pretty sure that i will be fine running 13.5 or 13 with an 02. I bought the Perrin MBC.
While At Rome is offline   Reply With Quote
Old 06-14-2010, 05:37 PM   #31
Chi_San
Scooby Guru
 
Member#: 53558
Join Date: Jan 2004
Chapter/Region: NWIC
Location: Deadford, OR
Vehicle:
2005 Baja Turbo
White/Silver/Black 3tone

Default

it'll throw a code, and go into limp mode. On top of that, MBC behaves totally differently than an EBC, so get tuned.
Chi_San is offline   Reply With Quote
Old 06-14-2010, 06:59 PM   #32
snobordboi
Scooby Newbie
 
Member#: 149130
Join Date: May 2007
Location: Denver
Vehicle:
2002 WRX,
2010 X5M

Default

On top of that, since there was obviously some type of boost control system on there before, it may (hopefully) have been tuned for it, and is only safe right now since you arent building much boost. I would get the boost control situation sorted, and get it tuned as quickly as you can, and don't hit high boost levels until tuned.
snobordboi is offline   Reply With Quote
Old 06-15-2010, 01:59 AM   #33
samneumann
Scooby Newbie
 
Member#: 245075
Join Date: Apr 2010
Default

I am having the exact same problem, i just put in a boost gauge and it reads im only boostin like 6 to 7lbs also. Im pretty sure im not leaking boost, and my BCS is good. what is this pill that needed for vaccum hoses?
samneumann is offline   Reply With Quote
Old 06-15-2010, 02:19 AM   #34
XanRules
Scooby Guru
 
Member#: 157348
Join Date: Aug 2007
Location: Hell and Jail
Vehicle:
180+ IQ Genius
Mindset Lifestyle

Default

Quote:
Originally Posted by samneumann View Post
I am having the exact same problem, i just put in a boost gauge and it reads im only boostin like 6 to 7lbs also. Im pretty sure im not leaking boost, and my BCS is good. what is this pill that needed for vaccum hoses?
start your own thread, please.
XanRules is offline   Reply With Quote
Old 06-15-2010, 02:46 AM   #35
Jeffman44
Scooby Newbie
 
Member#: 239072
Join Date: Feb 2010
Chapter/Region: RMIC
Location: Castle Rock, CO
Vehicle:
2005 WRX Wagon
white

Default

Quote:
Originally Posted by While At Rome View Post
are you sure?

after researching, im pretty sure that i will be fine running 13.5 or 13 with an 02. I bought the Perrin MBC.
research "partial throttle, full boost" or PTFB. It is a condition created by manual boost controllers. the EBCS won't let you hit full boost unless you are on the throttle hard.

running a manual boost controller will give you a lean condition while not WOT causing risk to your engine.
Jeffman44 is offline   Reply With Quote
Old 06-15-2010, 12:22 PM   #36
While At Rome
Scooby Newbie
 
Member#: 247550
Join Date: May 2010
Chapter/Region: RMIC
Location: Salt Lake
Vehicle:
09 STI

Default

Im thinking about getting it tuned. What tuning options are out there?

i got an up-pipe and an MBC right now. Im not trying to go anything more than 15 psi as this is my daily driver. it may lead to an exhaust and an FMIC, but that is to be decided.
While At Rome is offline   Reply With Quote
Old 06-15-2010, 12:25 PM   #37
WhyHelloOfficer
Scooby Specialist
 
Member#: 193989
Join Date: Nov 2008
Chapter/Region: South East
Location: Tampa, Fl
Vehicle:
2007 Stormy Blue
Blown Roadster

Default

Quote:
Originally Posted by XanRules View Post
start your own thread, please.
So we can have 3 threads on the first page of the 2.0 Tech Boards that say "I too, am only hitting 7psi?"

Quote:
Originally Posted by While At Rome View Post
Im thinking about getting it tuned. What tuning options are out there?

i got an up-pipe and an MBC right now. Im not trying to go anything more than 15 psi as this is my daily driver. it may lead to an exhaust and an FMIC, but that is to be decided.
You, need to do a lot more reading. FAQs are your friend.
http://forums.nasioc.com/forums/show....php?t=1169980
WhyHelloOfficer is offline   Reply With Quote
Old 06-15-2010, 12:57 PM   #38
While At Rome
Scooby Newbie
 
Member#: 247550
Join Date: May 2010
Chapter/Region: RMIC
Location: Salt Lake
Vehicle:
09 STI

Default

Quote:
Originally Posted by WhyHelloOfficer View Post
So we can have 3 threads on the first page of the 2.0 Tech Boards that say "I too, am only hitting 7psi?"


You, need to do a lot more reading. FAQs are your friend.
http://forums.nasioc.com/forums/show....php?t=1169980

ive read almost all of that before i even bought my car, and then read it again to try and figure out wtf is going on.

If you read it, it simply says "talk to your tuner for best options" for about every single mod and fuel management question.

I know im hitting wg pressure, my EBCS is not working, but electrical tests that i did according to the shop manual says that it is, or should be. And every single thing says ECM failure. This leads me to believe that the ECU is tuned, and coverted back to stock in a half ass way. I pulled off the kickplate on the passenger side and the ECU clips look like they had been removed a few times.
While At Rome is offline   Reply With Quote
Old 06-16-2010, 02:49 AM   #39
While At Rome
Scooby Newbie
 
Member#: 247550
Join Date: May 2010
Chapter/Region: RMIC
Location: Salt Lake
Vehicle:
09 STI

Default

regardless wtf ends up being the source of this ****, im goin down to cobb tomorrow and talking to them about accessport. MBC and a tune will be more fun no matter what.
While At Rome is offline   Reply With Quote
Old 12-06-2014, 11:14 PM   #40
huezo_e
Scooby Newbie
 
Member#: 408009
Join Date: Dec 2014
Location: Everett
Default

Was the problem fixed?
If so what was the fix?
huezo_e is offline   Reply With Quote
Old 12-08-2019, 02:57 PM   #41
Rljs
Scooby Newbie
 
Member#: 476120
Join Date: Oct 2017
Vehicle:
2000 RHD JDM Bugeye
Blue

Default

I know this is an old thread but I was searching through here while trying to figure out why my car would boost maybe once or twice and the be limited to wastegate pressure for the rest of that drive or even a week at a time. I determined my maf sensor was shot so if all your other tests from above check out look into it. As I did the bcs and it was fine. If you need rock auto sells maf that are cheaper just to test if it fixes your problems.
Rljs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stage 2 WRX Only Puts Down 214 hp? Is This True? Turbo20VJetta Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 11 11-02-2005 09:38 PM
alternator only putting out 12.4 volts yellowscooby New England Impreza Club Forum -- NESIC 1 06-06-2005 03:27 PM
Only 7 PSI boost with STi Tanman Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 18 12-03-2004 12:26 PM
How Many CFM's of air does the stock WRX turbo put out? BrysImpreza Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 09-02-2002 07:55 PM
Help! My WRX is Only Putting Out .5 bar (7psi) of Boost clsmooth71 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 04-01-2002 10:49 AM

All times are GMT -4. The time now is 02:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.