Welcome to the North American Subaru Impreza Owners Club Monday October 15, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old Yesterday, 04:11 PM   #1
D9ZZ
Scooby Newbie
 
Member#: 365848
Join Date: Aug 2013
Location: Alaska
Vehicle:
12 Legacy gt
White

Default Clutch squeak brake moves when clutch

2014 sti hatch 60,000 ish miles
Stage 2 dual friction clutch installed 15k ago
Iíve read a bunch.
Pulled cowl and welds seem fine.
Brake pedal moves to left slightly when depressing clutch.
If you release clutch slow I get a horrible squeak in the accelerator pedal area.
Canít feel bracket moving at firewall and welds seem secure.
Clutch transfer rod doesnít appear broken.
Bushings worn out?
I have an its brace here but if I need to replace pedal assembly might as well do it all at once.
Any ideas?
* Registered users of the site do not see these ads.
D9ZZ is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old Yesterday, 04:30 PM   #2
D9ZZ
Scooby Newbie
 
Member#: 365848
Join Date: Aug 2013
Location: Alaska
Vehicle:
12 Legacy gt
White

Default

Squeak eliminated
Was the pushrod sliding through grommet. A spray of tri-flow and that is gone.
Brake pedal moves to left 1/4Ē or so when pressing clutch pedal
Never paid attention before noise started.
Is that much movement normal?
D9ZZ is offline   Reply With Quote
Old Yesterday, 04:31 PM   #3
D9ZZ
Scooby Newbie
 
Member#: 365848
Join Date: Aug 2013
Location: Alaska
Vehicle:
12 Legacy gt
White

Default

Squeak eliminated
Was the pushrod sliding through grommet. A spray of tri-flow and that is gone.
Brake pedal moves to left 1/4Ē or so when pressing clutch pedal
Never paid attention before noise started.
Is that much movement normal?
D9ZZ is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.